Remote Desktop will not connect

I am trying to remote desktop a computer located one floor below me. I have enabled remote desktop on both machines that I am using, as well as allowed exceptions in firewall (not that it matters, since I have turned both firewalls off -- both computer I am using and machine I am attempting to reach). I can 'see' the machine on the network and can ping it by both name and IP, but it will not connect.

At first failed attempt, I used netsh commands to reset the firewall and re-set the settings, but this too will not work. I have also tried updating Windows to ensure that it is not a security patch issue, but no luck there.

If anyone has any ideas, they would be appreciated.
SUNYESFAsked:
Who is Participating?
 
MikeKaneConnect With a Mentor Commented:
If your telnet to that port gives you an error on connection, then that port is not open.    If you can ping, then ICMP is fine and your routing is fine, but there has to be something blocking that port, or the RDP is not ready to receive inbound connections.    

Can you connect to any other service on that machine?   How about a scan on open ports to see what is available?
0
 
MikeKaneCommented:
Are you erroring out on the connection attempt or perhaps on the authentication attempt?

You should be able to telnet to the IP on port 3389.    You should see blinking cursor in the upper left,  you cant do anything, but this will tell you if you are connected to the port at the very least.   That way you can eliminate network communications....
0
 
SUNYESFAuthor Commented:
Yeah, telnet yields an error with no connection.
0
 
SUNYESFAuthor Commented:
When I use netstat -a to see what's listening, there are no ports listed above 1890 or so.
I have also tried adjusting the port used by RD in the registry, but that is not listened to either.
0
 
MikeKaneCommented:
Go and grab nmap and the gui front end, Zenmap.    It's a must have tool for any admin.....IMHO
  http://nmap.org/download.html

Run a scan against the server's ip and you should get an entry similiar to this:

Discovered open port 3389/tcp on xxx.xxx.xxx.xxx  

That tells you that your test PC can 'see' port 3389 (this is default) open on the remote server.   If you don't get this response, then you PC is blocked from that port, or the RDP is not turned on properly.     Or maybe its hosed.... you can also reset the rdp like this:
1. Open System control panel
2. Select Remote tab
3. Un-tick Remote Desktop to disable (default)
3. Goto 'Select Remote Users' and clear out all users listed.

You should now be at default.
1. Once Remote Desktop is enabled, it should start the 'Terminal Services' service.
2. Access it via Firewall, allow Remote Desktop in its properties.
3. Add users to the 'Remote Desktop users' group on the server.

0
All Courses

From novice to tech pro — start learning today.