Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 265
  • Last Modified:

Page could not be displayed after logging into OWA 2007

I was trying to fix the following error that kept showing up in our Exchange 2007 server

Source:  MSExchangeTransport

Category:  TransportService

Event ID:  12014

Microsoft Exchange couldn't find a certificate that contains the domain name mail.mydomain.net in the personal store on the local computer. Therefore, it is unable to offer the STARTTLS SMTP verb for any connector with a FQDN parameter of mail.fcc-inc.net. Verify the connector configuration and the installed certificates to make sure that there is a certificate with a domain name for every connector FQDN.

so i followed these instructions to try and fix it
_____________________________________________________________________________
I solved the problem today like this;
1. On the "Exchange Management Shell" I wrote "Get-ExchangeCertificate"  command..
there are many thumbprints of cretificates (Wrongly I created many certificates before)
I looked to correct thumbprint from OWA certicate from Internet explorer...
2. After that on the shelll I wrote  "Enable-ExchangeCertificate -Thumbprint 3afd24627925332cd096f45eb5b4473c72526112 -Services "SMTP"    *(These thumbprint numbers ar sample)

After that all errors are cancelled... I'm getting correct information from TLS

____________________________________________________________________________

and now when i log into OWA i get the login screen but when after I enter the credential it takes me to a page could not be displayed.  The GoDaddy certificate is installed in IIS and SSL is enabled.  

Any ideas what could be causing this?
0
shanna1017
Asked:
shanna1017
  • 3
  • 2
1 Solution
 
ParanormasticCryptographic EngineerCommented:
My first two guesses are:
1) Restart WWW service on OWA.  Many times this helps when messing around with the certs.
2) Clear client SSL cache - in Internet Options - Content tab - Clear SSL State button.  Close all browsers and try again.

Beyond that, could you be more descriptive of the error you are receiving?
0
 
shanna1017Author Commented:
i tried restarting WWW and clearing my client's SSL cashe and I still receive an HTTP 400 page could not be displayed after I enter my credentials at the OWA page.
0
 
ParanormasticCryptographic EngineerCommented:
The godaddy cert isn't a wildcard (*.domain.com) is it?  If so, these do not work very well with OWA, you might want to look into a regular cert or possibly a UCC (multi-domain) cert instead.
Also in your client you might want to check the advanced tab in internet options and enable TLS and if you have a proxy check enable http 1.1 through proxy connections.
Given the error message, I don't think this will do it, but you can try anyways between user name formats of domain\username and username@domain.com.
0
 
shanna1017Author Commented:
I'm an idiot...i should've tried this on multiple machines before i assumed it was an issue.  It works on other machines so it must just be my machine.  

It was just odd that it worked on my machine before i made the change and then it stopped working immediately afterwards.  

Sorry to waste your time.  have some points for your effort.
0
 
ParanormasticCryptographic EngineerCommented:
Thanks for the points.  Glad things are working better for you - that's the main thing.  Maybe a reboot of the problem client might help?  Otherwise take a look at your browser settings.
0

Featured Post

Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now