Outlook 2007 prompting for username and password

I have a user that is using outlook 2007.
Server is Exchange 2007.
Every time he launches outlook, it prompts for username and password.
I have recreated the outlook profile which had no effect on the problem and also changed authentication to NTLM with no joy.
I can hit cancel on the user prompt and continue using outlook but it keeps popping up over time.
LVL 10
mcrosslandAsked:
Who is Participating?
 
mcrosslandConnect With a Mentor Author Commented:
I contacted Microsoft on this issue and paid the 250.00.
Took them about 4 hours to figure it out.
Here was the resolution:
We were getting prompted once we open outlook and also when we were downloading the Off Line Address Book.
Once we moved the Offline Address Book to the new server we were no longer getting prompted for credentials when we tried to download the Offile Address Book.
But we were still getting prompted for credentials when we opened outlook.
Found that NTLM was falling and that as because Windows Authentication was disabled on EWS virtual directory under IIS 7.

0
 
codezpCommented:
2 things can cause this:

1. Exchange server by default asks for username and password each time you starts Outlook and this is a security feature in Exchange 2008 and cannot be turned off.

2. If its asking to ENTER NETWORK PASSWORD then its a different issue. You can find solution for this here  http://support.microsoft.com/?id=290684

Also check if you have any Addons in outlook as those will cause this as well (Spam Scanner, Auto Sig any of those)

Hope that helps.

0
 
TAMSCODANCommented:
you need to log on to the domain on wich your running exchange not just on the local machine.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell┬« is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
JMMLANCommented:
could also try to reset the WIndows password in AD then log out and back in
0
 
AaogCommented:
This is something I would like to get to the bottom of too.  I found a couple things that may help out.  
First, this article explains something that I haven't tried yet msyelf but seems to have saved a lot of people a lot of trouble: http://trycatch.be/blogs/pdtit/archive/2008/01/30/outlook-2007-autodiscover-authentication-popup-mistery.aspx

Second, this post on Experts Exchange is about the same thing:  http://www.experts-exchange.com/Software/Server_Software/Email_Servers/Exchange/Q_23509406.html

I'm going to try this out too since I'm having the same problem.  We'll figure it out.
0
 
mcrosslandAuthor Commented:
OK.  It's not the proxy setting.  I'm setting up a profile for this user on another system to see if the problem follows.
0
 
mcrosslandAuthor Commented:
I set up a brand new profile on a completely different system with Outlook 2K7 and it prompts for username and password.
0
 
TAMSCODANCommented:
is your computer on the domain? are you logging on to the domain?
0
 
mcrosslandAuthor Commented:
Yes, I'm logged into the domain and on the lan.
I was able to fix it on my test system by going into the proxy settings in the Outlook Account Setup (connections).
Under Microsoft Exchange Proxy Settings I did the following.
Change the "only connect to proxy servers that have this principle name in their certificates to the exact server dns name.  Here is an example.
Was like this: msstd:myserver.mydomain.com
I changed it to this:  myserver.mydomain.com

That fixed it on two systems.  I'm going to go test it on the original system right now.
0
 
mcrosslandAuthor Commented:
OK.  I've got more info on this.
I have confirmed that my fix above works only on windows Vista systems and NOT on XP Pro systems.
What the?
0
 
trivalentCommented:
The accepted solution solved my issue as well.   We are running Exchange 2007 / OWA w/ SSL / Outlook Anywhere and Outlook 2007 clients inside the LAN would get prompted for authentication to the mail server after opening Outlook.   Checking the Windows Authentication flag in the Security Settings for the EWS seemed to do the trick.  I also let the 'bin' sub inherit it.  

Thanks EE
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.