?
Solved

Outlook Web Access Calendar availability gets "You don't have permission to perform this action"

Posted on 2008-10-10
4
Medium Priority
?
1,968 Views
Last Modified: 2008-10-25
Have any of you seen this or have a solution for it. In OWA users are not able to see the availabiltiy of other users calendars or even their own for that matter. When you go in and create a new appointment then click the availability tab you get "you don't have permission to perform this action". I'm assuming this is some kind of IIS Permissions issue since there are absolutely no problems when any user uses their outlook client for scheduling appointments.
 
 Thanks in Advance
0
Comment
Question by:Colmanh
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
4 Comments
 
LVL 13

Expert Comment

by:ach_patil
ID: 22702053
Is the error occuring for all the users in your environment.

Try using the OWA Web Admin Tool and see if there are any permissions setting set on your Calendar
http://www.microsoft.com/downloads/details.aspx?familyid=4BBE7065-A04E-43CA-8220-859212411E10&displaylang=en
0
 

Author Comment

by:Colmanh
ID: 22704201
Although this is a great tool and very informative it does not have any focus on the Calendar and this is the only place that we are experiencing any issues. I appreciate your input but still need help in getting this issue resolved.

Thanks
0
 

Author Comment

by:Colmanh
ID: 22705377
Further Findings:
ok i've been digging into this a bit more and it seems the free/busy is part of the Public Folder structure so I've been looking at the permissions on that. Now the following is what is rather odd. If I logon to OWA and click on Public Folders I get a new window displaying the public folders just fine. I'll leave that window open and can continue to get to it as much as I want. Although as soon as I go back and check the availability  tab in a new appointment window the public folders then become a 403.4 - Forbidden error stating "The page must be viewed over a secure channel.

This is one a Front End Server with a certificate and the back end server does not have a cert and none of the require ssl options are selected.

Thanks
0
 

Accepted Solution

by:
Colmanh earned 0 total points
ID: 22761295
We've figured out that this was a problem with Replication from the top tier server where the Public Folder Hierarchy is stored. It was not being properly replicated down to the other servers. Once the replication was put in place everything started to work. The replication was created for the Free/Busy System folder.
0

Featured Post

Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Find out what you should include to make the best professional email signature for your organization.
After hours on line I found a solution which pointed to the inherited Active Directory permissions . You have to give/allow permissions to the "Exchange trusted subsystem" for the user in the Active Directory...
To show how to create a transport rule in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Mail Flow >> Rules tab.:  To cr…
how to add IIS SMTP to handle application/Scanner relays into office 365.
Suggested Courses

752 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question