Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Exchange tries sending mail to the wrong IP address periodically

Posted on 2008-10-10
10
Medium Priority
?
305 Views
Last Modified: 2013-11-30
I have an SBS 2003 server running Exchange. Periodically, when sending to a remote domain it fails with an NDR, usually no such recipient. Looking in the SMTP logs I've noted that when the emails go through successfully, the Exchange server is sending to the correct IP address. When the emails fails, the Exchange server is trying to send to a wrong address, which happens to be the same domains WWW record IP address, which happens to be running an SMTP server, but kicks it back as no such recipeint. The remote domain is running their own mail server, not hosting it.
0
Comment
Question by:msjesiel
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
10 Comments
 
LVL 4

Expert Comment

by:codezp
ID: 22689450
I would suggest your try clearing the DNS, the wrong IP might be cached and it sometime pulls it up if it tries using local instead of network.

hope that helps
0
 

Author Comment

by:msjesiel
ID: 22689550
That is one of the first things I did, flushed teh DNS cache on the server. This appears to be happening over several days time, longer than a likely TTL would be set at. I'm attaching two smtp logs for a successful mail delivery and a failed email delivery. They were sent an hour and a half apart or so.
0
 

Author Comment

by:msjesiel
ID: 22689558
Here are the log files for failed and success delivery. One and a half hours apart.
failed.txt
successful-sent-hour-earlier.txt
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 4

Expert Comment

by:codezp
ID: 22689726
Ok so they have both of those ips:

Pinging alderwoodwater.com [209.200.118.90] with 32 bytes of data:
Reply from 209.200.118.90: bytes=32 time=82ms TTL=113
Reply from 209.200.118.90: bytes=32 time=83ms TTL=113
Reply from 209.200.118.90: bytes=32 time=83ms TTL=113
Reply from 209.200.118.90: bytes=32 time=110ms TTL=113

C:\Users\Codez>ping smtp.alderwoodwater.com

Pinging smtp.alderwoodwater.com [74.94.76.97] with 32 bytes of data:
Reply from 74.94.76.97: bytes=32 time=109ms TTL=239
Reply from 74.94.76.97: bytes=32 time=111ms TTL=239
Reply from 74.94.76.97: bytes=32 time=110ms TTL=239
Reply from 74.94.76.97: bytes=32 time=110ms TTL=239



As you see 74.94.26.97 is their SMTP server and the other one is their web server. They are on seperate servers.

if I have to guess I would think either you have a wrong cache of it localy or their mx records are not setup properly.


0
 
LVL 4

Expert Comment

by:codezp
ID: 22689771
if you do a nslookup -q=mx domain.com from your Exchange, does DNS resolv this to a correct name and IP of the destination domain?

I suspect the problem can be caused if you have an unneeded SMTP Connector -- for example, if you have a single-site, single server topology but have an SMTP Connector installed. However, this is only a guess. At one location I removed the unneeded SMTP Connector among other changes and the problem went away. I never knew if removing the SMTP connector solved the issue or if something else resolved the issue.

Also tryDNS properties and under forwarders section check if "Do not use recursion for this domain" is disabled.
Under "Advanced" tab see "Disable recursion" option is disabled.

Restart the DNS server and try if emails goes through at one shot.

ALSO

In the properties for the SMTP Virtual Server, set the IP address to be an IP not the "All Unassigned" option and that may help.

Hope that helps!
0
 
LVL 4

Expert Comment

by:ckozloski
ID: 22690316
Make sure that you have a world MX record that is pointed to the proper IP address. If your MX record is also an alias of your web domain that could cause problems.
0
 

Author Comment

by:msjesiel
ID: 22690726
All great suggestions. I won't be able to try anything until after the weekend, so I'll get back to this on Monday. Thanks.
0
 

Author Comment

by:msjesiel
ID: 22716703
Changed the SMTP virtual server configuration to not use external DNS, which it was. Also made sure teh internal DNS server forwarders were set correctly. It's sporadic, so I'll let it go a couple days adn see if we have any more failures.
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 23645042
PAQed with points refunded (250)

Computer101
EE Admin
0

Featured Post

New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
How to deal with a specific error when using the Enable-RemoteMailbox cmdlet to create a mailbox in the cloud-based service, for an existing user in an on-premises Active Directory.
In this video we show how to create an Address List in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Organization >> Ad…
In this Micro Video tutorial you will learn the basics about Database Availability Groups and How to configure one using a live Exchange Server Environment. The video tutorial explains the basics of the Exchange server Database Availability grou…

661 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question