Solved

Exchange 2007 Prepareschema & PrepareAD Fails

Posted on 2008-10-10
40
6,867 Views
Last Modified: 2013-11-11
I have a single forest with two sub-domains. After running domainprep, forestprep, and gpprep, I started on the setup /PrepareLegacyExchangePermissions which went fine but got a few hiccups on setup /PrepareSchema and setup /PrepareAD.

Domain Structure...
                       Root.Domain.com
                       |                             |
             Child.domain.com         Child.domain.com

Schema Master is the same DC as Root.Domain.com. There is one exchange 2003 server in each child domain.

Error...

Exchange Server setup encountered an error.

Z:\E2K7ENT>setup /PrepareSchema /domaincontroller:anyroot.anypub.com

Welcome to Microsoft Exchange Server 2007 Unattended Setup

Preparing Exchange Setup

    Copying Setup Files              ......................... COMPLETED

No server roles will be installed

Performing Microsoft Exchange Server Prerequisite Check

    Organization Checks              ......................... FAILED
 The Active Directory schema will be upgraded if you continue. Verify that the o
rganization is ready for Exchange 2007 by running the Exchange 2007 Readiness Ch
eck, which is part of the Exchange Best Practices Analyzer.
 Cannot find the Recipient Update Service responsible for domain 'DC=ANYPUB,DC=com'.
New and existing users may not be properly Exchange-enabled.
 Setup needs to contact the Active Directory schema master but this computer
 is not in the same Active Directory domain as the schema master (DC=ANYPUBLIS
HING,DC=com).

     Setup encountered a problem while validating the state of Active Directory:
 The user-specified domain controller anyroot.ANYPUB.COM is not a dom
ain controller in the local domain.


The Exchange Server Setup operation did not complete. For more information, visi
t http://support.microsoft.com and enter the Error ID.

Exchange Server setup encountered an error.

AND........

Z:\E2K7ENT>setup /PrepareAD /domaincontroller:anyroot

Welcome to Microsoft Exchange Server 2007 Unattended Setup

Preparing Exchange Setup

    Copying Setup Files              ......................... COMPLETED

No server roles will be installed

Performing Microsoft Exchange Server Prerequisite Check

    Organization Checks              ......................... FAILED
 Cannot find the Recipient Update Service responsible for domain 'DC=ANYPUB,DC=com'.
New and existing users may not be properly Exchange-enabled.
 Setup needs to contact the Active Directory schema master but this computer
 is not in the same Active Directory domain as the schema master (DC=ANYPUB,DC=com).

     Setup encountered a problem while validating the state of Active Directory:
 The user-specified domain controller anyroot does not exist.


The Exchange Server Setup operation did not complete. For more information, visi
t http://support.microsoft.com and enter the Error ID.

Exchange Server setup encountered an error.

**The Server OS is Server 2008 ENT x64 w/Hyper-V & Exchange 2007 ENT x64**
0
Comment
Question by:llib21
  • 19
  • 14
  • 4
  • +1
40 Comments
 
LVL 2

Expert Comment

by:scottbortis
ID: 22689751
Did you allow time for replication?

have you tried it without the /domaincontroller switch?

Is this an upgrade from exchange X to exchange 2007?
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22689960
Setup needs to contact the Active Directory schema master but this computer is not in the same Active Directory domain as the schema master (DC=ANYPUBLISHING,DC=com).

*******Please transfer the schema master role to the domain from where you are running Exchange setup OR run Exchange prepare schema in the domain where Schema master role is configured.

 The user-specified domain controller anyroot does not exist.

*******You sure that your local DC is called anyroot ?? if you are please have the FQDN specified rather than anyroot.
0
 

Author Comment

by:llib21
ID: 22689971
I did the Forest & Domain Prep yesterday. I did the legacy permissions today. Replication time???

I have tried it without /domaincontroller switch, still the same error.

This is not a upgrade from Exchange 2003 to 2007. It's a fresh install on a new server running server 2008 but in the same domain as existing exchange 2003.
0
Optimizing Cloud Backup for Low Bandwidth

With cloud storage prices going down a growing number of SMBs start to use it for backup storage. Unfortunately, business data volume rarely fits the average Internet speed. This article provides an overview of main Internet speed challenges and reveals backup best practices.

 

Author Comment

by:llib21
ID: 22690159
Exchange Geek,

There is a schema master for anypub.com then there is a schema master for child.anypub.com. The existing exchange server is located under child.anypub.com but receives and replies as joe@anypub.com. I have tried both schema masters using FQDN and short names, neither seem to work.

Local DC: I have three DC's within child.anypub.com and I pointed install to shema master of this domain. I know which one is the master by looking at AD U&C, right and operation masters for local DC [SUS] that is master. If I go to AD Domain & Trusts, the DC is [anyroot].anypub.com.

Now, I have a choice under AD Domain & Trusts to change the operational Master to local DC [SUS] that belongs to child.anypub.com domain. I guess replication finished and now I can see the change could be made to [SUS]. Is this what I am suppose to do? And how is this going to reflect on the second Exchange server replacement on the second child domain?
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22690271
There is a schema master for anypub.com then there is a schema master for child.anypub.com. The existing exchange server is located under child.anypub.com but receives and replies as joe@anypub.com. I have tried both schema masters using FQDN and short names, neither seem to work.

******In the history of active directory never has there been two schema masters ever in same forest.
Run the command netdom query fsmo and it would tell you which DC the SM role holds.

Now, I have a choice under AD Domain & Trusts to change the operational Master to local DC

******Why are you working with AD Domain and Trust for operational Master - that is a role termed Domain Naming Master - why are you troubling that - it has nothing to do with this issue.

Please follow my earlier instruction and trust me Exchange 2007 installation isn't that a big deal.
0
 

Author Comment

by:llib21
ID: 22690332
Ok. Here is the query...

C:\WINDOWS>netdom query fsmo
Schema owner                anyroot.anypub.COM

Domain role owner           anyroot.anypub.COM

PDC role                    lnntfs.child1.anypub.COM

RID pool manager            lnntfs.child1.ANYPUB.COM

Infrastructure owner        lnntfs.child1.ANYPUB.COM

The command completed successfully.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22690369
That answers your query: there exists only one SM that resides on anyroot.anypub.COM
So, there aren't two versions of it

So, which domain are we running Exchange setup from ?

Simply run a command set L and post the info here please
0
 

Author Comment

by:llib21
ID: 22690532
The domain we are running the setup is under lnntfs.child1.anypub.com.

But what is command set L?
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22690576
That is where the chaos began

Schema Master is not in the domain where Exchange setup is being run
SM: anypub.COM
Your Domain: child1.anypub.com

So, bottom line is move the schema master to your local domain OR run the Exchange prepare schema in anypub.com

 
0
 

Author Comment

by:llib21
ID: 22690596
Lets move the schema master. What about replication time? Both are within the same LAN.
0
 

Author Comment

by:llib21
ID: 22690631
Stupid question? At what mmc do I move the schema master and at what level (i.e. anypub.com or child1.anypub.com).

Not too well versed with AD.
0
 
LVL 32

Expert Comment

by:gupnit
ID: 22690664
Well well well....Schema Master movement...why for God sake..!! See Schema Master can be in any Domain, you only need to make sure that Schema Master is contactable...
Schema just need preparation, can be done from any DC.
Also since you r installing Exchange 2007 in an exisiting Exchange 2003 (coexistence) make sure Legacy Prep is done properly
Cheers
Nitin
0
 
LVL 32

Expert Comment

by:gupnit
ID: 22690689
Make sure from which ever DC you are doing the prep work, your FMSO role holders are contactable by FQDN and your DNS is clear !! Check Event VIewer !!
Like Exchange_Geek said - 2007 install is not that diffcult....take a deep breath and cheer up. The positivity counts man
Cheers
Nitin
0
 
LVL 32

Expert Comment

by:gupnit
ID: 22690703
Replication was a valid comment from Exchange_geek ------ Dude you got to listen to him !!
0
 
LVL 32

Expert Comment

by:gupnit
ID: 22690709
I mean llib21 you got to listen to Exchange_Geek
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22690766
The reason why we are moving SM role is stated clear in link:

http://technet.microsoft.com/en-us/library/bb288907(EXCHG.80).aspx

"Setup /PrepareSchema or Setup /ps must be run from a server in the same Active Directory site and domain as the schema master. Typically, the schema master role will be on a domain controller in the first domain created in the forest."

Also, refer to the error:
"Setup needs to contact the Active Directory schema master but this computer
 is not in the same Active Directory domain as the schema master"

FYI......Exchage setup and SM are in different domains
0
 

Author Comment

by:llib21
ID: 22690772
Gupnit,
I did run the legacy commands. And, the username used to install is a member of local domain admin, enterprise admin, and schema admin.

I did ping the anyroot.anypub.com [schema master] from the "new" exchange box. The pings came back fine. I know this thing is suppose to be easy but still got these errors. per your and exchange geeks suggestions, i checked the event viewer and saw....nothing.

I am using a slice of Hyper V and connecting via virtual nic if that makes any difference. The internal DNS server is the Schema Master.

0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22690808
Ref Link:

Transfer the schema master role
http://technet.microsoft.com/en-us/library/cc759254.aspx


0
 

Author Comment

by:llib21
ID: 22690860
Thanx, i found that article too. I just changed it, Replication time is needed then will update post on what occurs afterwards. Should be 15 mins.

0
 

Author Comment

by:llib21
ID: 22690867
Sorry, I forgot to say Thank You and I change the FSMO to lnntfs.child1.anypub.com.

0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22690903
Wonderful job - now please run the prepare schema once more.
0
 

Author Comment

by:llib21
ID: 22690976
Alright, so full steam ahead after replication finished. I ran setup /ps /domaincontroller:lnntfs.child1.anypub.com. This worked fine and completed successfully.

Then tried running setup /p /on:lincoln                              
got this error...

Z:\E2K7ENT>setup /p /on:lincoln
Welcome to Microsoft Exchange Server 2007 Unattended Setup
Preparing Exchange Setup
    Copying Setup Files              ......................... COMPLETED
No server roles will be installed
 Exchange organization name cannot be specified. There already exists an Exchang
e organization with name 'Any Pub'.
Exchange Server setup encountered an error.

The organization name is correct. What might I be doing wrong here?
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22690987
/organizationName is given for new setup
0
 

Author Comment

by:llib21
ID: 22691011
Exchange Geek,

So I don't need to setup /organization Name? Or do I need to Specify a new name?

Also, running setup /PrepareAD /domaincontroller:lnntfs:child1.anypub.com ....which seems to be working properly. No successful message yet.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22691026
you do not require to use /organization name while running setup at the moment
0
 

Author Comment

by:llib21
ID: 22691091
Got an error.... tried running setup /p; setup /PrepareAD; setup /PrepareAD /domaincontroller:lnntfs.

Z:\E2K7ENT>setup /p
Welcome to Microsoft Exchange Server 2007 Unattended Setup
Preparing Exchange Setup
    Copying Setup Files              ......................... COMPLETED
No server roles will be installed
Performing Microsoft Exchange Server Prerequisite Check
    Organization Checks              ......................... COMPLETED
 Cannot find the Recipient Update Service responsible for domain 'DC=ANYPUB,DC=com'. New and existing users may not be properly Exchange-enabled.
Configuring Microsoft Exchange Server
    Organization Preparation         ......................... FAILED
     An error occurred. The error code was 3238218282. The message was Failed to
 contact Windows Domain Controller..
The Exchange Server Setup operation did not complete. For more information, visi
t http://support.microsoft.com and enter the Error ID.
Exchange Server setup encountered an error.
0
 

Author Comment

by:llib21
ID: 22694043
Exactly my point. In the E-Books I read overnite yesterday, there is no mention of errors let alone this type of error.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22694744
Please run ipconfig /all along with netdiag report - this seems more of an DNS problems - however too early to conclude
0
 

Author Comment

by:llib21
ID: 22698140
ipconfig /all info for the "new exchange server 2007" instance running on Hyper V instance.

Z:\E2K7ENT>ipconfig /all
Windows IP Configuration
   Host Name . . . . . . . . . . . . : LNEXC
   Primary Dns Suffix  . . . . . . . : CHILD1.ANYPUB.COM
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No
   DNS Suffix Search List. . . . . . : anypub.com
                                       child1.anypub.com
                                       child2.anypub.com
Ethernet adapter Local Area Connection:
   Connection-specific DNS Suffix  . : child1.anypub.com
   Description . . . . . . . . . . . : Microsoft VMBus Network Adapter
   Physical Address. . . . . . . . . : 00-15-5D-01-33-03
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv4 Address. . . . . . . . . . . : 191.100.0.153(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . : 191.100.0.1
   DNS Servers . . . . . . . . . . . : 191.100.0.31
                                       191.100.0.3
   NetBIOS over Tcpip. . . . . . . . : Enabled
Tunnel adapter Local Area Connection* 8:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : child1.anypub.com
   Description . . . . . . . . . . . : isatap.child1.anypub.com
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
Tunnel adapter Local Area Connection* 9:
   Connection-specific DNS Suffix  . : child1.anypub.com
   Description . . . . . . . . . . . : 6TO4 Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2002:bf64:99::bf64:99(Preferred)
   Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
   DNS Servers . . . . . . . . . . . : 191.100.0.31
                                       191.100.0.3
   NetBIOS over Tcpip. . . . . . . . : Disabled
Tunnel adapter Local Area Connection* 11:
   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 02-00-54-55-4E-01
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

I ran NetDiag on the Schema Master (lnntfs) because Server 2008 does not have netdiag tool. Info listed below.

C:\>netdiag
..............................................
    Computer Name: LNNTFS
    DNS Host Name: lnntfs.CHILD1.ANYPUB.COM
    System info : Microsoft Windows Server 2003 R2 (Build 3790)
    Processor : x86 Family 6 Model 15 Stepping 7, GenuineIntel
    List of installed hotfixes :
        KB924667-v2
        KB925398_WMP64
        KB925902
        KB927891
        KB929123
        KB930178
        KB931768-IE7
        KB931784
        KB932168
        KB933729
        KB933854
        KB935839
        KB935840
        KB936021
        KB936357
        KB936782
        KB938127-IE7
        KB938464
        KB941202
        KB941568
        KB941569
        KB941644
        KB941672
        KB941693
        KB942763
        KB943055
        KB943460
        KB943484
        KB943485
        KB944533-IE7
        KB944653
        KB945553
        KB946026
        KB947864-IE7
        KB948496
        KB948590
        KB948881
        KB949014
        KB950759-IE7
        KB950760
        KB950762
        KB950974
        KB951066
        KB951072-v2
        KB951698
        KB951746
        KB951748
        KB952954
        KB953838-IE7
        KB953839
        Q147222
Netcard queries test . . . . . . . : Passed
Per interface results:
    Adapter : Local Area Connection Monitor Port
        Netcard queries test . . . : Passed
        Host Name. . . . . . . . . : lnntfs.child1.anypub.com
        IP Address . . . . . . . . : 191.100.0.254
        Subnet Mask. . . . . . . . : 255.255.0.0
        Default Gateway. . . . . . : 191.100.0.1
        Primary WINS Server. . . . : 191.100.0.6
        Dns Servers. . . . . . . . : 191.100.0.31
                                     10.1.1.62
                                     191.100.0.3
        AutoConfiguration results. . . . . . : Passed
        Default gateway test . . . : Passed
        NetBT name test. . . . . . : Passed
        WINS service test. . . . . : Passed
    Adapter : LAN Monitor Port
        Netcard queries test . . . : Passed
        Host Name. . . . . . . . . : lnntfs
        IP Address . . . . . . . . : 191.100.1.31
        Subnet Mask. . . . . . . . : 255.255.0.0
        Default Gateway. . . . . . : 191.100.0.1
        Primary WINS Server. . . . : 191.100.0.6
        Dns Servers. . . . . . . . : 191.100.0.31
                                     191.100.0.3
                                     4.2.2.2
        AutoConfiguration results. . . . . . : Passed
        Default gateway test . . . : Passed
        NetBT name test. . . . . . : Passed
        [WARNING] At least one of the <00> 'WorkStation Service', <03> 'Messenge
r Service', <20> 'WINS' names is missing.
        WINS service test. . . . . : Passed

Global results:
Domain membership test . . . . . . : Passed
NetBT transports test. . . . . . . : Passed
    List of NetBt transports currently configured:
        NetBT_Tcpip_{D1CD563B-3534-4859-9531-9FCBAB4E0FAE}
        NetBT_Tcpip_{048F5045-830D-4DFC-8D6F-E8C9DE0CC16E}
    2 NetBt transports currently configured.
Autonet address test . . . . . . . : Passed
IP loopback ping test. . . . . . . : Passed
Default gateway test . . . . . . . : Passed
NetBT name test. . . . . . . . . . : Passed
Winsock test . . . . . . . . . . . : Passed
DNS test . . . . . . . . . . . . . : Passed
    PASS - All the DNS entries for DC are registered on DNS server '191.100.0.31
' and other DCs also have some of the names registered.
    PASS - All the DNS entries for DC are registered on DNS server '10.1.1.62' a
nd other DCs also have some of the names registered.
    PASS - All the DNS entries for DC are registered on DNS server '191.100.0.3'
 and other DCs also have some of the names registered.
    [WARNING] The DNS entries for this DC are not registered correctly on DNS se
rver '4.2.2.2'. Please wait for 30 minutes for DNS server replication.
Redir and Browser test . . . . . . : Passed
    List of NetBt transports currently bound to the Redir
        NetBT_Tcpip_{D1CD563B-3534-4859-9531-9FCBAB4E0FAE}
        NetBT_Tcpip_{048F5045-830D-4DFC-8D6F-E8C9DE0CC16E}
    The redir is bound to 2 NetBt transports.
    List of NetBt transports currently bound to the browser
        NetBT_Tcpip_{D1CD563B-3534-4859-9531-9FCBAB4E0FAE}
        NetBT_Tcpip_{048F5045-830D-4DFC-8D6F-E8C9DE0CC16E}
    The browser is bound to 2 NetBt transports.
DC discovery test. . . . . . . . . : Passed
DC list test . . . . . . . . . . . : Passed
Trust relationship test. . . . . . : Skipped
Kerberos test. . . . . . . . . . . : Passed
LDAP test. . . . . . . . . . . . . : Passed
Bindings test. . . . . . . . . . . : Passed
WAN configuration test . . . . . . : Skipped
    No active remote access connections.
Modem diagnostics test . . . . . . : Passed
IP Security test . . . . . . . . . : Skipped
    Note: run "netsh ipsec dynamic show /?" for more detailed information
The command completed successfully





I think that Exchange Server 2007 is not supported on Hpver V quite yet. I have not found much on it this topic. Most of the books refer to equipment as sole Exchange box but in my case it is a slice running on Hyper V.  I did check the DNS entries on 191.100.0.31 and both servers were automatically listed under child1.anypub.com and I created a A record on anypub.com. I even tried removing and re-adding the virtual network card on LNEXC Hyper V instance, didn't work.



0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22698237
I am not sure what logic this makes - however looking into old records - i consulted a few colleagues of mine who had informed me that they had solved one case by enabling WINS on the box where Exchange was being installed to solve this particular problem.

(Please do not catch my collar since i am myself wondering what is the co-relation but they did solve the case by enabling WINS)

Try it out. Mean while i am checking if some one else has faced this sort of issue.
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22698259
Oh and one more thing - you did mention that E2k7 on hyper-V - why not try to work with setup /prepareAD from a physical box - how about on a domain controller ??

It is always recommended (unofficially by MSFT) to work with all such setup commands from physical boxes rather than virtual environment.

So, firstly try the WINS and if that does not help you - try working with prepareAD commands from physical box - preferably a DC.
0
 

Author Comment

by:llib21
ID: 22698842
I have WINS setup on LNEXC, the virtual instance.

I tried running it on a Domain Controller but since all are 2003's, the error I received was the setup is a valid file but not meant for this computer.

I tried running it on physical box but got an error,

Description:
  Stopped working

Problem signature:
  Problem Event Name:      APPCRASH
  Application Name:      ExSetup.exe
  Application Version:      8.1.240.6
  Application Timestamp:      474b7502
  Fault Module Name:      KERNEL32.dll
  Fault Module Version:      6.0.6001.18000
  Fault Module Timestamp:      4791ada5
  Exception Code:      e0434f4d
  Exception Offset:      000000000002649d
  OS Version:      6.0.6001.2.1.0.274.10
  Locale ID:      1033


G:\E2K7ENT>setup /p

Welcome to Microsoft Exchange Server 2007 Unattended Setup

Preparing Exchange Setup

    Copying Setup Files              ......................... COMPLETED

Setup failed due to insufficient permissions.  Please make sure that the current
 user has local administrator permissions. Error: The source was not found, but
some or all event logs could not be searched.  Inaccessible logs: Security.
0
 

Author Comment

by:llib21
ID: 22699148
I figured out why I was getting the "Setup failed due to insufficient permissions" error and fixed it. The user i was logged in was schema admin, enterprise admin and domain admin of anypub.com but did not have "local domain admin" to child1.anypub.com. Once that was fixed, I received errors for Faxmaker EDK compatiblity issues and I uninstalled that program, rebooted exchange server. That error went away but received a new error, liste below.

Now, it's failing because the forestprep is still replicating. I don't know how long it will take to replicate.

Z:\E2K7ENT>setup /PrepareAD
Welcome to Microsoft Exchange Server 2007 Unattended Setup
Preparing Exchange Setup
    Copying Setup Files              ......................... COMPLETED
No server roles will be installed
Performing Microsoft Exchange Server Prerequisite Check
    Organization Checks              ......................... COMPLETED
 Cannot find the Recipient Update Service responsible for domain 'DC=ANYPUB,DC=com'. New and existing users may not be properly Exchange-enabled.
Configuring Microsoft Exchange Server
    Organization Preparation         ......................... FAILED
     PrepareDomain for domain CHILD1 has partially completed.  Because of your
Active Directory site configuration, you must wait for forest-wide replication t
o occur, and then run PrepareDomain for CHILD1 again.
The Exchange Server Setup operation did not complete. For more information, visi
t http://support.microsoft.com and enter the Error ID.
Exchange Server setup encountered an error.

0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22699754
"Because of your Active Directory site configuration, you must wait for forest-wide replication t
o occur, and then run PrepareDomain for CHILD1 again."

Either wait for another 2hrs or force replication using Active directory sites and service (for better results use replmon tool).

0
 

Author Comment

by:llib21
ID: 22700030
I know about forcing replication. The forest seems to be replicated but error still exists. I sent you an email, please check out the error and let me know (same error as above).


Thank You
0
 

Author Comment

by:llib21
ID: 22703471
I have tried to force replication. checked replmon and see all server replicating fine, up to date. Still I receive this error. can't seem to figure it out.

[10/12/2008 7:11:52 PM] [2] Added group CN=Exchange Install Domain Servers,CN=Microsoft Exchange System Objects,DC=CHILD1,DC=ANYPUB,DC=com to CN=Exchange Servers,OU=Microsoft Exchange Security Groups,DC=ANYPUB,DC=com on root.ANYPUB.COM. Link resolution server is ntfs.CHILD1.ANYPUB.COM.

[10/12/2008 7:11:52 PM] [2] [WARNING] Failed to add CN=Exchange Install Domain Servers,CN=Microsoft Exchange System Objects,DC=CHILD1,DC=ANYPUB,DC=com to CN=Exchange Servers,OU=Microsoft Exchange Security Groups,DC=ANYPUB,DC=com on ntfs.CHILD1.ANYPUB.COM, link resolution server is root.ANYPUB.COM, aborting the task.  Error is 00002141: SvcErr: DSID-031A0FC0, problem 5003 (WILL_NOT_PERFORM), data 0

[10/12/2008 7:11:52 PM] [2] [ERROR] PrepareDomain for domain CHILD1 has partially completed.  Because of your Active Directory site configuration, you must wait for forest-wide replication to occur, and then run PrepareDomain for CHILD1 again.
[10/12/2008 7:11:52 PM] [2] [ERROR] Active Directory operation failed on ntfs.CHILD1.ANYPUB.COM. This error is not retriable. Additional information: The specified group type is invalid.
0
 

Accepted Solution

by:
llib21 earned 0 total points
ID: 22705776
Ok, Exchange 2007 is finally installed.

1. The issue was schema master (ntfs) was not a GC and forest wide replication had finished but NTFS was never being notified.
2. Public Folder did not have "inherit permissions" box checked on existing Exchage 2003 boxes.

Once NTFS was made into a GC and inherit permission box was check on both of my exchange servers, the readiness test completed successfully. I re-ran setup /PreparelLgacyExchangePermissions, /PrepareSchema, and then /PrepareAD and /PrepareDomain:child1.anypub.com. This finished successfully.

I ran setup.exe and went through the setup, readiness check cleared away fine and installed the typical setup [Hyper V Guest does not support Unified Messsaging Role].
0
 
LVL 33

Expert Comment

by:Exchange_Geek
ID: 22708159
Wonderful........three cheers for llib21 - you definitely won't forget Exchange 2007 installation in near future.
LOL Take care buddy. And hey do post some interesting queries of this sort in future.

Cheeers !!!!
0

Featured Post

Does Powershell have you tied up in knots?

Managing Active Directory does not always have to be complicated.  If you are spending more time trying instead of doing, then it's time to look at something else. For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
Need to disable SSL Cipher 7 61
Exchange 2010 SP1 to SP3 + RU16 8 44
Exchange 2007 standard - defrag (eseutul /d) 10 40
Archive Office365 Email Account 2 17
Restoring deleted objects in Active Directory has been a standard feature in Active Directory for many years, yet some admins may not know what is available.
A procedure for exporting installed hotfix details of remote computers using powershell
This tutorial will walk an individual through setting the global and backup job media overwrite and protection periods in Backup Exec 2012. Log onto the Backup Exec Central Administration Server. Examine the services. If all or most of them are stop…
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…

770 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question