Solved

WSUS is not working!

Posted on 2008-10-10
4
1,739 Views
Last Modified: 2010-08-05
I am getting EVENTS 13032 and 13042, and none of my XP Pro machines are getting updates.  Can someone help?
I find it interesting that these below events were recorded the day that WSUS quit working.




WMI ADAP was unable to load the ASP.NET_2.0.50727 performance library because it returned invalid data: 0x0

WMI ADAP was unable to create the object Win32_PerfRawData_ASPNET_2050727_ASPNETAppsv2050727 for Performance Library ASP.NET_2.0.50727 because error 0x80041001 was returned

WMI ADAP was unable to create the object Win32_PerfRawData_ASPNET_2050727_ASPNETAppsv2050727 for Performance Library ASP.NET_2.0.50727 because error 0x80041001 was returned
The Open Procedure for service ".NETFramework" in DLL "C:\WINDOWS\system32\mscoree.dll" failed. Performance data for this service will not be available. The Status code returned is the first DWORD in the attached data.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


The Open Procedure for service "ASP" in DLL "C:\WINDOWS\system32\aspperf.dll" failed. Performance data for this service will not be available. The Status code returned is the first DWORD in the attached data.

Unable to locate the open procedure "??????????????#??" in DLL "C:\WINDOWS\system32\sqlctr90.dll" for the "MSSQL$MICROSOFT##SSEE" service. Performance data for this service will not be available. The Error Status is the first DWORD in the attached data.


Performance counter data collection from the "MSSQL$MICROSOFT##SSEE" service has been disabled due to one or more errors generated by the performance counter library for that service. The error(s) that forced this action have been written to the application event log. The error(s) should be corrected before the performance counters for this service are enabled again.
0
Comment
Question by:zachwideman
4 Comments
 
LVL 31

Expert Comment

by:Henrik Johansson
Comment Utility
0
 

Author Comment

by:zachwideman
Comment Utility
I just fixed this.  The SelfUpdate directory was missing from IIS.  I exported the selfupdate folder from another WSUS server at another location that was working fine.  I then, imported the .xml file into my IIS, and now it is working properly.

:)
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
Comment Utility
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

Do You Know the 4 Main Threat Actor Types?

Do you know the main threat actor types? Most attackers fall into one of four categories, each with their own favored tactics, techniques, and procedures.

Join & Write a Comment

What is an ISAPI filter?   •      It's an assembly (.dll file) that can add or change the way IIS works.   •      They can be enabled globally for your web server or on a site-by-site basis.   When the IIS server receives a request, enabling the ISAPI fi…
Running classic asp applications under Windows Server 2008 R2 (x64) and IIS 7 is not as easy as one may think. It took me a while to figure it out while getting error 8002801d a few times. After you install the OS you will need to install the fol…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …
This video demonstrates how to create an example email signature rule for a department in a company using CodeTwo Exchange Rules. The signature will be inserted beneath users' latest emails in conversations and will be displayed in users' Sent Items…

728 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now