Solved

WSUS is not working!

Posted on 2008-10-10
4
1,764 Views
Last Modified: 2010-08-05
I am getting EVENTS 13032 and 13042, and none of my XP Pro machines are getting updates.  Can someone help?
I find it interesting that these below events were recorded the day that WSUS quit working.




WMI ADAP was unable to load the ASP.NET_2.0.50727 performance library because it returned invalid data: 0x0

WMI ADAP was unable to create the object Win32_PerfRawData_ASPNET_2050727_ASPNETAppsv2050727 for Performance Library ASP.NET_2.0.50727 because error 0x80041001 was returned

WMI ADAP was unable to create the object Win32_PerfRawData_ASPNET_2050727_ASPNETAppsv2050727 for Performance Library ASP.NET_2.0.50727 because error 0x80041001 was returned
The Open Procedure for service ".NETFramework" in DLL "C:\WINDOWS\system32\mscoree.dll" failed. Performance data for this service will not be available. The Status code returned is the first DWORD in the attached data.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


The Open Procedure for service "ASP" in DLL "C:\WINDOWS\system32\aspperf.dll" failed. Performance data for this service will not be available. The Status code returned is the first DWORD in the attached data.

Unable to locate the open procedure "??????????????#??" in DLL "C:\WINDOWS\system32\sqlctr90.dll" for the "MSSQL$MICROSOFT##SSEE" service. Performance data for this service will not be available. The Error Status is the first DWORD in the attached data.


Performance counter data collection from the "MSSQL$MICROSOFT##SSEE" service has been disabled due to one or more errors generated by the performance counter library for that service. The error(s) that forced this action have been written to the application event log. The error(s) should be corrected before the performance counters for this service are enabled again.
0
Comment
Question by:zachwideman
4 Comments
 
LVL 31

Expert Comment

by:Henrik Johansson
ID: 22694862
0
 

Author Comment

by:zachwideman
ID: 22770888
I just fixed this.  The SelfUpdate directory was missing from IIS.  I exported the selfupdate folder from another WSUS server at another location that was working fine.  I then, imported the .xml file into my IIS, and now it is working properly.

:)
0
 
LVL 1

Accepted Solution

by:
Computer101 earned 0 total points
ID: 23179685
PAQed with points refunded (500)

Computer101
EE Admin
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Prologue It is often required to host multiple websites on a single instance of IIS, mostly in development environments instead of on production servers. I am sure it is not much a preferred solution on production servers but this is at least a pos…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.

789 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question