Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 524
  • Last Modified:

How do I prevent the need to repair my wireless network connection constantly?

My wireless network connection keeps becoming "broken", in the sense that, while it does not drop so to speak, it does stop working, until I repair the connection via the Windows XP Repair option (manually disabling the connection and reenabling it also works. This happens very frequently, especially when the computer returns from sleep mode.

I'm using Windows XP Professional on a Lenovo Thinkpad R61i
0
Peteshnick
Asked:
Peteshnick
  • 4
  • 3
  • 3
  • +1
1 Solution
 
ctuckeriniCommented:
Hi there-
Do you experience this problem with only one particular wireless router or is it all wireless connections (hotspots, hotels, campus, etc)?
0
 
PeteshnickAuthor Commented:
I've really only used it on one network, so its hard to say. In the very limited time I've used it elsewhere, I haven't seemed to have the problem.

Other computers using the network don't seem to experience this problem either.
0
 
ctuckeriniCommented:
Are there other pc's of the same model that aren't experiencing the issue?  I don't mean to be asking so many simple questions but we need to determine if:
a) there's a compatibility issue with the particular card and router
b) if any firmware updates are needed on the router
c) if there are any newer drivers for the wireless card
d) if you are using the wireless utility from the card manufacturer or Microsoft's zero config utility
0
What Kind of Coding Program is Right for You?

There are many ways to learn to code these days. From coding bootcamps like Flatiron School to online courses to totally free beginner resources. The best way to learn to code depends on many factors, but the most important one is you. See what course is best for you.

 
PeteshnickAuthor Commented:
Hi... This is the only computer of this model we've used on this network, so I don't know about your first question. The only other question of yours I can at least partly answer is d) Both the Microsoft Utility and Lenovo Thinkvantage Wireless connection utility seems to be running..
0
 
ctuckeriniCommented:
Please check Lenovo's and the manufacturer of your router's websites for driver/firmware updates.  Also, what type of router are you using?
0
 
vacnetCommented:
If it's possible, try connecting it directly to your modem, to see if it has the same problem when physically connected. Or you can try manually assigning an IP address for your computer. Ctuckerini mentioned whether or not you are using the wireless utility or M$'s zero config utility; I've seen a problem with this a few times. You might want to check into that as well.
0
 
Darr247Commented:
Since you mention it happens especially when 'waking up' the computer, first check in Device Manager (Start->Run, devmgmt.msc [Enter]). Drill down in Network Adapters and right-click the wireless adapter. If there is a Power Management tab, UNcheck Allow the computer to turn off this device to save power. Just remember you've done that so if you're ever running strictly on battery and not using the wireless card, if you want to maximum run time go into the Network Connections window, right-click on the wireless adapter and choose Disable (doing the same on the Ethernet adapter will extend battery time too, because it checks every couple seconds to see if there has been a cable plugged in, and that check uses extra power).
There may also be driver-dependent power management options, so even if there is a Power Management tab, check on the Advanced tab while you're in the card's Properties in Device Manager.

You can have both a 3rd-party connection manager and the WZC service running but still be restricted to using only one or the other. To tell which you're using mainly, right-click on the wireless adapter in Network Connections and choose View Available Wireless Networks. If it displays 1 or more wireless networks you're using the WZC service; if it says you've chosen to allow another application to control it, then the WZC service isn't really doing anything but using extra resources (if it's even started).

If you've upgraded the drivers numerous times, you should try a 'clean install' of the latest drivers.
First ensure you have the latest driver install file available (as suggested in message# 22694216 by ctuckerini).
Next, uininstall the card in Device Manager (which is what actually uninstalls its drivers).
Then run your driver install file to load only the latest drivers (to prevent other versions from possibly being automatically loaded by windows, do not reboot and do not 'scan for hardware changes' between those steps).
0
 
PeteshnickAuthor Commented:
Just needed an update to the wireless adapter driver... Thanks
0
 
Darr247Commented:
So this is a useful addition to the knowledgebase (e.g. for people that run a search before asking a new question), could you please clarify which of the 4 possibilities in the accepted solution fixed your problem, Peteshnick?

Thanks.
0
 
PeteshnickAuthor Commented:
Yeah.. As I indicated under the grading comments, I just needed to update the driver for the wireless card.
0
 
Darr247Commented:
> Yeah.. As I indicated under the grading comments, I just needed to update the driver for the wireless card.

That's nice, but nobody can see the grading comments besides you, the person[s] awarded the points, and mods/admins.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

  • 4
  • 3
  • 3
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now