Solved

How to set 1280 800 (widescreen) resolution in RHE Linux 4?

Posted on 2008-10-11
4
797 Views
Last Modified: 2013-12-06
The problem is simple. I have installed Red Hat Enterprise Linux 4 in VMWare Workstation(though I suppose that shouldn't matter, but am not sure) and I want to set its resolution to 1280 x 800, (which is my widescreen laptop resolution). But I couldn't find any solution to this. All the monitors which I selected in the Applications-->System Settings-->Display, had either 800x600, 1024x768, or 1280 x 960 but didn't have a 1280x800 resolution. I tried a few things found on the internet like modifying the file /etc/X11/xorg.conf and replacing all the occurrences of 1024x768 by 1280x800, but with no success... it doesn't show up in the list when I select from the Display.

Any ideas? I know it can be done.
Thanks !
0
Comment
Question by:piyush_soni
  • 2
  • 2
4 Comments
 
LVL 87

Expert Comment

by:rindi
ID: 22696775
First thing, did you install the VmWare Tools, and what version of VmWare workstation are you using?
0
 
LVL 2

Author Comment

by:piyush_soni
ID: 22696848
Yes, I did install VMWware Tools, and the version I'm using is this:
VMware Workstation ACE Edition
Version 6.0.4 build 93057
0
 
LVL 87

Expert Comment

by:rindi
ID: 22697018
You might want to update to the newest version, I think 6.5?If you can't upgrade due to licensing (I don't know how licensing for the paid versions of VmWare work), try using VmWare Server 2 instead, which is free.
0
 
LVL 2

Accepted Solution

by:
piyush_soni earned 0 total points
ID: 22697104
I don't think that would solve the problem. The culprit is linux, not VMWare.
Anyway, I found out the solution to the problem myself, which I'm writing for any people who come here searching:

We knew that we have to somehow edit the xorg.conf file kept at path /etc/X11/xorg.conf, but
the initial replacements I had done were not helping. The solution is to do something like tihs:

Replace "HorizSync 31.5 - 48.5" by HorizSync 30.0 - 82.0
make maxlimit of VertRefresh to 90.0
comment the option dpms line by adding a #
#Option DPMS
Add this line just after this:
ModeLine 1280×8003 80.58 1280 1344 1480 1680 800 801 804 827 -HSync -VSync

And then add a "1280x800" in each SubSection "Display" Modes. (Initially I was only doing this)

(Some of the changes done might be highly irrelevant, but this worked for me so I'm writing here. I'm not a linux or hardware expert) Some more knowledgeable people can comment on this.  
0

Featured Post

Better Security Awareness With Threat Intelligence

See how one of the leading financial services organizations uses Recorded Future as part of a holistic threat intelligence program to promote security awareness and proactively and efficiently identify threats.

Join & Write a Comment

Are you sitting there reading this and wondering how to get started with Linux? It almost seems like picking the right Linux distribution is about like picking the right college or buying a new car if you read some of the article out there. Relax… l…
If you use Debian 6 Squeeze and you are tired of looking at the childish graphical GDM login screen that is used by default, here's an easy way to change it. If you've already tried to change it you've probably discovered that none of the old met…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.

762 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

20 Experts available now in Live!

Get 1:1 Help Now