Solved

Mobile Broadband on eee pc

Posted on 2008-10-11
20
976 Views
Last Modified: 2013-11-15
I have an eee pc 8g, with Ubuntu 8.4.1 eeepc version installed. I am trying to install a Sierra Compass 597 mobile broadband modem, for use on the Sprint network. I'm running into problems.

I followed the directions found at www4.sprint.com/pcsbusiness/downloads/Sprint_Mobile_Broadband_Setup_Guide.pdf, which had me install and use KPPP. Everything seemed to be working fine--the program was recognizing the modem, etc. However, when I tried to connect, right at the tail end of the connection process, I received this error message:

pppd daemon died unexpectedly!
Exit Status: 2
See 'man pppd' for an explanation of the error codes or take a look at the kpppd FAQ on http://developer.kde.org/~kppp/index.html

In the ppp log, it says, "pppd[8019]: Can't open option file /etc/ppp/peers/kppp-options: Permission denied."

I have already activated this modem on my Windows laptop, and it's working fine there.

Please help!
0
Comment
Question by:kjannot
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 11
  • 7
  • 2
20 Comments
 

Author Comment

by:kjannot
ID: 22695829
PS: I tried the suggestion under the FAQ (under the link above) for "Dial-up failures with exit code 2," and got this message: cp: cannot stat '/etc/ppp/peers/ppp': No such file or directory
0
 
LVL 28

Assisted Solution

by:burrcm
burrcm earned 50 total points
ID: 22696881
So does /etc/ppp/peers/kppp-options exist? Have a look from a command (root) prompt. If it does and it is a permissions issue, try chmod 777 kppp-options from within the directory. That will give "everyone" permission to use or execute the file.

Chris B
0
 

Author Comment

by:kjannot
ID: 22697227
I always forget the commands to use at the prompt. What command do I need for checking to see if it exists?
0
Turn Insights Into Action

You’ve already invested in ITSM tools, chat applications, automation utilities, and more. Fortify these solutions with intelligent communications so you can drive business processes forward.

With xMatters, you'll never miss a beat.

 

Author Comment

by:kjannot
ID: 22698005
I tried to do the second part of your suggestion, and I got the message that it couldn't find kppp-options. That seems to indicate that it doesn't exist. So how can I get it?
0
 

Author Comment

by:kjannot
ID: 22699586
New development: I noticed in Synaptic that there was a newer version of KPPP, so I downloaded and installed that one.This time, when I started that program, I got the error message,

"You do not have sufficient permission to run /usr/sbin/pppd. Please make sure that kppp is owned by root and has the SUID bit set."

After clicking "Okay," I was able to set up the connection and modem, and when I tried to connect I did not get the error message from my first post--but nothing further happens past "logging on to network." The program just hangs there.

Also, nothing happens when I query the modem.
0
 
LVL 28

Expert Comment

by:burrcm
ID: 22700599
To get to the directory where the file is, at the command prompt type cd /usr/sbin then to list the file type ls pppd and it should appear. To set the permissions use the command mentioned earlier. I know SCO Unix, not Ubuntu but the command structure is very similar.

Chris B
0
 

Author Comment

by:kjannot
ID: 22701890
If, after putting in 'sudo chmod 777 pppd', it goes immediately to the command promptwith no text intervening), does that mean a change has been made?

After I did this, I immediately opened kppp, and got the same error message at the start and the same hang at  'logging on to network...'.
0
 
LVL 28

Expert Comment

by:burrcm
ID: 22701974
Comand prompt with no error message means success generally. I don't know what you mean by <<'sudo chmod 777 pppd'>>, in unix the command would simply be at the command prompt within the directory housing the file - chmod 777 pppd. Other than that I don't think I can offer a solution.

Chris B
0
 

Author Comment

by:kjannot
ID: 22702072
In Ubuntu, 'sudo' is needed to get to root permission. I couldn't run that command otherwise; the computer let me run the command with it.
0
 
LVL 28

Expert Comment

by:burrcm
ID: 22709581
I will remember that one. A I mentioned I work in unix, similar but not the same. Sorry I couldn't help further.

Chris B
0
 

Author Comment

by:kjannot
ID: 22713223
Another new development--I seem to be moving forward, but getting new roadblocks.

On another forum, I found this possible solution posted:

sudo chmod u+s /usr/sbin/pppd

I tried that, and it seems to have fixed part of the problem. Now, my newer version of KPPP successfully connects my modem (at least, it says it does). BUT -- Firefox does not seem to want to use that connection. Whenever I only have that modem going (shutting down the wifi connection in my house), Firefox continues to say that there is no connection to the internet.

So, how do I get Firefox to use this mobile broadband connection?
0
 
LVL 28

Expert Comment

by:burrcm
ID: 22718183
Better see if it is actually connected first. From command prompt, type ifconfig. See what the ip address is and ping <ip address> If you get a reply the modem is connected to the PC and has allocated an address. If that works try ping microsoft. If that works you have an internet connection.

Chris B
0
 

Author Comment

by:kjannot
ID: 22730214
I seem to be back to hanging on "logging in to network."
0
 
LVL 31

Expert Comment

by:rid
ID: 22734761
Firefox seems to have that quirk... Simplest workaround is to leave the connection as is (i.e don't try to remake it once you have started it) and go to the File menu and "untick" the "Work offline" item (or whatever it may be in proper english; I have a swedish system). That gets Firefox back on track.
/RID
0
 
LVL 28

Expert Comment

by:burrcm
ID: 22739139
IE will do that too at times, however I don't think you are connected.

Chris B
0
 

Accepted Solution

by:
kjannot earned 0 total points
ID: 22740505
Well, I got connected, Chris, and it looks like you may have been right from the beginning, but I didn't really understand what to do.

It was a strange ride around several different forums, and through several different sets of directions from Sprint and the manufacturer, Sierra--but I finally found one set of directions that had the lightbulb go off inside my head. All I had to do was to get to the REAL root directory (not just 'sudo'), and create the KPPP configuration from within that directory. I hadn't really understood how to do that until now. (sudo su in Ubuntu) AND, then, I needed to get back into the root directory to run KPPP; when I did that, the connection worked just fine.

Now, I'll go back and from the root directory re-try the 'chmod' suggestions above, to see if I can set this up so I don't have to run KPPP from root. I'll let you know.
0
 

Author Comment

by:kjannot
ID: 22742361
Still getting the same "pppd daemon died unexpectedly" error message, if I try to connect KPPP normally. (I also needed to set up the connection all over again in the normal mode--what I set up in KPPP in root doesn't show up unless I'm back in root.)

Again, the connection goes through IF I open KPPP from the terminal in root. Once the connection is made, I can open Firefox normally from the desktop icon.

I can live with this arrangement if need be (It's not that much of a pain); but is there anything I can do to make the terminal-root step unnecessary?
0
 
LVL 28

Expert Comment

by:burrcm
ID: 22745671
All right then. (so sudo = pseudo but doesn't really have full root authority). A reminder, I don't know anything about ubuntu. I presume it has a man (instruction manual) structure - man xxx gives you details of the xxx command. In SCO if you want a process to run with root authority you give the authority via a command called asroot, eg asroot xxx. Try man asroot to see if the command exists.

Chris B
0
 
LVL 31

Expert Comment

by:rid
ID: 22747307
sudo GIVES full root access, but you need to navigate the file system to get to the right place. Sudo keeps you in your own directory /home/user, so you have to go up to / and then find the directory you need. I recommend the mc software, it is a very useful and fast file manager, very much like Norton Commander, with editor built-in.

You can do: sudo apt-get install mc
and your PW to have it installed.

Once in a terminal you can run the program. If you need root access you just run: sudo mc
then you can access and edit any file.
/RID
0
 

Author Comment

by:kjannot
ID: 22763800
Chris--

No entry for "man asroot".

rid: You seem to know a bit about Ubuntu--do you know how I can get KPPP to connect without opeining the root folder first? Or, to ge KPPP running "as root" automatically? Would that mc program help me with that?
0

Featured Post

Don't Miss ATEN at InfoComm 2017!

Visit booth #2167 to see the  new ATEN VM3200 32 x 32 Modular Matrix Switch. Other highlights include the VE8950 4K HDMI Over IP Extender, VS1912 12-Port DP Video Wall Media Player  and VK2100 ATEN Control System. Register now with Free Pass Code ATEN288!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

How can this article save you time AND money?  In just a few minutes you may discover something you didn't know existed that is easy enough for you to fix yourself!
1. Introduction As many people are interested in Linux but not as many are interested or knowledgeable (enough) to install Linux on their system, here is a safe way to try out Linux on your existing (Windows) system. The idea is that you insta…
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.

695 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question