Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Can't bridge multiple network adapters in VMWare Server 2.0

Posted on 2008-10-12
5
Medium Priority
?
5,584 Views
Last Modified: 2010-04-16
I installed VMWare Server 2.0 on a Windows 2003 Server (Standard Edition).  The host also has two network cards, one connected to a 10.20.1.0/24 network and the other connected to a 10.50.1.0/24 network.  I created the guest VM using the VMWare Conversion utility on a second physical machine.  The guest VM starts fine, but I can not get the two NIC's to bridge so that the guest OS can access both networks at the same time.

I have set up the guest network adapters as bridged and have tried every way I can imagine of configuring the virtual network adapters from within the Virtual Network Manager utility (making sure to refresh the network every time I make a change).  For example, I have tried bridging vmnet0 to the one network card and then vmnet2 to the other.  I have tried doing the same with vmnet2 and vmnet3.  I have switched the properties of each virtual adapter within the guest.

Right now, I have vmnet0 and vmnet2 configured.  However, whatever host network card is bound to vmnet0 seems to be the only network that works for the guest; I can get it to see each network by doing that, but never both at the same time.  Both guest NIC's say that they're connected.  In testing, I also set each to obtain IP addresses from the DHCP server, and both NIC's on the guest OS obtain IP addresses from the same network (again, whichever one is bound to vmnet0).
0
Comment
Question by:RAHopkinson
5 Comments
 
LVL 6

Expert Comment

by:xfreddie
ID: 22709882
I would recoment disableling the automatic bridging.
This can be done in the "manage virtual network editor"
Under the tab "Automatic bridging"
Once you have done this, then go to the "Host Virtual Network Mapping" Tab and config the VMnics with the host network card.

I hope it helps.
Gr,
Xfreddie
0
 
LVL 1

Author Comment

by:RAHopkinson
ID: 22710407
I have alrady disabled the Automatic Bridging feature.  On the Host Virtual Network Mapping tab, I have configured the NIC's on vmnet0 & 2 and vmnet 2 & 3, but the guest OS only sees what's on vmnet0.
0
 

Expert Comment

by:f3tpadmin
ID: 22711920
Solution:

You need to click on your Host (vmware server host) and click 'Refresh Network List'.  Your bridged network should now appear in the 'Networks' list and will then be selectable when you setup your network adapters for your vm's.


0
 
LVL 1

Accepted Solution

by:
RAHopkinson earned 0 total points
ID: 22717457
In the original question, you'll see the phrase "making sure to refresh the network every time I make a change," so that wasn't the issue (although it took me a while at first to find that option).

The problem turned out to be one of nomenclature.  In the guest virtual adapter settings, I took "bridged" to mean the type of network connection--not the actual interface.  In VMWare 2.0, "bridged" means "vmnet0" so setting the guest network adapters to "bridged" and "vmnet2" respectively solved the problem.
0
 

Expert Comment

by:soldato0973
ID: 25609358
I am having the same problem, but I don't seem to understand how you solved it.  I got to the point you did in the Accepted Solution, but I am not clear what steps you took to solve.  What are your settings in the "Host Virtual Network Mapping" tool and also in the VMWare web console for the guest settings?
0

Featured Post

Concerto Cloud for Software Providers & ISVs

Can Concerto Cloud Services help you focus on evolving your application offerings, while delivering the best cloud experience to your customers? From DevOps to revenue models and customer support, the answer is yes!

Learn how Concerto can help you.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In this article, I will show you HOW TO: Suppress Configuration Issues and Warnings Alert displayed in Summary status for ESXi 6.5 after enabling SSH or ESXi Shell.
When rebooting a vCenters 6.0 and try to connect using vSphere Client we get this issue "Invalid URL: The hostname could not parsed." When we get this error we need to do some changes in the vCenter advanced settings to fix the issue.
Teach the user how to install ESXi 5.5 and configure the management network System Requirements: ESXi Installation:  Management Network Configuration: Management Network Testing:
Teach the user how to rename, unmount, delete and upgrade VMFS datastores. Open vSphere Web Client: Rename VMFS and NFS datastores: Upgrade VMFS-3 volume to VMFS-5: Unmount VMFS datastore: Delete a VMFS datastore:

963 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question