[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1643
  • Last Modified:

getting large number Spam Mails to all users

i had 550 5.7.1 Unable to relay issue on exchange 2007. As per ID ID:22678110. i got resolved the issue. But now i am not getting lot of spam mails.  As per above given id i have modified the edge external receiver connector as described below.

.  log on to the edge server go to the properties of the Default Ext edge receive connector. click the Permission group tab check Exchange Servers tick box which is currently unticked. click Apply click the authentication tab Untick Enable Domain Security (Mutual auth TLS) Untick "Exchange server authentication" Tick "Externally Secured (for e.g. IPSEC)" check box. click Apply

Please help me to stop this spam.
0
senmohan
Asked:
senmohan
  • 7
  • 6
6 Solutions
 
tenaj-207Commented:
Have you turned the Anti-Spam feature on?

1) Expand Organization Configuration then Hub Transport
2) Click on the Anti-Spam tab.
3) Right click on Content Filtering and choose properties
4) Go to the Action tab and setup the SCL ratings

I have mine set for Delete at 9, reject at 7, and send to Spam@domain.com at 5.  It's working well for me.
0
 
senmohanAuthor Commented:
do i need to create separate mailbox  like spam@mydomainname.com.

Also is there any option to send notification mails to users where they can see the spam mails which they have received. Like in Barracuda spam filter  
0
 
tenaj-207Commented:
Yes you do need to create a spam@mydomainname.com account.

No, there's no way to send notifications to the users.  It's a very limited (still a good price for free) spam filter.  If you have a barracuda spam filter that has worked well for you in the past then as long as it's compatible with Exchange 2007 I would use it.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
senmohanAuthor Commented:
In edge server i have thousands of spam mail quedup and now mail are not flowing. how can i delete the queues mail at a same
0
 
senmohanAuthor Commented:
I am geeting below message in my edge server...


the query produced too many results. To reduce the number of results, use a more restrictive filter.it was runnung command get-message -ResultSize "1000' -Returnpageinfo $true -server Edgeserver.dhcc.mazaya.com -SortOrder -FromAddress -SearchForword $true-BookmarkObject $null -BookmarkIndex '-1'Includebookmark $false

Please advice what to do next.

i have enavled SCL rating and set the values !!!
0
 
tenaj-207Commented:
In the queue you can clear queues by right clicking on them and choosing Remove Messages.

As far as your error message goes.  It looks like you were trying to use the Message tracking and the filter you were using was to broad and gave you more responses then it could handle.  

If you open Exchange power shell and use the get-message command then you can by pass this by changing the -ResultSize to 9999.  You also need to export the data so you can read it.  Ad the end of your get-message command put in | export-csv c:\exchangereports\userstats.csv.  This will allow you to open the file with Excel and read it.

The following link explains more about the get-message command.
http://technet.microsoft.com/en-us/library/bb124738(EXCHG.80).aspx
0
 
senmohanAuthor Commented:
i have cleared all the queue. it was hectic job. But still get spam mails. the header looks like this...

From: Williams Pharmacy Newsletter [mailto:noreply@newsletter.ac.com.do]
Sent: Tuesday, October 14, 2008 7:17 PM

After i enable SCL rating. Some know mails are blocking. how to bypass those ?
0
 
tenaj-207Commented:
That address has been spoofed.  To reject this type of spam change the settings to your Sender ID.  This setting is in the same location that the Content Filtering was in.  To change it right click on Sender ID, then choose properties.  Click on the action tab and choose Reject message from the list.  Then click on OK and it should apply that setting.

Let me know if that helps.
-t
0
 
senmohanAuthor Commented:
i have changed the settings to reject . but still i am getting lot of spam.
please advice me as soon as possible.
0
 
tenaj-207Commented:
You could lower the SCL ratings by a couple numbers and see if that helps.  Just make sure that you are keeping a close eye for any false positives.
0
 
senmohanAuthor Commented:
if i lower the rate also no luck also some my important mails are getting ejected.
0
 
tenaj-207Commented:
Then your only option left is to purchase a 3rd party spam solution to filter out the spam.  I've heard good things about the barracuda spam filter.
http://www.barracudanetworks.com/ns/products/spam_overview.php

But as far as filtering out the spam with the Exchange server tools, you've done all you can with the limited tools that Exchange has.
0
 
senmohanAuthor Commented:
ok let me try !!! thanks for your time.
0

Featured Post

The 14th Annual Expert Award Winners

The results are in! Meet the top members of our 2017 Expert Awards. Congratulations to all who qualified!

  • 7
  • 6
Tackle projects and never again get stuck behind a technical roadblock.
Join Now