Can't resolve Exchange server via VPN

When I VPN to our server and run Outlook, I cannot connect to the Exchange Server UNLESS I put a route in my local Host file:

192.***.***.**    Myserver.my-domain.com

With this information in my Hosts file, it connects first time every time but without it fails.  Not really a biggie as it works by making this amendment, but I'm sure a simple DNS tweak would 'resolve' this issue?
LVL 3
-Juddy-Asked:
Who is Participating?
 
-Juddy-Connect With a Mentor Author Commented:
Our domain controller (which also controls DNS and VPN) ALSO has the Exchnage Server software on it, they are the same machine.
0
 
icky2000Commented:
When you connect to the VPN, the VPN connection provides you with an IP address and likely also gives you an IP of a DNS server to resolve DNS requests on that network. Is it giving you the IP of a valid DNS server in the domain the Exchange server is in?
0
 
-Juddy-Author Commented:
The Exchange Server software is on the same Server that I VPN in on.  The DHCP Relay Agent (on Routing and Remote Access) does indeed point to our DNS Server.
0
Has Powershell sent you back into the Stone Age?

If managing Active Directory using Windows Powershell® is making you feel like you stepped back in time, you are not alone.  For nearly 20 years, AD admins around the world have used one tool for day-to-day AD management: Hyena. Discover why.

 
icky2000Commented:
OK, so after making the VPN connection open a command prompt on your PC and type this:
nslookup exchangeservername

(obviously replace exchangeservername with the name of your Exchange server)

Does that yield the appropriate IP address for the Exchange server? I would guess not given the issue you are having but might tell you something.

Also from the PC and in the command prompt, when you do a "ipconfig /all", does it show the IP of the correct DNS server in the list of DNS servers?

And just to be sure, the DNS server in question, this is a domain controller on your network that is the same domain the Exchange server is in, yes?
0
 
BertlingCommented:
you need to specify the DNS in the DHCP for the VPN client.

or just manually enter the DNS address in the TCPIP settings under the VPN NIC on your PC
0
 
-Juddy-Author Commented:
Ok, to test this I used a remote PC, removed the information I had added into the local Hosts file and then connected the VPN.  When I start Outlook, I cannot connect to the Exchange Server (shows as disconnected) and I cannot browse our corporate network by using server names (\\myserver\my files etc) but if I use the IP address, it does work.  

When I run nslookup myservername I get:

server: th-cache-2-a-1.ns.uk.tiscali.com (my ISP)
Address 212.139.132.10 (Tiscali's name server, I think)

Non Autoritative answer:

Name: Myservername.mydomain.com
Address: 195.238.237.142 AND 195.238.237.142 (No idea, and they are not and our our IP addresses)

Ipconfig /all shows the correct DNS information for our internal network but for some reason, three entries:

192.***.***.11 (Our Dns Server and Domain Controller)
192.***.***.15 (A file server and backup Domain Controller)
192.***.***.11 (Our Domain controller, again!)

Re-adding the record to the local hosts file means that I can use Outlook, connect to Exchange and browse by network names.
0
 
-Juddy-Author Commented:
As an added note, when I ping the Exchnage Server (once connected to the VPN, Host File has entry removed) it fails to reply, but does elude to the fact that's it's trying to resolve:

myservername.mydomain.com

So it's kind of looking in the right direction, as it adds the domain name after the hostname.  Not sure if that helps!?
0
 
BertlingCommented:
try pining the excahnge.domain.local rather than just exchange
0
 
-Juddy-Author Commented:
Sorry mate, you have lost me there! Could you explain that last post?
0
 
BertlingCommented:
when you ping exchange it will append the domain.local which is the fuly qualified domain name.

what happens if you yupe:

ping exchange.domain.local? does it resolve

rather than just ping exchange which is not resolving?
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.