Solved

How to be able to connect to the same server you are VPNing through?

Posted on 2008-10-13
7
273 Views
Last Modified: 2010-04-18
Hi,

I just installed the VPN service on my win2k3 server, and was wondering how I would be able to "connect" (use shared directories for example) to that same server when connected through VPN.

I tried adding a static route but wasn't successful so far.

My network information:
Public IP of the server: 85.x.x.x
Netmask: 255.255.255.0
Gateway: 85.x.x.254

All VPN clients are getting a static IP address assigned:
192.168.123.1 to 192.168.123.254
Netmask: 255.255.255.0

Kind regards,

Matthias Vance
0
Comment
Question by:MatthiasVance
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 2
7 Comments
 
LVL 1

Expert Comment

by:Intechnical
ID: 22700878
Good Morninig,
I assume you have installed the RAS conponent in w2k3 server? Are you able to ping the server once connected via vpn by name and address?
Have you configured the remote access policy?

Regards
Integratech
0
 
LVL 8

Author Comment

by:MatthiasVance
ID: 22700923
- I have indeed installed RAS component and enabled.
- I am able to ping the server on the PPP interface (192.168.123.1) and on the LAN interface that is connected to the internet (85.x.x.x)
- I am not able to ping the server when using the servername SERVER, it gives me the error "Unable to resolve target system name SERVER."
- I have not configured any Remote Access Policies, but there are two installed by default.

Kind regards,

Matthias Vance
0
 
LVL 8

Accepted Solution

by:
MatthiasVance earned 0 total points
ID: 22700970
I'm able to access the shared directories using the IP address \\192.168.123.1.
I will just add an entry to my hosts file containing the servername to resolve that issue.

Seems that I resolved my own question.

Kind regards,

Matthias Vance
0
Are You Headed to Black Hat USA 2017?

Getting ready for Black Hat next week? Kick things off with the WatchGuard Badge Challenge and test your puzzle and cipher skills. Do you have what it takes to earn our limited edition Firebox Badge? Get started today - https://crimsonthorn.net

 
LVL 10

Expert Comment

by:JaredJ1
ID: 22700999
If you can ping the server with the LAN ip address then it is probably a DNS issue. To verify - try mapping a drive with a UNC, but instead of using the name of the server, try using the IP
i.e. "\\192.168.123.1\Sharename"
If you can successfully access, then you have a problem resolving that domain name. You mentioned that you are "staticly assigning" addresses. I assume what you actually mean is dynamically assigning as you have provided a range of addresses. Can you check to see if you are also assigning an internal DNS server? Run an "ipconfig /all" from a vpn connected workstation and see what DNS server address (if any) comes back for the vpn adaptor.
I suspect this is where the problem is. If there is no address, try changing your TCP/IP scope settings in the RAS configuration.

If you do have an internal DNS server - make sure that it's not a problem with appending the domain name suffix. i.e. try pinging with a fqdn ping "servername.domainname"
0
 
LVL 8

Author Comment

by:MatthiasVance
ID: 22701019
- There is no DNS server configured for that interface (ipconfig /all shows no addresses).
- The server isn't running in a domain.
- I indeed meant that I the server is dynamically assigning from a given range of addresses.

How would I change the TCP/IP scope settings in the RAS connfiguration? I was unable to find it after a quick peek.

Kind regards,

Matthias Vance
0
 
LVL 8

Author Comment

by:MatthiasVance
ID: 22701029
I must be still sleeping, I meant to ask: To what values do you suggest changing the IP scope?
0
 
LVL 10

Expert Comment

by:JaredJ1
ID: 22703356
Sorry - the dhcp scope settings will be in the DHCP management console - not in the RAS configuration. Look in DHCP and check to see what address you are giving out as the gateway.

Do you use a DNS or WINS server on your network for resolving internal server names/addresses?
You need to specify these server addresses in your dhcp scope for vpn clients.
0

Featured Post

Get 15 Days FREE Full-Featured Trial

Benefit from a mission critical IT monitoring with Monitis Premium or get it FREE for your entry level monitoring needs.
-Over 200,000 users
-More than 300,000 websites monitored
-Used in 197 countries
-Recommended by 98% of users

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I've always wanted to allow a user to have a printer no matter where they login. The steps below will show you how to achieve just that. In this Article I'll show how to deploy printers automatically with group policy and then using security fil…
ADCs have gained traction within the last decade, largely due to increased demand for legacy load balancing appliances to handle more advanced application delivery requirements and improve application performance.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

627 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question