LPT printer not getting redirected.

Hi
I have a problem with 2 terminal servers in the same OU.
Both of them doesn't connect my client printers.
When connecting to a domain controller in the same domain but default OU, it maps the printer correctly.
In the eventlog of the 2 servers, I can see it adds the driver for my "Hp laserjet 4m Plus". See attached picture.
However I don't get the following:
event id 9: Printer HP LaserJet 4 (from KEWELAPTOP) in session 1 was set.
event id 2: Printer HP LaserJet 4 (from KEWELAPTOP) in session 1 was created.

However I get an event id 3019 from MRxSmb: The redirector failed to determine the connection type.
Come to think of it, I think the MRxSmb event is related to a GPO that utilises UNC path to the server itself.



printeradd.JPG
LVL 2
mathiesen-dataAsked:
Who is Participating?
 
mathiesen-dataAuthor Commented:
It was the registry that was cleaned after cleanspl.exe
I just copied the entire registry under [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Print\Monitors] from another windows 2003 server, with no printers installed.
After a restart of the spooler service it works.
0
 
mathiesen-dataAuthor Commented:
Come to think of it, I think the MRxSmb event is related to a GPO that utilises UNC path to the server itself.
0
 
mathiesen-dataAuthor Commented:
as per http://support.microsoft.com/default.aspx?scid=kb;EN-US;243552 I just realised that I don't have any ports named TSxxx
I do have those on the domain controller.
0
 
mathiesen-dataAuthor Commented:
I think I know the problem.
I ran cleanspl.exe from the ressource kit earlier on, and that probably deleted the ports.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.