Solved

XP Pro Ntfs.sys missing or corrupted

Posted on 2008-10-13
5
1,599 Views
Last Modified: 2013-11-05
Greetings all. I have another question open for a related issue but I need a bit more exposure, hence, a second post. Original post was for a missing system file. I successfully copied it from the repair folder and that error is gone. The hardware is a Dell Optiplex GX280, XP Pro, SP3, Maxtor 7y250M0 250G Sata Drive, 3 Gig Ram (3 - 1G sticks). The system hung on shutdown. Did ctrl-alt-del and immediately shut down. Waited 5 minutes, rebooted, all normal. Shut down, normal. Booted next day with the following error:
"Ntfs.sys is missing or corrupted. Will not boot to safe mode either.
What I have done so far:

run Chkdsk /r   found 2 errors and corrected them
Copied Ntfs.sys from XP CD to the drivers folder (after renaming the original Ntfs.old). No change
Booted UBCD to test the Hard drive... ok
Booted Knoppix and run Ntfsfix on /dev/sda1.  no change
Booted ERD Commander, and performed the following:
copied Ntfs.sys again from ERD CD. No change
File checker. No corrupted files.
System Restore. No change.
Removed all Ram and tried one stick at a time in each of the 4 slots (12 reboots total). No change

Power supply is 3 weeks old and is a Power and Cooling 500 Watt

When attempting to boot, I get hashes across the bottom that slowly fill until I get the error message. Kind of looks like Windows 2000 booting.

Last thing done to system before problem occurred was installing EA Games Spore. (This is son's PC) Ran no problem for 3 days prior to this issue occurring. I am at work but will try any and all suggestions as soon as I get home. I am really desperate folks. I have the installation CD from Dell, but not sure if it is a recovery CD or Installation CD. A recovery CD means a reformat. Installation means I can do a repair... I think??? What have I not tried yet??? My son is so bummed... and it's my birthday today  :), so someone make my day plssssssssss...

0
Comment
Question by:flubbster
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
5 Comments
 

Expert Comment

by:reedsdomain
ID: 22703266
I've run into this issue on several computers before and it was one of 2 things:

1.  The power supply is faulty and not getting enough power to the HD causing errors to occur during reading/writing (this was a rare example).  Replacing the power supply and copying over the needed files from a working computer resolved the issue.

2. On the majority of computers I have fixed this issue on a virus infected the hd.  I took out the hard drive, installed it on another computer and ran several scans on it to find/clean the virus (I used Symantec Anti-Virus, Spybot Search and Destroy & Ad-Aware).  Also after you clean the hd you can copy over any important docs as a backup.  This fix had only about a 50% success rate.

Unfortunately I found that the quickest fix tended to be copying off needed files by setting up the hard drive as a slave on another computer (don't forget to scan for viruses first) and then placing original hd back in primary computer and reinstalling the operating system.  Hopefully you get another post that resolves the issue with less work.
0
 
LVL 30

Author Comment

by:flubbster
ID: 22703359
System was running Avast Antivirus, Superantispyware, and Spybot Search and Destroy. I would hope there is no virus. Don't have another PC to try it in either....
0
 
LVL 39

Expert Comment

by:PUNKY
ID: 22703361
0
 
LVL 18

Expert Comment

by:sk_raja_raja
ID: 22703879
1.On the NTFS.sys file take a look at this
http://xphelpandsupport.mvps.org/how_do_i_rectify_a_missing_or_co.htm
Do you have another computer? If so, then take your Hard Drive from this computer
And put it on the other computer BUT!!!! Make sure the other computer is running XP as well.
Copy over the files you need.

2.http://www.computerhope.com/issues/ch000876.htm
Missing or corrupt c:\windows\system32\drivers\ntfs.sys.

3.See http://www.windowsitpro.com/Article/ArticleID/39746/39746.html about copying the ntfs.sys file from your CD to your system area

4.You may need a repair install, then: http://www.dougknox.com/xp/tips/xp_repair_install.htm 

5.http://www.experts-exchange.com/OS/Microsoft_Operating_Systems/Windows/XP/Q_23211470.html
0
 
LVL 30

Accepted Solution

by:
flubbster earned 0 total points
ID: 22704121
I have copied the ntfs.sys file to the drivers folder several times with no luck. Something else is hosing the system it seems. I am going to run memtest from UBCD tonight just in case.

any other ideas?????
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
external hard drive and Raidon 3630 5 132
Toshiba Satellite 5 166
Process prvSGxBA.exe 100 % CPU, is this a virus? 7 76
Error login w2012 domain 6 104
Are you unable to synchronize your OST (Offline Storage Table) file with Microsoft Exchange Server? Is your OST file exceeding 2 GB size limit? In Microsoft Outlook 2002 and earlier versions, there is a 2 GB size limit for the OST file. If the file …
If you have done a reformat of your hard drive and proceeded to do a successful Windows XP installation, you may notice that a choice between two operating systems when you start up the machine. Here is how to get rid of this: Click Start Clic…
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

756 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question