• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 741
  • Last Modified:

Setting up Iphone 2.0 with Exchange server


I am trying to setup an Iphone with our Exchange server.  I have been using the Iphone Enterprise Deployment guide, but I am still running into problems.  

Background info:  we do NOT use OWA or have IMAP enabled on our Exchange server.  So we were going to use Exchange Active Sync.  We didn't have an ISA server or a front end Exchange server so I setup an ISA server and put it in our DMZ.  We added an access list on our router and firewall to allow https traffic to the ISA server in the dmz, then another access list to allow https traffic from the ISA server to our Exchange server.  Right now however, we are having problems getting the Iphone to establish a connection to our ISA server.    

Our mx record for our email points to a hosted spam/virus filtering company, which then forwards email directly to our Exchange server.  When configuring the Iphone, I cannot put the mx record in for the "server" as that would bypass our ISA server.  So I was trying to put in the public IP address of our ISA server, but we do not see any traffic on that IP.  I even tried to put in a public IP that is not in use much and we did not see any logs on our router or firewall blocking access.  Does this mean I cannot enter an IP address into the "server" field?  Also, I have been trying on a non-3g Iphone but it has been upgraded to 2.1 firmware.  The ATT techs tell me I do not need any special plan, is this also true?  

Any help would be greatly appreciated!
2 Solutions
I had kind of a similar problem which I'd managed to resolve.

First step:

From a web browser within your local LAN, type: http:// or https://mailservername/oma

If you get a "browser not compatible error" after logging in this would indicate that Activesync is functioning as expected.  

That being the case, you can then create an A record, e.g.: oma.domain.com corresponding to the public IP address of your server, or if you prefer, the IP address of the ISA server (remember to create the rule passing SSL / 443 traffic to your exchange box)
You should also install a SSL certificate on your IIS server (can be self signed as long as you can bear the certificate error message when connecting)

Let me know if that helps, or if you need any further info.
A couple of things if ths question is still active...?
  • Check that exchange has SP2 else you are going to have problems
  • Do yourself a favour and get an SSL certficiate for your isntallation, it will save you many heart aches in the future
  • You should be able to use an IP in the server name but I would recommend yous peak to your ISP and create a DNS name.
  • ISA servers take a little setting up to publish OMA correctly, check the logs if you are having problems
  • Start simple, Get the iphone connedted to a Wifi network that has access to the exchage server directly and check that everything works. Then work outwards until you are outside the FW and all is working fine..
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now