Celebrate National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Connect two Cisco 2960G Switches with Smartports

Posted on 2008-10-13
14
Medium Priority
?
1,384 Views
Last Modified: 2012-05-05
Our main switch is a Cisco 2960G-48TC.  Connected to it via fiber are four Cisco 2960G-24TC switches.  Due to expansion, we added a second Cisco 2960G-48TC next to the main switch.  The vendor that we purchased it from installed the switch and all the tech did to connect the two 2960G-48TC switches together (via ethernet) was to go into smartports and change two of the ports (on each switch) to "Trunk".

I asked about load sharing and he said the smartports would take care of it.  Is this a correct statement and is this the best way to connect the two switches together?

Thanks.
0
Comment
Question by:knelson99
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 7
14 Comments
 
LVL 26

Expert Comment

by:Soulja
ID: 22703990
Are you referring to smartport macros? If so, then no, because the macro is nothing but a group of commands that you can apply to an interface. If all he did was place a trunk between the switches than they are just connected together. No load balancing of any sort. What type of load balancing are you trying to accomplish?
0
 

Author Comment

by:knelson99
ID: 22704133
The vendor accessed the Switch via the web browser and then used the graphical interface to configure the ports.  He basically clicked on the port and changed it to a trunk under the smartport configuration menu.

The main switch should have been ordered as a 96 port to begin with.  Since I ran out of ports and had to add the second switch, I thought it might be beneficial to use more than a 1 GB link between the two switches.  The vendor recommended utilizing  at least two ports and stated I could use as many as I wanted..

If there are benefits to utilizing two (or more) ports, how do I configure the switches?

Thanks.

0
 
LVL 26

Expert Comment

by:Soulja
ID: 22704695
If you have more than 1 link between the switches one is block if you are using spanning tree or the vendor set them up as an etherchannel. Maybe that is what is is referring to as the load balance. The switches will load balance across those two links if they are in fact set up as etherchannels.

Etherchannels are limited to 8 ports to my knowledge.
0
Connect further...control easier

With the ATEN CE624, you can now enjoy a high-quality visual experience powered by HDBaseT technology and the convenience of a single Cat6 cable to transmit uncompressed video with zero latency and multi-streaming for dual-view applications where remote access is required.

 

Author Comment

by:knelson99
ID: 22705267
To configure, they went in to the Catalyst 2960 series device manager via the web browser.  They clicked on configure, smartports and then changed the port roles on two of the ports to "Cisco Switch".  They did not do any command line changes to these ports.

So my question is, what do I have? A 2 GB link, two 1 GB links with load balancing, or a 1 GB link with one port blocked?  
0
 
LVL 26

Expert Comment

by:Soulja
ID: 22705414
I never work in the switch gui. Could you post your config? Log into the cli and do:

teminal length 0
sh run

Copy all the config to clipboard and paste it here.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 22705428
If it's etherchannel it is two 1Gb links being load balanced. If no etherchannel then on of the links will definitely be blocked by spanning tree.
0
 

Author Comment

by:knelson99
ID: 22706191
Here's the config:
Current configuration : 2563 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname ServerRoom2
!
enable secret ..
!
username xxxxx privilege 15 password xxxxxxxxx
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
description Trunk1 to Switch1
switchport mode trunk
macro description cisco-switch
auto qos voip trust
spanning-tree link-type point-to-point
!
interface GigabitEthernet0/2
description Trunk2 to Switch1
switchport mode trunk
macro description cisco-switch
auto qos voip trust
spanning-tree link-type point-to-point
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
description Beverage002
!
interface GigabitEthernet0/5
description 184-Keith1
!
interface GigabitEthernet0/6
description 184-Keith2
!
interface GigabitEthernet0/7
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
!
interface GigabitEthernet0/10
!
interface GigabitEthernet0/11
!
interface GigabitEthernet0/12
!
interface GigabitEthernet0/13
!
interface GigabitEthernet0/14
!
interface GigabitEthernet0/15
!
interface GigabitEthernet0/16
!
interface GigabitEthernet0/17
!
interface GigabitEthernet0/18
!
interface GigabitEthernet0/19
!
interface GigabitEthernet0/20
!
interface GigabitEthernet0/21
!
interface GigabitEthernet0/22
!
interface GigabitEthernet0/23
!
interface GigabitEthernet0/24
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface GigabitEthernet0/29
!
interface GigabitEthernet0/30
!
interface GigabitEthernet0/31
!
interface GigabitEthernet0/32
!
interface GigabitEthernet0/33
!
interface GigabitEthernet0/34
!
interface GigabitEthernet0/35
!
interface GigabitEthernet0/36
!
interface GigabitEthernet0/37
!
interface GigabitEthernet0/38
!
interface GigabitEthernet0/39
!
interface GigabitEthernet0/40
!
interface GigabitEthernet0/41
!
interface GigabitEthernet0/42
!
interface GigabitEthernet0/43
!
interface GigabitEthernet0/44
!
interface GigabitEthernet0/45
!
interface GigabitEthernet0/46
!
interface GigabitEthernet0/47
!
interface GigabitEthernet0/48
!
interface Vlan1
ip address xxx.xxx.xxx.xxxx 255.255.255.0
no ip route-cache
!
ip default-gateway xxxx.xxx.xxx.xxx
ip http server
!
control-plane
!
!
line con 0
line vty 0 4
password xxxxxxx
login
line vty 5 15
password xxxxxx
login
!
end

ServerRoom2#
0
 

Author Comment

by:knelson99
ID: 22706215
Is there a way to retract that post???

Thanks.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 22706267
No port channels, so one of those links are blocked.
0
 
LVL 26

Expert Comment

by:Soulja
ID: 22706295
I don't see any additional vlan, so they didn't need to make the ports trunks either.
0
 

Author Comment

by:knelson99
ID: 22706606
If I want to set up two 1-GB links with load balancing on int gi0/1 and int gi0/2, what are the commands I need to put in?

Thanks.
0
 
LVL 26

Accepted Solution

by:
Soulja earned 500 total points
ID: 22706654
Try:


config t
interface port-channel 1
no shutdown
exit
int range gi0/1-2
channel-group 1 mode on
0
 

Author Comment

by:knelson99
ID: 22707304
I got sidetracked on another project.  Will work on this again tomorrow.

Thanks.
0
 

Author Closing Comment

by:knelson99
ID: 31406303
Etherchannel is up and running.  Thanks for your help.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This tutorial will go through the steps required to write a script that will back up the configuration settings of a HP-ProCurve switch. You will need to get the following things to follow this tutorial: Telnet Scripting Tool e.g. TST10.exe …
This article will show how Aten was able to supply easy management and control for Artear's video walls and wide range display configurations of their newsroom.
In this video, Percona Director of Solution Engineering Jon Tobin discusses the function and features of Percona Server for MongoDB. How Percona can help Percona can help you determine if Percona Server for MongoDB is the right solution for …
In this video, Percona Solution Engineer Rick Golba discuss how (and why) you implement high availability in a database environment. To discuss how Percona Consulting can help with your design and architecture needs for your database and infrastr…

730 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question