Solved

shared folders not accessible over openvpn

Posted on 2008-10-13
6
959 Views
Last Modified: 2013-12-02
Hi,
My Linux system admin set up openvpn on our ipcop gateway so that we can connect to the lan from home and work.
when I connect, I can ssh and ping and remote desktop and VNC and ceck the cameras, and surf the intranet, but I can not see shared folder, not on windows hosts, or SMB shares on linux hosts.
if I start > run > \\servername ot IP >Enter I get "No network provider accepted the given network path"
Please help.
Steven
0
Comment
Question by:steviedeehook
  • 3
  • 2
6 Comments
 
LVL 1

Expert Comment

by:devnull22
ID: 22707178
It might be possible that your admin set up security on the shares, and forgot to add the range of ips from openVPN.

Ex: I have a similar set-up at work, and while our network starts with 10.1.17.0/24, openVPN gives a 10.1.18.0/24 network. If I setup the server shares to use scurity only to the 10.1.17.0/24 network, I won't be able to access it from openVPN.

But that's assuming a lot of things. How is your setup at work? Do the file servers you are trying to reach run on windows, or Linux? is it a machine that is behind the firewall, the same as other services you can access? Is there  firewall running preventing access by ip classes? etc...

I hope I can help pinpoint you to a resolution of this problem, but we need more details to help!
0
 
LVL 1

Author Comment

by:steviedeehook
ID: 22708901
Hi,
Openvpn is on an unusual range - I think 10.1.18.0/24  but there ir routing between that and our LAN range 192.168.10.0
On all servers I can access any of the services except smb or nfs.
ie. on our VOIP server (192.168.10.2) I can SSH, ping and SCP - but not SMB
on our file server (192.168.10.4) I can remote desktop, VNC, ping, but not access shared folders
It is the same with all the servers on the LAN, I can do anything like I would if I was in the office, except access the shares.
the windows hosts were set up and maintained by me, the Lunix hosts are set up and maintained by him (and sometimes me when he can't fix something in time)
it's like that port is blocked somehow - if that is an option with openvpn?
Steven
0
 
LVL 1

Author Comment

by:steviedeehook
ID: 22708961
maybe because port 445 is ipcop's interface?
Steven
0
The curse of the end user strikes again      

You’ve updated all your end user’s email signatures. Hooray! But guess what? They’re playing around with the HTML, adding stupid taglines and ruining the imagery. Find out how you can save your signatures from end users today.

 
LVL 4

Accepted Solution

by:
larsga earned 500 total points
ID: 22726497
Ping, VNC etc indicates that routing is working fine. We can eliminate that as possible problem.

1) It might be some firewall blocking. You might test this by trying to telnet to the tcp ports used by smb/windows networking (139/445), or use a tcp ping tool (google for windows tcp ping to find one).

2) Is "TCP/IP Netbios helper service", "Workstation service" running on the client? Is "client for microsoft networks" in the properties for the network connection?

3) What is the OS running on the client and the servers? There might be some mismatch in authentication methods supported. On one of the servers, try Administrative Tools | Local Security Policies
In Security Options Change the Network security: LAN Manager authentication level: Send LM & NTLM responses.

0
 
LVL 1

Expert Comment

by:devnull22
ID: 22736213
It does sound like a port necessary for SMB is blocked. I do as larsga suggested and try to scan the ports used for SMB (139, 445 usually, but 135 and 137 sometimes, in rare cases) to make sure it reachable by TCP.

Maybe something like this: http://lantricks.com/lanspy/
As I see you use Windows at home (start -> run in your message) try running this at work, and at home and compare, that will l let you and the network guy figure out if SMB is blocked. After that, aside from checking out your Firewall (conf for openvpn, and the output of iptables -L as root on ipcop) I'm afraid I can't do more. =)
0
 
LVL 1

Author Closing Comment

by:steviedeehook
ID: 31407097
Firewall on the local PC - AVG firewall didn't really know how to handle the TAP network adaptor, so I just disabled it and it worked, AVG support is investigating.
0

Featured Post

Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

Join & Write a Comment

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
If, like me, you have a lot of Dell servers in the estate you manage this article should save you a little time. When attempting to login to iDrac on any server I would be presented with two errors. The first reads "Do you want to run this applicati…
Access reports are powerful and flexible. Learn how to create a query and then a grouped report using the wizard. Modify the report design after the wizard is done to make it look better. There will be another video to explain how to put the final p…
This video shows how to remove a single email address from the Outlook 2010 Auto Suggestion memory. NOTE: For Outlook 2016 and 2013 perform the exact same steps. Open a new email: Click the New email button in Outlook. Start typing the address: …

757 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

19 Experts available now in Live!

Get 1:1 Help Now