Solved

iPhone and SBS2003 setup

Posted on 2008-10-13
22
1,945 Views
Last Modified: 2012-05-05
I would give someone $1,000 to solve this for all the trouble I've had setting this thing up.  We have SBS2003 with latest patches.  We have 2 iPhones that can see the Web and login to the OutlookWebAccess via the iPhone on Safari.  I have researched the "restricted IP" in the virtual directories and checked and unchecked these settings.  I have tested the connection with an iTouch.  I have gotten to the point where my iTouch - yes, I said iTouch, can SEE the server if I am on my wireless at home viewing the server from afar.  I get the same message - "The connection to the server failed".  I use the sytax for the server location as "http://remote.companyname.com/exchange/username".  The DNS is set up to route this to the OWA server with Sharepoint and Companyweb running.   I have tried "http://remote.companyname.com/remote" as one would do in our system to login to the OWA but the same message appears.  I had at one point received a Certificate Error but don't recall the settings that gave me that response.  I will award points to the solution that gets this explicitly outlined on the SBS2003 server.  I don't think there is a problem with the iPhones at all - and I'm not a MAC fan by any means - that's just the facts!
0
Comment
Question by:jdfuller
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 9
  • 8
  • 2
  • +2
22 Comments
 

Expert Comment

by:girfra01
ID: 22722990
oh my god i have the exact same problem and i did exactly the same steps and i had no luck either.
i heard some people saying the you need to run the connection wizard in your SBS and activate Outlook Mobile.

Wich i did btw but still no luck.
It should be simple and thats why i bought this Itouch but now im getting annoyed lol also tha apple dont give a lot of support for that.

0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 22778788
" I use the sytax for the server location as "http://remote.companyname.com/exchange/username".  "

That's not correct.

" I have tried "http://remote.companyname.com/remote" as one would do in our system to login to the OWA but the same message appears."

That's not correct either.

The correct FQDN to connect to your Exchange server is just remote.companyname.com


But first...  Do you have Exchange 2003 Service Pack 2 installed?  That's required.

Jeff
TechSoEasy

0
 

Author Comment

by:jdfuller
ID: 22781862
Yes.  The service pack is installed on the server.  The response I am getting with that string (remote.companyname.com) is that the account no longer shows up as an account to choose from on the iTouch and the POP3 account that I also have configured on the iTouch that used to work now just sits in a loop of showing me my Inbox for a few seconds then shifting the page to the right and the same page comes up, the Inbox for the POP account.  Over, and over.  I used to be able to choose from either account.  Now it goes to the POP account automatically and I can't see the Exchange account.
0
Turn your laptop into a mobile console!

The CV211 Laptop USB Console Adapter provides a direct Laptop-to-Computer connection for fast and easy remote desktop access with no software to install.

 

Author Comment

by:jdfuller
ID: 22781883
I managed to get out of the loop and choose the Exchange account (not sure what is happening with the POP account).  Nevertheless, I still get "Cannot Get Mail - The connection to the server failed."
0
 

Author Comment

by:jdfuller
ID: 22782065
I have opened the following ports.  These ports were not open before but I was told they needed to be opened for the iPhone to work;  Port 587 for SSL (which I have disabled on the iTouch) and 47 and 4125.  Ports 1723, 25, 80, 993 and 443 were already open.  I also allowed access to the default web folder and the microsoft-server-activesync folder beneath it enabling Microsoft Authentication and Basic Authentication on activesync.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 22783186
You don't need port 587.  That's for IMAP configuration, not ActiveSync.

Give this a try then... use https://remote.companyname.com/exchange

That should get you going.

Jeff
TechSoEasy
0
 

Author Comment

by:jdfuller
ID: 22828371
The https://remote.companyname.com/exchange returned the same connection error.  We have asked an "expert" in SBS who has done this before to come in and set this up.  I don't doubt his credentials but after 6 hours we still have no solution.  Before I close this question I would like to know if it is possible at all.  I have heard that it is but have not seen any evidence of late.
0
 
LVL 2

Expert Comment

by:HDanYoo
ID: 22828459
It is possible. I have done it couple month ago.

the IMAP port is 143, open that one to start with, follows these ports: 443,444,
If your are not sure about the FQDN, open the SBS server management and click on To Do List , then go through the steps until you get to enter the FQDN. that will helps you ind out what it should, i not , use remote.compynyname.com.
After that open a browser and try https://remote.companyname.com/exchange to see if you you get a logon screen, if yes, then get your i phone and try remote.companyname.com/exchange with the user name and password.

I suggest that you remove any trial setting that has not work from the phone so you get get confuse.
0
 

Author Comment

by:jdfuller
ID: 22838237
I will try this Thursday, PST. Stand by, please.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 22843559
Huh?

This is a 3G phone right?  So it's not using IMAP.  Its using ActiveSync.  So you only need port 443 open.  (444 is for SharePoint's Companyweb).

However, the point about the "To Do List" is a bit closer.  He's referring to the Configure Email and Internet Connection Wizard (CEICW -- which is linked as Connect to the Internet in the Server Management Console > To-Do List)

A visual how-to for the CEICW is here:  http://sbsurl.com/ceicw

Full networking information about your SBS can be found here:  http://sbsurl.com/msicw

Jeff
TechSoEasy
0
 

Author Comment

by:jdfuller
ID: 22898196
To clarify;  I want to use Active Sync over the internet, not IMAP.  I think from reading the details on the server set up that running Internet Email Setup again from the wizard resets the folder defaults incase you get them messed up trying to make other things work.  When I get to that point I re-run the wizard and it seems to reset things so I can continue other testing.

So far, none of the port openings suggested seem to have made any difference.  I have other ports open for RDP and OWA.

We have since hired another "expert" to make this work.  2 days later - it doesn't work.  So far we have spent over $2,400 to make this work.  I am beginning to believe that it cannot be done.

I 'm convinced within me that it can.  I don't read any literature saying it cannot be done but no literature from Apple/Microsoft showing the details of the configuration.  Each have their own documentation but relate vaguely to the others' setup.  I can understand that to a point but I am running out of options.
0
 
LVL 74

Assisted Solution

by:Jeffrey Kane - TechSoEasy
Jeffrey Kane - TechSoEasy earned 500 total points
ID: 22899124
Of course it can be done.  I've done it plenty of times.  

There is no special setup required on the SBS as long as you've configured it using the wizards.  So Apple's documentation should be all you need.

Jeff
TechSoEasy
0
 
LVL 2

Expert Comment

by:HDanYoo
ID: 22900638
The new Iphone has the active sync that allows you to sync the phone with the computer, I guess that you need the setup the phone to connect the the exchange server on your SBS. I don't think the direct active sync to the computer will allow you to syn through the air.

Connecting the Iphone to the exchange is straight forward and more efficient if your goal is to sync email,contact,calender,task, public folders.
0
 

Author Comment

by:jdfuller
ID: 22911126
OK, Jeff.  I am listening...

What can I use to ensure that I have the proper setup before the iPhone is at fault.?  Are you saying that as long as I have run the Internet and Email Connection Wizard and can reach the OWA with Safari on the iPhone that the Exchange Active Sync should be a go, too?
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 22918430
Essentially, yes.

However, if you are using a self-signed certificate on your SBS, then that needs to get installed on the iPhone.  It normally would be done automatically when you try to access OWA via Safari and get a certificate warning, which you can accept to have the cert installed.

If you have done this, and the phone is still not synching, then I would want to look at the IIS logs on the server to see what is going on.  These are found in C:\Windows\System32\logfiles

Jeff
TechSoEasy
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 22918437
One other thing...

Can you access OMA via Safari?  (ie, https://server.yourdomain.com/oma)

Jeff
TechSoEasy
0
 

Accepted Solution

by:
jdfuller earned 0 total points
ID: 22979291
HERE IT IS!!! The recipe for connecting SBS 2003 to an iPhone (or WIFi iTouch).  Leave the router alone!  Don't touch the Active-Sync directory folders.  As long as you have enabled and can use Outlook Web Access - part of the Wizard set up for the Internet and Email - then...make sure Exchange is at Service Pack 2 (download from Microsoft.  Restart needed.)  WALK AWAY FROM THE SERVER!  On the iPhone - go to Settings/Mail, Contacts, Calendars.  Add Account...  Choose Exchange (you can only configure one for each iPhone).  EMAIL ADDRESS: Enter the email address you will give others for this account.  SERVER: Enter the remote access website like you would to get to the OWA except no slash after the .com.  The Fully Qualified Domain Name (FQDN) with NO slash anything after the .com or .org, etc.   Don't use http:// or https:// just the [prefix].companyname.com
USER and PASSWORD: Whatever it is to get on the server at when you login on the web or at a workstation tied to the network.  NEXT:  At this point you will get a Certificate error.  ACCEPT it and move on.  Finish the configuration.  You may get another message about the certificate.  ACCEPT it.  Go back to the settings and choose the account you just created and move into the configurations until you get to where you can turn the SSL off.  Back out to the home screen.  All done!  If this doesn't work then you may have other settings already in place elsewhere in the network that prohibit Exchange networking from outside the domain.  Contact your Admin and ask them - SSsssuuup with that!   WARNING!!! Back up your Contacts with a quick sync with iTunes or Outlook BEFORE you set up the Exchange account because the iPhone or iTouch will be wiped with the information on the Exchange server.  Any POP accounts on the iPhone/iTouch will remain intact.  Enjoy!!
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 22981987
Oh... c'mon... that's EXACTLY what I told you in my first comment {http:#22778788}

Jeff
TechSoEasy
0
 
LVL 22

Expert Comment

by:Olaf De Ceuster
ID: 22983202
Agree with Jeff. He answered the question in his first statement. That's why no other experts got involved.  Problem was solved.
The trick is symply not to add the http: . Nothing hard about that.
Credit where credit is due. Give Jeff the points.
Olaf
0
 

Author Comment

by:jdfuller
ID: 22992192
if you look closely you'll see that I gave Jeff full credit as he deserved.  I did ask for explicit direction.  I humbly submit to Jeff's prowess on the subject.  I summarized the answer with complete articulation which is what I would like to see on the subject not to piece the thread together.  Beside's, it is not just the intellectuals that subscribe here.   Us id10t types need lots of love, too.  I was mislead at first  (not by EE but others) which prevented Jeff's answer from working.  Once the folders got cleaned up back to normal it was slick.  I have since done it to two others.  Thanks for the help.
0
 
LVL 74

Expert Comment

by:Jeffrey Kane - TechSoEasy
ID: 22996924
Yes, I guess you did.  Sorry that I missed that.  Thanks!
0

Featured Post

Free Tool: IP Lookup

Get more info about an IP address or domain name, such as organization, abuse contacts and geolocation.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

This article explains how to install and use the NTBackup utility that comes with Windows Server.
Unified and professional email signatures help maintain a consistent company brand image to the outside world. This article shows how to create an email signature in Exchange Server 2010 using a transport rule and how to overcome native limitations …
In this video we show how to create a mailbox database in Exchange 2013. We show this process by using the Exchange Admin Center. Log into Exchange Admin Center.: First we need to log into the Exchange Admin Center. Navigate to the Servers >> Data…
The basic steps you have just learned will be implemented in this video. The basic steps are shown to configure an Exchange DAG in a live working Exchange Server Environment and manage the same (Exchange Server 2010 Software is used in a Windows Ser…
Suggested Courses

632 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question