• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 982
  • Last Modified:

Cannot remove "Read Only" tag from folders

The E:\ partition on my Windows 2003 Server has a "Makino V" folder containing two subfolders.  Users having full read/write privileges for these directories cannot write to them.  The problem appears to be a greyed-out "Read Only" flag on the "Makino V" folder and its two subfolders. As "Adminitrator", I can remove this tag from the Makino folder and from each subfolder and apply the changes, but when I again check properties, the flags are back.  This exact problem is covered in http://mcpmag.com/columns/article.asp?EditorialsID=1213, which refers to Microsoft KnowledgeBase article 326549.  I've followed the advice contained in the magazine article and the KB article, but still have the problem.  I also have tried several variants of the DOS ATTRIB command mentioned without luck.

Any Ideas?
0
dkuras
Asked:
dkuras
1 Solution
 
CarsontlCommented:
As the administrator user, can you remove the folder completely and rebuild it? It sounds like it could be inheriting the permissions from its parent folder.

Go to the security tab in properties on the folder, go to advanced, and under "Add" and "edit" there's a button, does it say:

Inherit from parent the permission entries that apply to child objects. ?

If so, uncheck it, click on "copy" to maintain all the current permissions, and then change the settings you need.
0
 
AzyreCommented:
check under the advanced option in the folder properties (Security) and ensure that the rights are just being inherited back from the parent folder.  You may need to uncheck the inherit permissions check mark to prevent this.

-> didn't read your links but this is probably your issue
0
 
Rob WilliamsCommented:
Try running from a command line:
attrib -R  "E:\Makino V"  /S  /D
to remove the read only attribute on that folder, sub-folders and files.
If the name contains spaces as it appears to, make sure you use the quotes as shown.
You need to be an admin.
0
Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
tenaj-207Commented:
Make sure that the administrator is the Owner of the folder.

This is done by;
1) right click on the folder choose properties
2) go to the security tab
3) click the advance button
4) click on the owner tab
5) highlight the administrator user
6) check the box that says replace owner on subcontainers and objects
7) click the ok button back through the different windows to apply the change
0
 
ShmoidCommented:
Hello dkuras,
I've seen this many times. As the article points out, the fact that the read only box is checked and greyed out does not neccesarily mean that the folder is read only. Just that the tri-mode flag is set. It could be as simple as a view setting for that folder.
Double check BOTH your SHARE level permissions as well as FILE SYSTEM permissions for the users in question. I'll bet one of them is set for read only.
0
 
sk_raja_rajaCommented:
The "-s" in the command below removes the 'System' attribute --
attrib -r -s c:\TheFolder\*.*

You can re-try with just:
attrib -r c:\TheFolder\*.*
OR
CD to the actual folder and try:
attrib -r *.*
0
 
dkurasAuthor Commented:
Thanks
0

Featured Post

Vote for the Most Valuable Expert

It’s time to recognize experts that go above and beyond with helpful solutions and engagement on site. Choose from the top experts in the Hall of Fame or on the right rail of your favorite topic page. Look for the blue “Nominate” button on their profile to vote.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now