• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1017
  • Last Modified:

Disable Hyperlink Warning in Document

I am working with two Word documents that have hyperlinks to each other.  Let's call them Doc #1 and Doc #2.  The hyperlinks are created from each document to bookmarks in the other document.

When I hyperlink from #1 to #2, I can Ctrl-Click and immediately go to the right section.
When I hyperlink from #2 to #1, when I Ctrl-Click I get the following message...

    Hyperlinks can be harmful to your computer and data.  
    To protect your computer, click only those hyperlinks
    from trusted sources.  Do you want to continue?

How can I disable this message <b>within the document files?</b>

I do know how to disable this message by a registry modification.  And, I would make the registry modification if I was the only one to use these documents.  Since #1 and #2 are being created for a wide audience of users, (and I can't make the registry change on their machines), I need some change within the files I send out that will avoid the dialog box warning.
0
LarryAndro
Asked:
LarryAndro
  • 2
  • 2
3 Solutions
 
Joanne M. OrzechManager, Document Services CenterCommented:
Other than the regedit, I think maybe the only way is to set your macro security to low.... but then you could put yourself at risk for a virus.....
0
 
LarryAndroAuthor Commented:
I tried setting the macro security low, out of curiosity, and it had no affect.  I still received the message when going from #2 to #1.
0
 
Joanne M. OrzechManager, Document Services CenterCommented:
hmmm - sorry then... regedit is the only thing I've found....

Maybe you would put an AutoOpen macro in that turns alerts off?  Although I have tried it... just tossing ideas out there




Sub AutoOpen()
   Application.DisplayAlerts = wdAlertsNone
End Sub

Open in new window

0
 
drakcon1Commented:
This behavior occurs regardless of your security level settings. To locate your security level settings, on the Tools menu, point to Macro, and then click Security. To disable the hyperlink warnings in Office 2003 when an HTTP:// or an FTP:// address is used, you must create a new registry sub key.

There is not a universal fix that would stop this on all computers you run the document on; this was design that way to stop the infection of malware and virus activity from automatically launching with a document embedded script.
0
 
LarryAndroAuthor Commented:
Does anyone know why I can hyperlink from doc #1 to doc #2 without the warning?  Because I can, it made me hope there was a setting that could be set, or permissions that could be granted to allow the same hyperlinking from doc #2 to #1.

I'll give time for more responses.  If the registry edit is the only solution, in the morning I will award points.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now