Solved

Initial connect of Outlook client to Exchange server 2007sp1 with Outlook anywhere takes a long time (1,5 minute) auth=ntlm

Posted on 2008-10-13
11
857 Views
Last Modified: 2012-06-22
Hi,

I have a weird problem. When I start my Outlook on a remote site. Outlook connects to my server using Outlook anywhere (rpc over https). The initial connect time is very long (1,5minute).

After this, when Outlook shows connected, everything works very fast.

The authentication is NTLM. On my old server, with Windows 2003 x64, I did NOT have this problem. On my new Windows 2008 x64 server I cannot find the problem.

I have tried disabling ipv6. Did not make any difference.


Anyone can help me out?


Thanks,
Raymond
0
Comment
Question by:Raymond Jansen
  • 6
  • 3
  • 2
11 Comments
 
LVL 15

Expert Comment

by:tenaj-207
ID: 22705951
Try closing Outlook then renaming the ost file located at;
c:\Documents and Settings\<profilename>\Local Settings\Application Data\Microsoft\Outlook

This will force the machine to recreate the OST file which may be corrupt.  Also, how big is your OST file?  Every time you start Outlook it checks to make sure that you have a good OST file and if it's huge you might see an improvement if you archived some of your data.

-t


0
 
LVL 7

Author Comment

by:Raymond Jansen
ID: 22706360
Thanks, I will try this tomorrow. I'm at the server location now. My ost is not so big, it is 100Mb now.

Raymond
0
 

Expert Comment

by:redsoxunixgeek
ID: 22708981
Try disabling NTLM and Changing to Basic. Also you should verify what Authentication Method you are using server side.

You didnt mention which Version of Outlook you were using - if you are using 2007 all you need to do is match the version running server side - if you are running 2k3 - make sure you use basic as NTLM might work - but more often than not requires basic.

http://msexchangeteam.com/archive/2007/11/08/447484.aspx

THis will help you check your authentication methods within Exchange http://technet.microsoft.com/en-us/library/bb124149.aspx
0
 

Expert Comment

by:redsoxunixgeek
ID: 22708991
You can also do some additional troubleshooting  by locating the Exchange Icon within the System Tray and holding down your Ctrl Key and Right Clicking on it - then select "Connection Status" this will show you the RPC Process and the Negotiation and what Directory Server you are using.
0
 
LVL 7

Author Comment

by:Raymond Jansen
ID: 22710040
@tenaj: My ost is rebuild, but connecting still takes a long time.

@redsoxunixgeek: I will try both and get back to you. Thanks! BTW I use Outlook 2007.


0
IT, Stop Being Called Into Every Meeting

Highfive is so simple that setting up every meeting room takes just minutes and every employee will be able to start or join a call from any room with ease. Never be called into a meeting just to get it started again. This is how video conferencing should work!

 
LVL 7

Author Comment

by:Raymond Jansen
ID: 22710054
@redsonunixgeek:

Connection status shows connected with https to my server for all items (5).


I will try to switch to basic, but I need some time for that. I'll get back to you for that. Thanks,

Raymond
0
 
LVL 7

Author Comment

by:Raymond Jansen
ID: 22711472
I changed server and client to basic authentication now. However, it still takes a long time before Outlook 2007 askes for a password. When I finally can enter the password, Outlook shows connected within seconds.

I still have no clue why it takes so long to ask for a password. Status is trying to connect.

I can use the webmail interface without problems.


Raymond
0
 
LVL 15

Expert Comment

by:tenaj-207
ID: 22712818
Have you reviewed the logs on the server?
0
 
LVL 7

Author Comment

by:Raymond Jansen
ID: 22725282
Hi,

Sorry for the late reply. I have gone through the logs. When I logon I can see nothing special in the logs. I'm gessing I have to live with the delay, or go back to Windows server 2003 x64.

Raymond
0
 
LVL 15

Accepted Solution

by:
tenaj-207 earned 500 total points
ID: 22727001
Perhaps the issue is with a conflict with another piece of software.

Just for testing purposes open up msconfig (start > run > msconfig) go to the startup tab and remove everything.  Then go to the services tab check the box to hide Microsoft services and uncheck everything there too.  Then reboot and retest you connection to Outlook.  

It could be that your AV or Anti-Spyware software is causing the delay.
0
 
LVL 7

Author Comment

by:Raymond Jansen
ID: 22738041
Tried this also. No luck. I'm going away for a week, so I close this. Thanks for your help tenaj!
0

Featured Post

Why do Marketing keep bothering you?

Is your marketing department constantly asking for new email signature updates? Are they requesting a different design for every department? Do they need yet another banner added? Don’t let it get you down! There is an easy way to manage all of these requests...

Join & Write a Comment

Utilizing an array to gracefully append to a list of EmailAddresses
Follow this checklist to learn more about the 15 things you should never include in an email signature from personal quotes, animated gifs and out-of-date marketing content.
This tutorial will walk an individual through configuring a drive on a Windows Server 2008 to perform shadow copies in order to quickly recover deleted files and folders. Click on Start and then select Computer to view the available drives on the se…
This tutorial will walk an individual through the process of transferring the five major, necessary Active Directory Roles, commonly referred to as the FSMO roles to another domain controller. Log onto the new domain controller with a user account t…

743 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

9 Experts available now in Live!

Get 1:1 Help Now