Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
?
Solved

Problems starting/accessing IOS images on Dynamips/Dynagen

Posted on 2008-10-13
6
Medium Priority
?
1,318 Views
Last Modified: 2012-05-05
I'm trying to start the "simple2.net" lab on Dynamips/Dynagen but getting the same error on Vista and XP entire code attached below, basically it gets stuck at the last line

C7200 'Leela': starting simulation (CPU0 PC=0xffffffffbfc00000), JIT enabled.

this is the entire output


****************************
Cisco Router Simulation Platform (version 0.2.8-RC2-x86)
Copyright (c) 2005-2007 Christophe Fillot.
Build date: Nov  9 2007 09:54:39

ILT: loaded table "mips64j" from cache.
ILT: loaded table "mips64e" from cache.
ILT: loaded table "ppc32j" from cache.
ILT: loaded table "ppc32e" from cache.
Hypervisor TCP control server started (port 7200).
Shutdown in progress...
Shutdown completed.
CPU0: carved JIT exec zone of 16 Mb into 512 pages of 32 Kb.
NVRAM is empty, setting config register to 0x2142
C7200 instance 'Zapp' (id 0):
  VM Status  : 0
  RAM size   : 64 Mb
  IOMEM size : 0 Mb
  NVRAM size : 128 Kb
  NPE model  : npe-400
  Midplane   : vxr
  IOS image  : \Program Files\Dynamips\images\c7200-jk9s-mz.124-13b.bin

Loading ELF file '\Program Files\Dynamips\images\c7200-jk9s-mz.124-13b.bin'...
ELF entry point: 0x80008000

C7200 'Zapp': starting simulation (CPU0 PC=0xffffffffbfc00000), JIT enabled.
CPU0: carved JIT exec zone of 16 Mb into 512 pages of 32 Kb.
NVRAM is empty, setting config register to 0x2142
C7200 instance 'Kif' (id 2):
  VM Status  : 0
  RAM size   : 64 Mb
  IOMEM size : 0 Mb
  NVRAM size : 128 Kb
  NPE model  : npe-400
  Midplane   : vxr
  IOS image  : \Program Files\Dynamips\images\c7200-jk9s-mz.124-13b.bin

Loading ELF file '\Program Files\Dynamips\images\c7200-jk9s-mz.124-13b.bin'...
ELF entry point: 0x80008000

C7200 'Kif': starting simulation (CPU0 PC=0xffffffffbfc00000), JIT enabled.
vtty_tcp_waitcon: bind: Operation not permitted
CPU0: carved JIT exec zone of 16 Mb into 512 pages of 32 Kb.
NVRAM is empty, setting config register to 0x2142
C7200 instance 'Leela' (id 1):
  VM Status  : 0
  RAM size   : 64 Mb
  IOMEM size : 0 Mb
  NVRAM size : 128 Kb
  NPE model  : npe-400
  Midplane   : vxr
  IOS image  : \Program Files\Dynamips\images\c7200-jk9s-mz.124-13b.bin

Loading ELF file '\Program Files\Dynamips\images\c7200-jk9s-mz.124-13b.bin'...
ELF entry point: 0x80008000

C7200 'Leela': starting simulation (CPU0 PC=0xffffffffbfc00000), JIT enabled.



********************************


Her's the out put from Dynagen


*************************************************************
Reading configuration file...

*** Warning:  Starting Zapp with no idle-pc value
*** Warning:  Starting Kif with no idle-pc value
*** Warning:  Starting Leela with no idle-pc value
Network successfully loaded

Dynagen management console for Dynamips and Pemuwrapper 0.11.0
Copyright (c) 2005-2007 Greg Anuzelli, contributions Pavel Skovajsa

=> list
Name       Type       State      Server          Console
Zapp       7200       running    localhost:7200  2001
Leela      7200       running    localhost:7200  2002
Kif        7200       running    localhost:7200  2003
=>

**************************************************

so it looks like it's running, but it's not working

and here's the .net file config


***********************************************************
# Another simple dynagen configuration file
#
# All the f0/0 interfaces are on VLAN 1 and the F1/0 interfaces are on VLAN 2

[localhost]

    [[7200]]
    image = \Program Files\Dynamips\images\c7200-jk9s-mz.124-13b.bin
    # On Linux / Unix use forward slashes:
    # image = /opt/7200-images/c7200-jk9o3s-mz.124-7a.image
    npe = npe-400
    ram = 64
   
    [[ROUTER Zapp]]
    console = 2001
    f0/0 = LAN 1
    f1/0 = LAN 2

    [[ROUTER Leela]]
    console = 2002
    f0/0 = LAN 1
    f1/0 = LAN 2
   
    [[ROUTER Kif]]
    console = 2003
    f0/0 = LAN 1
    f1/0 = LAN 2

****************************************************

When trying to telnet on with Putty to port 2001, 2002 or 2003 I get only this far

*************************
Connected to Dynamips VM "Zapp" (ID 0, type c7200) - Console port
*************************

What can be wrong?

Bad IOS image? Memory allocation?

Please advise

Thank you

0
Comment
Question by:piotrmikula108
  • 3
  • 2
6 Comments
 
LVL 23

Accepted Solution

by:
that1guy15 earned 1500 total points
ID: 22706875
Have you looked into GNS3 yet. Simplifies the set up alot. Very great product. Plus it also supports PIX/ASA.

check it out
www.gns3.net
0
 
LVL 1

Author Comment

by:piotrmikula108
ID: 22707347
yea, I have, it was not working in the beggining but now it started working..very strange..I think it didn't like some of the IOS images I had use before. Now it crashes when I try to open the sample labs, but works when I create my own topology
0
 
LVL 23

Expert Comment

by:that1guy15
ID: 22707381
Strange. I have noticed i have several images that it dosent like but i dont know if that is GNS3 or the image.

Are you running the latest version of GNS3?
0
Microsoft Certification Exam 74-409

Veeam® is happy to provide the Microsoft community with a study guide prepared by MVP and MCT, Orin Thomas. This guide will take you through each of the exam objectives, helping you to prepare for and pass the examination.

 
LVL 1

Author Comment

by:piotrmikula108
ID: 22707442
yes, the 0.5 BETA, just checked the web site and it looks that is still the latest version
0
 
LVL 23

Expert Comment

by:that1guy15
ID: 22711431
The only other times i have noticed issues with GNS3 is when im running it on vista. Make sure you are running it as administrator and try disabling UAC and windows firewall.
0
 

Expert Comment

by:Wish2Bccie
ID: 24801194
Hello!

Can you please send me the Instruction how does GNS3 three works with Dynagen also need complete instruction how to build CCIE R&S lab through Dynamips and GNS3



Thanks
0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

On Feb. 28, Amazon’s Simple Storage Service (S3) went down after an employee issued the wrong command during a debugging exercise. Among those affected were big names like Netflix, Spotify and Expedia.
This article explains the fundamentals of industrial networking which ultimately is the backbone network which is providing communications for process devices like robots and other not so interesting stuff.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

578 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question