• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 307
  • Last Modified:

How to print locally from and RDP connection

I have a computer running windows xp a 1 location

This client RDP's into the corporate headquarters onto windows 2003 and runs quickbooks off the server.

The question is how can this client print to her local computer via the RDP connection

She needs to print a quickbooks report that she is accessing via RDP off the windows 2003 server and print it to her local printer attched to the windows xp machine at her location.

Is this possible

thanks
0
WestonGroup
Asked:
WestonGroup
  • 2
  • 2
  • 2
1 Solution
 
Oddball_OneCommented:
Open the RDP session and select options- Local resources-Printers. Check the appropriate box and print away
0
 
Oddball_OneCommented:
Open the RDP session and select options- Local resources-Printers. Check the appropriate box and print away
0
 
WestonGroupAuthor Commented:
select options where?  in quickbooks or the RDP session?

how do you select options in the RDP session?
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
SheddingCommented:
This is definitely possible.  It is done all the time.  The first thing you have to do is install the exact print drivers on both machines (the local machine and the remote terminal server).  If the printer is USB, sometimes it has a problem seeing this.  On the local machine do this - This tips is so used by me that I saved it on my local drive to refer to it every once in a while.  This came from microsoft's site.  Do this on the CLIENT'S machine.

To Force all ports (including DOT4) on the client computer to be filtered for redirection. To do this, add a DWORD value named FilterQueueType to HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR and set its value data to FFFFFFFF.

Follow these steps, and then quit Registry Editor:
1)      Click Start, click Run, type regedit, and then click OK.
2)      Locate and then click the following key in the registry:
3)      HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Default\AddIns\RDPDR  
4)      On the Edit menu, point to New, and then click DWORD Value.
5)      Type FilterQueueType, and then press ENTER.
6)      On the Edit menu, click Modify.
7)      Type FFFFFFFF, and then click OK.
This enables all ports on the client to be redirected.



0
 
SheddingCommented:
Go to start, run and type MSTSC (that is the RDP Client)

Go to options

Click on Local resources

and make sure that the printer box is checked.  Normally this is on by default I believe.
0
 
WestonGroupAuthor Commented:
I installed the drivers on both the local printer and the server (rdp connection) and it didn't work

the printer locally is a tcp/ip connection  it has a internal ip address of 192.168.1.39  

I didn't know how to install it on the server so I gave it the same ip address....what is the proper way to do it on the server as whatever I did , didn't work?

Thanks

0

Featured Post

Get quick recovery of individual SharePoint items

Free tool – Veeam Explorer for Microsoft SharePoint, enables fast, easy restores of SharePoint sites, documents, libraries and lists — all with no agents to manage and no additional licenses to buy.

  • 2
  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now