Solved

Slow internet sharing while network runs great...

Posted on 2008-10-13
12
776 Views
Last Modified: 2012-05-05
Hello,

I have the following setup:

Server 1:  
-Win2008 Standard is the domain controller/active directory..etc..the whole works.
-High Speed internet connection (shared) on port 1
-Local network runs on port 2

Server 2: Win2003 SBS (SBS part is not really setup) runs the business application..

Although there are no issues with network performance, no errors and LAN runs great (using Netgear ProSafe gigabits switch) the internet seems to drag..

Even when opening browser from the 2008 server it takes a while for page to load initially, also from clients and other server on the network Internet seems to be very slow to load.. once it loads it works fine and if i were to download something it pulls off with decent speed but that initial time from opening a page or changing from site to site it takes very long..
I tested it by plugging in directly to internet and it's not the internet problem but most likely has something to do with server 2008.

Prior to installing 2008 to run things i had 2003 sbs and that worked great.. so once again all indicators point to something wrong in the windows 2008 server.

I checked DNS stuff (used OpenDNS and without) and no change..

Because of this pesky problem we are not able to enjoy fully the newly improved gigabits setup.:(
 
0
Comment
Question by:kharkovyy
12 Comments
 

Expert Comment

by:ckness
ID: 22708184
still would lean towards a dns problem,  also dont beleive smb can integrate with 2008 server would be two seperate domains.  dns should always be the activedirectory server, but what happens when you manulay configure a client with a external dns ... clear cache first  ipconfig /flushdns  

0
 
LVL 1

Author Comment

by:kharkovyy
ID: 22708223
I have the 2003 SBS basically set as another server part of the domain.. so it really doesn't have anything configured on there.. i didn't even install the SBS options.. (infact it didn't let me as you point out it cant be part of another domain)

Basically the 2003 SBS doesn't have anything other than client privileges... there are no dns or dch stuff coming out of that.. in fact for all intensive purposes i can disconnect that and still have slow speeds with that server being out of the picture...

This is my settings on cards of the 2008 server..

Outside Connection (static):
xx.xxx.xx.117
255.255.255.252
xx.xxx.xx.118

Inside Connection (manual)
IP:     192.168.100.2
         255.255.255.0
Gtw: 192.168.100.2

DNS: 192.168.100.2


I will check on the  ipconfig /flushdns   in the meantime
my clients are using DHCP to get all settings .. are you saying i should use manual configuration ?
0
 
LVL 6

Expert Comment

by:carlsiy
ID: 22708377
Check your provider for your upstream and down stream, seems that you have a slow upstream connection. is your connection ADSL?
0
 
LVL 1

Author Comment

by:kharkovyy
ID: 22708571
i did check with them.. infact they mentioned something about that and came in to fix it.. but that still doesn't explain why things work fine when i connect a laptop straight on to the internet bypassing the server 2008...

i have business level cable 8 down / 1 up
0
 
LVL 2

Expert Comment

by:GoBieN
ID: 22710038
In the DNS settings on the 2008 server you can choose to set a forwarding (or something like that) DNS server. You can fill in the ISP's DNS server there, or use the openDNS there. If not filed in, windows server uses the ROOT servers i think.
0
 
LVL 2

Expert Comment

by:GoBieN
ID: 22710046
In fact here is a screenshot of the setting i talk about:
http://www.zdnetasia.com/i/techguide/dns-figK.gif
0
How does your email signature look on mobiles?

Do your employees use mobile devices to reply to emails? With mobile becoming increasingly important to the business world, it is in your best interest to make sure that your email signature looks great across all types of devices.

 
LVL 1

Author Comment

by:kharkovyy
ID: 22711166
The problem occurs even when OpenDNS is filled in to the forwarding zone as shown by the screenshot in the message above.. i did that during my initial setup and since it didn't help i tried without it and no change...
0
 
LVL 2

Expert Comment

by:GoBieN
ID: 22714272
Could you possibly set one of the clients to manual IP settings and set the DNS for the client to ISP/OpenDNS. Check to see if this makes the slowness go away. I'm still convinced that DNS is the culprit.
0
 
LVL 26

Expert Comment

by:lnkevin
ID: 22714713
We need some more info. Here is a bunch of question. Try to answer them as much as you can.

- What browser did you test? Did you try FireFox?
- Any firewall, proxies enable in this server since the box is SBS? Windows firewall needs to be disable.
- What Anti Virus software is running on the box?
- Did you run speed test yet? http://www.dslreports.com/speedtest?flash=1
- Can you run trace route to google and post its result?
- Check your network property and make sure ipV6 is not checked. If you can, highlight IPv6 and click Uninstall.

K
0
 
LVL 1

Author Comment

by:kharkovyy
ID: 22715617
Hello,
First of all let me clarify that the 2003 SBS server is not in play here.. i only mentioned it as it is a part of the overall setup. But the services on that server are NOT configured it is simply a server 2003 machine connected to the main 2008 server.. The 2003 is running nothing other than file sharing..
------------------------------------------
- I tried Firefox (latest) Internet Explorer... with clients.. used mac os browsers.. same thing
- Firewall on Windows 2008 is shut off completely
- I'm running TrendMicro Worry Free Business Security.. (which is pretty much the old Server/Client suite)
- Speed test (on firefox)  shows the following (once it loads which takes like 20 sec)
  ::::: San Francisco: ::::Latency to Server: 45ms | Download Speed: 2453kb/s | Upload: 871kb/s
  ::::::Chicago::::::: Latency to Server:  132 |  Download Speed: 5945kb/s  |  Upload: 1223 Kb/s
-  Traceroute from one of the clients to google.com (connected to the Win2008 Server):

traceroute: Warning: www.google.com has multiple addresses; using 208.69.36.231
traceroute to google.navigation.opendns.com (208.69.36.231), 64 hops max, 40 byte packets
 1  192.168.100.2 (192.168.100.2)  1.448 ms *  0.897 ms
 2  * * *
 3  ge-7-25-ur01.mishawaka.in.sbend.comcast.net (68.87.204.17)  12.423 ms  44.656 ms  8.333 ms
 4  te-8-4-ur03.mishawaka.in.sbend.comcast.net (68.87.235.9)  8.955 ms  9.387 ms  10.269 ms
 5  te-1-4-ar01.elmhurst.il.chicago.comcast.net (68.87.230.249)  19.010 ms  15.591 ms  13.917 ms
 6  68.86.90.49 (68.86.90.49)  13.630 ms  31.118 ms  13.727 ms
 7  xe-10-0-0.edge1.Chicago2.Level3.net (4.71.248.29)  14.593 ms  12.591 ms  14.586 ms
 8  vlan51.ebr1.Chicago2.Level3.net (4.69.138.158)  13.095 ms vlan52.ebr2.Chicago2.Level3.net (4.69.138.190)  14.195 ms  14.558 ms
 9  ae-6.ebr1.Chicago1.Level3.net (4.69.140.189)  14.374 ms ae-5.ebr2.Chicago1.Level3.net (4.69.140.193)  24.858 ms ae-6.ebr1.Chicago1.Level3.net (4.69.140.189)  25.585 ms
10  ae-1-53.edge3.Chicago3.Level3.net (4.68.101.84)  13.878 ms ae-2-56.edge3.Chicago3.Level3.net (4.68.101.180)  15.715 ms ae-1-55.edge3.Chicago3.Level3.net (4.68.101.148)  13.766 ms
11  * * *
12  * * *
13  fa-9-16.r01.chcgil09.us.ce.gin.ntt.net (128.242.180.46)  17.474 ms  15.900 ms  15.373 ms
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *

- I have disabled IPv6 on both LAN and WAN (i cannot uninstall it for some reason)
0
 
LVL 1

Author Comment

by:kharkovyy
ID: 22716739
OK, it seems as though i got this somewhat pin-pointed..

when i force a client to use local server IP as the dns things seem to pick up...

but now i can't seem to find where in Windows 2008 i can do that so that it is done by default.... because with DHCP enabled the DNS server that get's passed on to my clients is the external ip for some reason..
and there are too many clients to do it by hand...

0
 
LVL 1

Accepted Solution

by:
kharkovyy earned 0 total points
ID: 22716861
OK, i got it.. i went into the Server Options node under the DHCP server settings and changed the ip to be my local IP instead of the static ip i use to access the internet.. for some reason that's what was set there.. although i just did a fairly straight forward install..

I now consider this issue resolved

Thank you for your comments!
0

Featured Post

Integrate social media with email signatures

Is your company active on social media? Do you also use email signatures? Including social media icons in your email signature is a great way to get fans for free. Let all your email users know you’re on social media quickly and easily, in a single click.

Join & Write a Comment

Remote Apps is a feature in server 2008 which allows users to run applications off Remote Desktop Servers without having to log into them to run the applications.  The user can either have a desktop shortcut installed or go through the web portal to…
Possible fixes for Windows 7 and Windows Server 2008 updating problem. Solutions mentioned are from Microsoft themselves. I started a case with them from our Microsoft Silver Partner option to open a case and get direct support from Microsoft. If s…
This tutorial will give a an overview on how to deploy remote agents in Backup Exec 2012 to new servers. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as connecting to a remote Back…
This tutorial will give a short introduction and overview of Backup Exec 2012 and how to navigate and perform basic functions. Click on the Backup Exec button in the upper left corner. From here, are global settings for the application such as conne…

708 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

11 Experts available now in Live!

Get 1:1 Help Now