Solved

How do I connect to NAS running XP under emulator in OS X?

Posted on 2008-10-13
8
818 Views
Last Modified: 2013-11-12
I am running XP under VMWare Fusion inside OS X 10.5, and have a problem connecting to a networked USB hub and HD.  I have a Belkin network USB Hub (F5L009) with an attached USB HD on my network.  On my XP machine I can see the network USB hub and HD just fine, and can connect to the HD.  On the Apple machine, when running OS X, I can likewise see the USB hub and HD just fine, and can connect.  However, when I run XP inside the VMWare emulator I can see the USB hub, but I can't connect to the HD.  The Belkin SW inside the emulated XP knows the MAC address of the hub and also it's IP address.  I can launch a browser inside the emulated XP and the USB hub IP address brings up the hub system information page, showing MAC address, IP address, etc.  

Any idea why the emulated XP won't connect to the HD?  
0
Comment
Question by:desertratr
  • 5
  • 3
8 Comments
 
LVL 3

Expert Comment

by:jp10558
ID: 22711632
Are you NATing the connection for your XP VM? Try Bridging it... Is this something you have to use special software for, or can you just browse to the NAS with Windows Explorer?
0
 

Author Comment

by:desertratr
ID: 22717984
I can't see the NAS with Windows Explorer. The hub uses special software provided by Belkin (hub manufacturer).  I also turned off Windows Firewall, in case that is the problem.  On my regular XP box I use Zone Alarm, and i had to add the hub IP address to ZA's Trusted Zone.  The Windows Firewall automatically was configured to allow the Belkin hub to receive incoming traffic.  Either way, even with that firewall disabled, I can't connect to the hub,  I don't know what bridging is.  

The Belkin SW works fine with the native OS X OS and alows me to connect.  And with XP stand alone it also allows the connection.  It is just inside the emulator I can't connect.  
0
 

Author Comment

by:desertratr
ID: 22718086
One other thing.  In either my XP box or the Mac I can use the hub special SW to connect.  Once connected in XP I can see the HD using Windows Explorer.  I can also connect to the HD using the special SW on my Mac, and likewise see the HD.  Inside the emulated XP I can see the HD but can't connect.
0
Efficient way to get backups off site to Azure

This user guide provides instructions on how to deploy and configure both a StoneFly Scale Out NAS Enterprise Cloud Drive virtual machine and Veeam Cloud Connect in the Microsoft Azure Cloud.

 
LVL 3

Accepted Solution

by:
jp10558 earned 250 total points
ID: 22719946
Bridging is a setting in VMWare (I don't use Fusion, but in Server, Workstation etc it's there) which makes the XP machine be like it's directly connected to the network. The other option is NATed, so it doesn't need it's own IP... Bridged is "better" in this case as you don't have additional complications. Look at the hardware setting inside VMWare Fusion for the network card for the virtual machine.
0
 

Author Comment

by:desertratr
ID: 22727800
Found the network card in VMWare.  NAT was the default.  I switched to Bridge, and it would not even acknowledge the presence of the hub.  However, rebooting the virtual XP it seemed to work.  I can now access the HD on the hub.

Is there any risk, or benefit (other than being able to see HD), from bridging instead of NAT?
0
 

Author Comment

by:desertratr
ID: 22727845
Another question, if you don't mind.  The Belkin hub control SW has a button to request usage of the HD (or any other connected device).  With two XP machines, and one connected to the HD, the other XP machine clicks the Request Use button and a message pops up on the other machine, requesting that machine to disconnect.  That feature does not function with either the Mac or the emulated XP on the Mac.  I connected to the HD from the emulated XP.  I then launched the Belkin control SW and clicked the request use button.  Nothing appeared on the emulated desktop.  I also tried closing the emulator completely and connecting to the HD from the Mac.  No message requesting usa appeared their either.  Any idea how to get the message to 'request use" to appear on the other machine?
0
 
LVL 3

Expert Comment

by:jp10558
ID: 22729851
Hmmm, I'm now actually aware of any issues with running bridged you wouldn't have with your standard physical XP machine. As to the special software? I'm not sure why you would need to request use, most NASs handle multiple connections at a time just fine...
0
 

Author Comment

by:desertratr
ID: 22753870
I am using the term NAS loosely.  It is really just a USB HD on the hub.  There is no traditional NAS security.  I set up three logical partitions, one for each family member.  All three can see all partitions.  The Belkin SW only allows a single connection, and offers the ability to for a user to request the currently logged in user to disconnect, thus allowing the other user to connect.  

I have an old desktop relic running XP I picked up as surplus from my employer.  I plan to install Server on it and make it a true NAS.  That is my project over the Christmas holiday break.  Lots to learn there.  Would I need to install Server, or can XP provide the NAS functionality?
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Hello All, I have been training on Multicast for a while now and whenever I start the topic , I find out that my friends /  Colleagues mention that they do not know how to test Multicast Joins. As most of the multicast would be video traffic and …
Hi there, This article summarizes what you need if you are going to set up your home or small business Network Attached Storage (NAS) to be accessible from the internet. Of course there are configuration differences based on your NAS or router ma…
This Micro Tutorial hows how you can integrate  Mac OSX to a Windows Active Directory Domain. Apple has made it easy to allow users to bind their macs to a windows domain with relative ease. The following video show how to bind OSX Mavericks to …
Two types of users will appreciate AOMEI Backupper Pro: 1 - Those with PCIe drives (and haven't found cloning software that works on them). 2 - Those who want a fast clone of their boot drive (no re-boots needed) and it can clone your drive wh…

813 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

16 Experts available now in Live!

Get 1:1 Help Now