• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 4953
  • Last Modified:

Remote Desktop failure after Service Pack 3

This one is easy to explain, but so far hard to fix.  My systems are all set up to allow Remote Desktop Protocol (RDP) access.  Most of the clients connect from home, and I can do updates and fix issues after hours without using up more Gasoline.  This has worked fine until SP3.  After install of SP3 I can no longer use RDP.  A rollback to pre SP3 and I can get back on.  Add SP3, and again, no RDP.

I tried a chat session with MS.  When I asked the tech "I can no longer connect via RDP to my machine after installation of SP3, can you tell me why?"  His informed answer was, "Most likely because of registry changes made by SP3."  Gee...Ya Think?

A packet sniff (wire shark) of the system shows that it receives the RDP request, it just doesn't seem to respond to it.
0
CEORACE
Asked:
CEORACE
  • 7
  • 4
  • 2
  • +2
1 Solution
 
Mitch1981Commented:
Do you have nvidia video card?
0
 
CEORACEAuthor Commented:
No, it is an Intel Video Card.
0
 
JoWickermanCommented:
Hi

Have you tried to start it with mstsc /admin to launch?
0
New feature and membership benefit!

New feature! Upgrade and increase expert visibility of your issues with Priority Questions.

 
CEORACEAuthor Commented:
No go JoWickerman, I cannot reach it at all.  It never answers the request.  Remove SP3 and it works, add SP3 and it does not.
0
 
Mitch1981Commented:
The nic and video drivers are updated?
Is there the trird-party application in this computer?
0
 
apcsolutionsukCommented:
Remote Desktop Connection

If you have installed the prerelease version of Remote Desktop Client 6.1 (KB 937468), and then install Windows XP SP3, the desktop will continuously display the text "For testing purposes only. Build 2600.xp_sp2_gdr&", and you will not be able to uninstall KB 937468 using Add/Remove Programs.

To avoid this, uninstall KB 937468 before you install Windows XP SP3.

If you have already encountered this issue, follow these steps to remove the test certificate that is responsible for the text message being displayed.
To remove the test certificate

   1.

      Click Start, click Run, type certmgr.msc, and then press ENTER.
   2.

      In the list that appears, find and expand the Trusted Root Certification Authority folder.
   3.

      Within the Trusted Root Certification Authority folder, find and expand the Certificates folder.
   4.

      In the right pane, find and delete all entries named Microsoft Test Root Authority.
   5.

      Restart the computer.

0
 
CEORACEAuthor Commented:
Mitch, Yes all drivers were updated this week.

apc, your response does not cover the issue.  I am not having issues with my client, I am having issues connecting to the other clients.
0
 
JoWickermanCommented:
Is your windows firewall enabled with exceptions?
0
 
CEORACEAuthor Commented:
Jo, I checked all firewalls.  Windows and otherwise.  As I said, I used wireshark to see that the packet requests are coming through, but the system seems to be ignoring them.
0
 
JoWickermanCommented:
Hi,

Try this:

Solution:
- Stop the process mstsc.exe
- Create a new folder "RDP" in %windir%
- Copy "mstsc.exe" and "mstscax.dll" from "C:\Windows\
$NtServicePackUninstall$" to this folder
- Copy the folder "en-US" "from C:\Windows\System32" to this folder
- Copy the "mstsc.exe.mui" and "mstscax.dll.mui" from "C:\Windows\
$NtServicePackUninstall$" to "C:\Windows\RDP\en-US"
- Change shortcut to ""C:\Windows\RDP\mstsc.exe"

At this time it is not possible to reinstall any version of RDP
when SP3 is installed.

Let me know if this works.

Cheers.
0
 
CEORACEAuthor Commented:
JoWickerman I think we got off track here.  I have made the changes, but that does not address the issue.  Let me go over it agin for clarity.

After installing SP3 on "Computer A" it can no longer be controlled remotely by "Computer B".  computer A can still remote control all other machines, it just will not respond when I attempt to control it.

I do appreciate your help.
0
 
JoWickermanCommented:
Hi,

I've understand what you're trying to say, thanks for explaining it again. I was pretty sure that if you do this on both PC's that it'll sort out the issue as this only reverts back to the older version of Remote Desktop without uninstalling the entire XP SP3.

I'll see if I can find something else.

Cheers.
0
 
CEORACEAuthor Commented:
I am awarding the points to JoW for the time and effort, turns out the IPSEC service had to be turned off.  I finally called MS and their tech had me disable, (NOT JUST TURN OFF) but disable the firewall service and the IPSEC service and it came back up.

0
 
CEORACEAuthor Commented:
Thanks for all your work.
0
 
sholomCommented:
None of the above answers work.

The correct answer can be found here.
http://www.aussieitguy.com/blog/?p=17

0

Featured Post

Free Tool: Site Down Detector

Helpful to verify reports of your own downtime, or to double check a downed website you are trying to access.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 7
  • 4
  • 2
  • +2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now