Solved

IE7 Run-once is corrupt and keeps loading everytime you open IE

Posted on 2008-10-14
4
1,502 Views
Last Modified: 2013-12-12
Hi,

I need some help please!

I have created a image of one of our workstations and deployed it to a couple of new workstations.  When i logon for the first time with a network account IE7 loads in the usual manor and presents the Run-Once screen.  I select the options we like, as usual and click save, but the options do not save and the page says "Settings were not able to be saved successfully".  The page is corrupt... the little yellow warning sign appears in the bottom left hand cornder of the IE7 window.

I have read a few articles about changing the registry settings to force runonce not to show, so i did this and run once doesn't show, but now I cannot change any of the search providers for the IE7.  For instance run once doesn't show, but when i click in the top right hand corner to go to the MS page where you select search provders for the intergrated search bar the page that loads is also corrupt and doesn't allow me to change the search provider.

I would like to have IE7 working fully so i can create a new image and then deploy this to the next lot of machines.  Otherwise it means an uninstall and reinstall on each new machine that i configure wit the current image.

Please help ASAP!
0
Comment
Question by:healthfoundation
  • 2
4 Comments
 
LVL 97

Expert Comment

by:war1
ID: 22712312
Hello healthfoundation,

Search is not showing because of the image, or because your registry edit corrupted something.

Starting from the beginning, run this script to fix the Runonce problem
http://enhanceie.com/dl/NoRunOnce.reg

Check if you still have the Search problem.

Hope this helps!
war1
0
 

Author Comment

by:healthfoundation
ID: 22719042
That script just edits the same registry entries as i have already edited.

The result being that RunOnce doesnt appear but it is then not possible to change the search provider.

Anyone have any ideas?
0
 
LVL 16

Expert Comment

by:ThinkPaper
ID: 22730998
have you tried using group policy to disable the runonce?

http://www.microsoft.com/downloads/details.aspx?FamilyID=11ab3e81-6462-4fda-8ee5-fcb8264c44b1&displaylang=en

I believe it is under:
Computer Configuration>Admin Templates>Windows Componenets>Internet Explorer>
Prevent performance of First Run Customize settings - enabled, go directly to home page
0
 

Accepted Solution

by:
healthfoundation earned 0 total points
ID: 22766512
I've just reinstalled it now, not set any of the run once info and then taken another image.  When the new image is deployed the runonce works.
0

Featured Post

Comprehensive Backup Solutions for Microsoft

Acronis protects the complete Microsoft technology stack: Windows Server, Windows PC, laptop and Surface data; Microsoft business applications; Microsoft Hyper-V; Azure VMs; Microsoft Windows Server 2016; Microsoft Exchange 2016 and SQL Server 2016.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Let’s list some of the technologies that enable smooth teleworking. 
SSL stands for “Secure Sockets Layer” and an SSL certificate is a critical component to keeping your website safe, secured, and compliant. Any ecommerce website must have an SSL certificate to ensure the safe handling of sensitive information like…
This Micro Tutorial will demonstrate how to add subdomains to your content reports. This can be very importing in having a site with multiple subdomains.
Shows how to create a shortcut to site-search Experts Exchange using Google in the Chrome browser. This eliminates the need to type out site:experts-exchange.com whenever you want to search the site. Launch the Search Engine Menu: In chrome, via you…

863 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

25 Experts available now in Live!

Get 1:1 Help Now