Solved

Can not publsih website using IIS 6.0

Posted on 2008-10-14
10
283 Views
Last Modified: 2012-05-05
I have a webiste that will not show using IIS on Windows 2003.  The website is using ASP.net.  When I tried on a Windows XP box it worked fine.  I have checked the permission for ASP.net in IIS and changed to Permit and is still does not work.  It just gives and error of Page Cant be Displayed.  

I have tried to go to it via IE and would get Page Cant be Displayed.  I have also right clicked on the website and clicked on Browse and would get a prompt for credentials, I put them in and would get Page cant be Displayed.

More information:  I am publishing the website on a Crystal Reprots server.  Everything with Crystal Reports website works successfully.  I have also tried publish the website on a different Windows 2003 box with no luck.

Any help would be much appreciated.

Thanks,

Omar
0
Comment
Question by:mhmservices
  • 6
  • 4
10 Comments
 
LVL 10

Expert Comment

by:tboy6423
ID: 22711020
Have you looked at the Httperrlog_number.log in C:\WINDOWS\system32\Logfiles\HTTPERR? It should give you a better idea of why you cannot view it.
0
 

Author Comment

by:mhmservices
ID: 22711079
This is what I see in the log file and it is not too helpful:

#Date: 2008-10-13 21:25:17
#Fields: date time c-ip c-port s-ip s-port cs-version cs-method cs-uri sc-status s-siteid s-reason s-queuename
2008-10-13 21:25:17 10.1.1.25 2097 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-13 21:27:42 10.1.1.163 4717 10.1.1.122 80 - - - - - Timer_ConnectionIdle -

Any ideas?

Thanks,

Omar
0
 
LVL 10

Expert Comment

by:tboy6423
ID: 22711135
Set the IIS on the server to "All Unassigned"
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 

Author Comment

by:mhmservices
ID: 22711139
This is the log from a different day:

#Date: 2008-09-30 16:34:10
#Fields: date time c-ip c-port s-ip s-port cs-version cs-method cs-uri sc-status s-siteid s-reason s-queuename
2008-09-30 16:34:10 10.1.1.25 2398 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-09-30 16:34:42 10.1.1.175 1149 10.1.1.122 80 HTTP/1.1 GET / 400 - Hostname -
2008-09-30 16:36:38 10.1.1.122 2708 10.1.1.122 80 HTTP/1.1 GET /CrystalReportDatabase/WebPages/Reports 400 - Hostname -
2008-09-30 16:48:06 10.1.1.25 4011 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-09-30 16:51:19 127.0.0.1 4381 127.0.0.1 80 HTTP/1.1 GET / 400 - Hostname -
2008-09-30 16:52:13 127.0.0.1 4498 127.0.0.1 80 HTTP/1.1 GET / 400 - Hostname -
2008-09-30 16:52:18 127.0.0.1 4503 127.0.0.1 80 HTTP/1.1 GET /Default.aspx 400 - Hostname -
2008-09-30 16:57:00 10.1.1.175 1231 10.1.1.122 80 - - - - - Timer_ConnectionIdle -
2008-09-30 16:57:00 10.1.1.175 1232 10.1.1.25 80 - - - - - Timer_ConnectionIdle -
2008-09-30 17:57:55 10.1.1.175 1706 10.1.1.122 80 - - - - - Timer_ConnectionIdle -
2008-09-30 18:01:35 10.1.1.175 1744 10.1.1.122 80 - - - - - Timer_ConnectionIdle -
2008-10-09 20:03:53 10.1.1.25 2514 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:04:01 10.1.1.25 2531 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-09 20:04:06 10.1.1.25 2542 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:04:58 10.1.1.25 2648 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:05:03 10.1.1.25 2657 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-09 20:05:13 10.1.1.25 2683 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-09 20:05:26 10.1.1.25 2708 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:06:18 10.1.1.25 2811 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-09 20:07:56 10.1.1.25 3000 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-09 20:08:25 10.1.1.25 3066 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:10:21 10.1.1.25 3293 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:10:21 10.1.1.25 3295 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:10:22 10.1.1.25 3296 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:10:22 10.1.1.25 3297 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:10:22 10.1.1.25 3299 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:10:22 10.1.1.25 3302 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:10:22 10.1.1.25 3303 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:10:22 10.1.1.25 3304 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:10:23 10.1.1.25 3305 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:10:23 10.1.1.25 3306 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:10:23 10.1.1.25 3307 10.1.1.25 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:14:30 127.0.0.1 3791 127.0.0.1 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-09 20:14:34 127.0.0.1 3803 127.0.0.1 80 HTTP/1.1 GET /tt 400 - Hostname -
2008-10-09 20:14:45 10.1.1.25 3822 10.1.1.25 80 HTTP/1.1 GET /TisTest 400 - Hostname -
2008-10-09 20:14:50 10.1.1.25 3832 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-09 20:14:56 127.0.0.1 3846 127.0.0.1 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-09 20:17:03 127.0.0.1 4084 127.0.0.1 80 HTTP/1.1 GET /10.1.1.25 400 - Hostname -
2008-10-09 20:17:08 10.1.1.25 4093 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-09 20:17:46 127.0.0.1 4176 127.0.0.1 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-09 20:42:37 10.1.1.25 3074 10.1.1.25 80 HTTP/1.1 GET /Report 400 - Hostname -
2008-10-10 12:57:47 10.1.1.25 3606 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-10 13:56:51 10.1.1.25 2461 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-10 14:12:47 10.1.1.25 4300 10.1.1.25 80 HTTP/1.1 GET / 400 - Hostname -
2008-10-10 14:17:11 10.1.1.25 4800 10.1.1.25 80 HTTP/1.1 GET /Report 400 - Hostname -
#Software: Microsoft HTTP API 1.0

Thanks,

Omar
0
 
LVL 10

Expert Comment

by:tboy6423
ID: 22711150
0
 

Author Comment

by:mhmservices
ID: 22711771
Unfortunatley I tired all the suggestions in the article with no luck.   I even tried it another server with one NIC card and it gives an error message of the "webpage declined to show this page".  I checked permission and they look good.
0
 
LVL 10

Expert Comment

by:tboy6423
ID: 22711806
Did you restart IIS after the changes?
0
 

Author Comment

by:mhmservices
ID: 22711816
Yes I did.  No luck.
0
 
LVL 10

Expert Comment

by:tboy6423
ID: 22711836
0
 
LVL 10

Accepted Solution

by:
tboy6423 earned 500 total points
ID: 22711896
Also do you have show freindly HTTP error messages selected in internet options, Advanced? If so uncheck it and try the website again. What other messages do you recieve?
0

Featured Post

Netscaler Common Configuration How To guides

If you use NetScaler you will want to see these guides. The NetScaler How To Guides show administrators how to get NetScaler up and configured by providing instructions for common scenarios and some not so common ones.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

A quick step-by-step overview of installing and configuring Carbonite Server Backup.
As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
I've attached the XLSM Excel spreadsheet I used in the video and also text files containing the macros used below. https://filedb.experts-exchange.com/incoming/2017/03_w12/1151775/Permutations.txt https://filedb.experts-exchange.com/incoming/201…

829 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question