Improve company productivity with a Business Account.Sign Up

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 547
  • Last Modified:

Change OWA redirection

Dear All,

When we need to access our Exchange OWA, we have to but the following:

https://mail.me.com/owa

It will open, its ok.

But how can I change that, I need just to keep the users use:

Mail.me.com


And after that, IIS make the redirection and add the HTTPS + /owa

Please help me on that
0
devdept
Asked:
devdept
3 Solutions
 
Andres PeralesCommented:
0
 
Pete LongTechnical ConsultantCommented:
Hello devdept,

Make OWA the Default Web site

Usually to access OWA you need to type http://servername/exchange or http://www.domain_name.com/servername/exchange to get to OWA.

That?s fine and dandy but what if you just want to type http://servername or even better http://OWA this is actually very simple to do.

1.      Log into the Server that hosts Outlook Web Access.
2.      Click Start > Administrative tools > Internet Information Services (IIS) Manager. (note on some machines you may need to access administrative tools through the control panel) or locate the iis.msc file on your server and double click it.
3.      In the left hand Pane expand Internet Information Services > {your_server_name} > Web Sites > Right Click ?Default Web Site? > Properties.
4.      Select the ?Home Directory? Tab you will see at the top there are three choices under ?The content for this resource should come from:? if yours hasn?t been fooled around with the top one will be selected, Change it to select the bottom one ?A Redirection to a URL?. The window below will change and in the ?Redirect to? box will contain ?http://?
5.      Delete ?http://? and replace it with ?/exchange?. The tick the box below that says ?A directory below the URL entered?. Click Apply.
6.      Click ?Select All? > OK.
7.      Click OK.
8.      Back at the IIS Manager > Right Click the Default Web Site > Stop.
9.      Right Click the Default Web Site > Start.

Regards,

PeteLong
0
 
Pete LongTechnical ConsultantCommented:
devdept,

OWA redirect HTTP to HTTPS

TO automatically redirect clients from http://servername/ecchange to https://servername/exchange without throwing the usual 403.4 error at you

1.      In the Inetpub/wwwroot folder create a folder called CustomErrors.
2      Open notepad and paste the following text into it,

-----------------copy all below---------------------
 <%

If Request.ServerVariables("HTTPS")  = "off" Then
                                    Response.Redirect "https://" & Request.ServerVariables("HTTP_HOST") & "/Exchange"
End If

      %>
-----------------copy all above---------------------

Save the file as Owahttps.asp in your CustomErrors Directory.
(Change the save as file type to "All files" or it will save as Owahttps.asp.txt)

3.      On the Web server open IIS administrator (under admin tools)
4.      Expand servername > Web Site > Default Website
5.      Locate the CustomErrors Directory (IN the IIS admin console) > right click > 
properties.
6.      Directory Tab > Application settings section, click Create.
7.      CustomErrors should appear in the "Application Name" box.
8.      IF you are running Exchange 2003 on IIS 6 then change the "Application pool"
Box (click the drop down arrow) to "ExchangeApplicationPool"
9.      Click the Directory Security tab > Authentication and access control section >
Edit.
10.      Tick Enable anonymous access > OK.
11.      Look down to the Secure communications section > Edit.
12.      Untick Require secure channel (SSL) check box, > OK > OK.
13.      Right-click the Exchange virtual directory > Properties.
14.      Click the Custom Errors tab > scroll down to > 403.4 > double click it
15.      Change Message Type to URL > in URL box enter /CustomErrors/Owahttps.asp
> OK.
16.      Click the Directory Security tab > Secure Communications > Edit.
17.      Tick Require secure channel (SSL) check box. (If you want 128 bit tick that too)
> OK > OK

Reference: http://support.microsoft.com/kb/839357/en-us

PeteLong
0
Improve Your Query Performance Tuning

In this FREE six-day email course, you'll learn from Janis Griffin, Database Performance Evangelist. She'll teach 12 steps that you can use to optimize your queries as much as possible and see measurable results in your work. Get started today!

 
CPAsAdminCommented:
IE defaults to http: unless specified in the address line. You would need to remove the "require SSL " on the website for OWA under "Directory Security" --> "Secure Communications" --> "Edit". Not recommended.
0
 
CPAsAdminCommented:
I stand humbly corrected....
0
 
devdeptAuthor Commented:
what about IIS 7, windows 2008... how we can do the same
 
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now