Go Premium for a chance to win a PS4. Enter to Win

x
?
Solved

Cannot Conntact To OMA

Posted on 2008-10-14
36
Medium Priority
?
1,094 Views
Last Modified: 2012-06-27
I cannot connect to Outlook Mobile Access on my domain controller using a mobile device (eg iPhone). Neither can i connect to OMA using any of the workstations on the network when i go to:

https://<SERVER-NAME>/oma

I get the following error, also i cannot stop it using SSL:

Unable to connect to your mailbox on server <SERVER-NAME>. Please try again  later. If the problem persists contact your administrator.
0
Comment
Question by:carlsilver
  • 19
  • 15
  • 2
36 Comments
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22712088
Have a look at the list of Virtual Directories under the Default Web Site in IIS Manager.  Make sure that OMA still exists.
0
 

Author Comment

by:carlsilver
ID: 22712168
"exchange-oma" is listed under "Default Web Site" in IIS
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22712197
exchange-oma is something different.  If you can't see the one called just oma, then you will need to recreate it.  Method 3 is easiest, I think:
http://support.microsoft.com/kb/883380
0
Get your Conversational Ransomware Defense e‑book

This e-book gives you an insight into the ransomware threat and reviews the fundamentals of top-notch ransomware preparedness and recovery. To help you protect yourself and your organization. The initial infection may be inevitable, so the best protection is to be fully prepared.

 

Author Comment

by:carlsilver
ID: 22712239
I have one item called "OMA" - see attached screenshot

oma.jpg
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22712295
What happens if you right-click it, and select Browse?

Can you show us the IIS log entries generated when you do that?
0
 

Author Comment

by:carlsilver
ID: 22712388
When i right click -> browse i get a popup box for my credentials, when i enter them i get the same message:

Unable to connect to your mailbox on server <SERVER-NAME>. Please try again  later. If the problem persists contact your administrator.
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22712451
I need to see the IIS log entries that are generated.  Look for the latest file in C:\Windows\System32\LogFiles\W3SVC1 .  Double-click it, and it will open in Notepad.  Note the times at the left that are in GMT.  A cluster of entries will be generated by your connection to OMA.  Can you copy/paste them for me?
0
 

Author Comment

by:carlsilver
ID: 22712592
I'm having trouble tracking the log entries down. I have a file thats as long as my arm - but i dont see any entries relating to OMA :(
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22712658
They should have GET /oma near the beginning.  If not, look at the properties of the OMA VDir, and make sure that 'Log Visits' is checked. Then at the properties of the Default Web Site, and make sure that 'enable logging' is checked.
0
 

Author Comment

by:carlsilver
ID: 22712693
Logging was disabled on the Default Web Site - i have enabled it now.

Log is:

#Software: Microsoft Internet Information Services 6.0
#Version: 1.0
#Date: 2008-10-14 16:07:19
#Fields: date time s-sitename s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status
2008-10-14 16:07:19 W3SVC1 192.168.1.200 GET /oma - 443 - 192.168.1.200 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648) 401 2 2148074254
2008-10-14 16:07:24 W3SVC1 192.168.1.200 GET /oma - 443 administrator 192.168.1.200 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648) 301 0 0
2008-10-14 16:07:24 W3SVC1 192.168.1.200 GET /oma/oma.aspx - 443 administrator 192.168.1.200 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648) 302 0 0
2008-10-14 16:07:24 W3SVC1 192.168.1.200 GET /oma/oma.aspx - 443 administrator 192.168.1.200 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648) 200 0 0
2008-10-14 16:07:24 W3SVC1 192.168.1.200 GET /favicon.ico - 443 administrator 192.168.1.200 Mozilla/4.0+(compatible;+MSIE+7.0;+Windows+NT+5.2;+.NET+CLR+1.1.4322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.04506.30;+.NET+CLR+3.0.04506.648) 404 0 2
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22713383
Is there anything after GET /oma/oma.aspx (ignoring favicon.ico, of course)?  There should be some requests for /Exchange (or /exchange-oma if you followed KB817379).  If not, look at the Exchange and exchange-oma VDirs, and make sure that 'log visits' is enabled there, too.

If it is already enabled, then you might have another web site on the server that is using port 80 instead of the Default Web Site.  OMA will get upset by that.
0
 

Author Comment

by:carlsilver
ID: 22714918
i just came accross these log entries (attached) which mention the iPod and active sync


log.txt
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22720109
Does this mean that you are running the Default Web Site on port 8080?
0
 

Author Comment

by:carlsilver
ID: 22720198
Yup
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22720299
That is why your OMA does not work.  You can connect to the OMA VDir on port 8080 okay, but OMA then send its own internal WebDAV calls to the /Exchange VDir on port 80 (this can't be changed).  The obvious question now is 'can you get your default web site back on port 80'?  Of course, I expect you have a reason for not doing so, but getting your OMA working now is going to be a bit complicated.  Is there another web site on the same server that does use port 80?
0
 

Author Comment

by:carlsilver
ID: 22720426
"Default SharePoint Website" was on port 80. We changed "Default Web Site" to port 80, now we are getting the following:



Outlook(R) Mobile Access is supported only on Microsoft(R) Exchange Server 2003. Currently your mailbox is stored on an older version of Exchange server. Please contact your system administrator for additional assistance.

Open in new window

0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22720455
I've never seen that message before.  But is what it is saying true?  Is your mailbox on an E2000 server somewhere?
0
 

Author Comment

by:carlsilver
ID: 22720489
We only have this one server running Exchange 2003 SP2
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22720666
Well, I can only Google it, and look at the points raised here:
http://support.microsoft.com/kb/839288

So, the first suggestion is 'The Exchange virtual directory is redirected to a different URL.'  Is that true?  If you go to http://servername/exchange, you should see your OWA GUI.  Also, it should not be redirected to https automatically.
0
 

Author Comment

by:carlsilver
ID: 22720728
http://servername/exchange ALWAYS redirects to httpS://servername/exchange even though i have unticked "Require Secure Channel (SSL)" on the "Default Web Site"
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22720803
But did you leave Require SSL ticked on the Exchange VDir?  The DWS setting can be over-ridden there.
0
 

Author Comment

by:carlsilver
ID: 22721108
Okay, i disabled SSL and i can connect to OWA using http and it does NOT redirect :)

However, http://servername/oma still shows:

Outlook(R) Mobile Access is supported only on Microsoft(R) Exchange Server 2003. Currently your mailbox is stored on an older version of Exchange server. Please contact your system administrator for additional assistance.
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22721171
Can you post the IIS log entries generated when you now try to use OMA?  They should be different to the ones you posted previously.
0
 

Author Comment

by:carlsilver
ID: 22721934
Attached is a copy of the logs

ex08101514.log
0
 

Author Comment

by:carlsilver
ID: 22722531
UPDATE:
We now have OMA working - but still cannot connect our iPhone
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22722634
I see from the IIS log that you have read KB817379 and created the exchange-oma VDir.  You also removed SSL on that?

Anyway, are you trying to connect the iPhone by using ActievSync?
0
 

Author Comment

by:carlsilver
ID: 22722691
SSL on exchange-oma is not enabled. Yes we are trying to use ActiveSync.

What address should we be using for the server address on the iPhone?
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22722737
Usually the public DNS name.  mail.domain.com sort of thing.  No http:// or /exchange or anything like that.
0
 

Author Comment

by:carlsilver
ID: 22722775
we have exchange.domain.com which redirects to our servers external static IP - but this just gives us account verification failed

our email is a POP3 catchall not an SMTP feed
0
 
LVL 5

Expert Comment

by:gambit_642
ID: 22723059
Yes, just use server.domain.com.

Also, make sure that SSL is not required on the /Exchange virtual directory.  While iPhone uses SSL, it still uses WebDav on 80 so you can't force SSL in IIS6 or the iPhone will receive an 403.4 every time it tries to access the WebDav service, which causes failure to auth.

I found this using a script to redirect http to https on 403.4.
0
 
LVL 31

Expert Comment

by:LeeDerbyshire
ID: 22723608
Can you post the IIS log entries generated when you try to use ActiveSync?  You should see requests for 'Microsoft-Server-ActiveSync'.
0
 

Author Comment

by:carlsilver
ID: 22723999
Okay, i managed to connect to OMA outside of our network and it was giving the IIS IP denied error. i went into OMA and ticked "By default all computers will be granted access" and now i can access OMA perfectly fine externally using https://<IP>/oma

However, my iPhone (and iPod) both still say "Exchange account verification failed" no matter what i use as the server IP. i have disabled SSL on OMA and still get the same error
0
 
LVL 5

Expert Comment

by:gambit_642
ID: 22724627
Did you disable on the /Exchange Virtual Dir too?
0
 

Author Comment

by:carlsilver
ID: 22724711
Just tried that now - still same error: "Exchange account verification failed"
0
 

Author Comment

by:carlsilver
ID: 22727782
i think it could be (kinda) talking to the server now, it's now saying exchange account verified, then it says "configured for (null)" and when you go to email there is nothing there.

Attached is the latest logs from IIS

log.txt
0
 

Accepted Solution

by:
carlsilver earned 0 total points
ID: 22729486
UPDATE:


I have resolved this issue. I reinstalled SP2 for Exchange 2003 and the iPhone sync'd up first time!

Thank you to all those that helped! :)
0

Featured Post

Simplify Active Directory Administration

Administration of Active Directory does not have to be hard.  Too often what should be a simple task is made more difficult than it needs to be.The solution?  Hyena from SystemTools Software.  With ease-of-use as well as powerful importing and bulk updating capabilities.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Here in this article, you will get a step by step guidance on how to restore an Exchange database to a recovery database. Get a brief on Recovery Database and how it can be used to restore Exchange database in this section!
Eseutil Hard Recovery is part of exchange tool and ensures Exchange mailbox data recovery when mailbox gets corrupt due to some problem on Exchange server.
This video shows how to quickly and easily add an email signature for all users on Exchange 2016. The resulting signature is applied on a server level by Exchange Online. The email signature template has been downloaded from: www.mail-signatures…
There are cases when e.g. an IT administrator wants to have full access and view into selected mailboxes on Exchange server, directly from his own email account in Outlook or Outlook Web Access. This proves useful when for example administrator want…
Suggested Courses

926 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question