• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 402
  • Last Modified:

How do I fix this phpMyAdmin error?

I'm trying to install phpMyAdmin and I get this error:

Cannot start session without errors, please check errors given in your PHP and/or webserver log file and configure your PHP installation properly.

I ran a test.php file that I'm assuming displays the necessary information needed to identify the problem. The code looks like this:

<?php
error_reporting(E_ALL);
ini_set('display_errors','1');
session_start();
?>

The resulting page from that code is posted as below as a code "snippet." I want to believe this is an easy fix as far as writing out the correct "path," but I don't know how and I'm hoping somebody can point me in the right direction.

Thanks!
Warning: session_start() [function.session-start]: open(C:\DOCUME~1\Bruce\LOCALS~1\Temp\php\session\sess_2ur9lpm8tu8rh53rbahj7hcvp2, O_RDWR) failed: Permission denied (13) in C:\Inetpub\wwwroot\phpMyAdmin\test.php on line 4
 
Warning: Unknown: open(C:\DOCUME~1\Bruce\LOCALS~1\Temp\php\session\sess_2ur9lpm8tu8rh53rbahj7hcvp2, O_RDWR) failed: Permission denied (13) in Unknown on line 0
 
Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\DOCUME~1\Bruce\LOCALS~1\Temp\php\session) in Unknown on line 0
PHP Warning: session_start() [function.session-start]: open(C:\DOCUME~1\Bruce\LOCALS~1\Temp\php\session\sess_2ur9lpm8tu8rh53rbahj7hcvp2, O_RDWR) failed: Permission denied (13) in C:\Inetpub\wwwroot\phpMyAdmin\test.php on line 4 PHP Warning: Unknown: open(C:\DOCUME~1\Bruce\LOCALS~1\Temp\php\session\sess_2ur9lpm8tu8rh53rbahj7hcvp2, O_RDWR) failed: Permission denied (13) in Unknown on line 0 PHP Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct (C:\DOCUME~1\Bruce\LOCALS~1\Temp\php\session) in Unknown on line 0

Open in new window

0
brucegust
Asked:
brucegust
  • 6
  • 3
  • 2
  • +1
3 Solutions
 
Beverley PortlockCommented:
It appears to be a permissions problem. Ensure that the webserver has "write" permissions to the "temp" directory or that the "Temp" directory exists. It seems to be attempting to access "....\Bruce\Local Settings\Temp"

0
 
jazzIIIloveCommented:
Hi there;

You got privilege on the machine? Check for that...

It's better to see under \apache\logs...

Best regards...
0
 
Beverley PortlockCommented:
Did a bit more digging and found this

http://blogs.iis.net/bills/archive/2006/10/18/loadUserProfile-and-IIS7-_2D00_-understanding-temporary-directory-failures.aspx

It seems IIS 6 used \windows\temp, but IIS7 uses a temp directory in a Local directory for each user. By default that directory is not writeable by IIS7
0
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

 
brucegustPHP DeveloperAuthor Commented:
Sorry, guys, if this sounds like a really stupid question, but I'm looking for that "temp" directory and can't find it. Where would I look?
0
 
wktang83Commented:
0
 
brucegustPHP DeveloperAuthor Commented:
wktang83, I di d what you suggested and the temp contents came up fine. The URL is C:\Documents and Settings\Bruce\Local Settings\Temp. Thing is, when I go out to C:\Documents and Settings\Bruce there is no "Local Settings" folder.

I'm assuming that's because it's a hidden folder. How do I "un-hide" it or am I barking up the wrong tree?
0
 
wktang83Commented:
0
 
brucegustPHP DeveloperAuthor Commented:
OK, I was able to find it by clicking on the "Local Settings" menu option that was listed to the left.

Once there, I clicked on "Properties" on the Temp directory and I have available to me: General, Sharing, Security, Web Sharing and Customize.

Where do I go from here?
0
 
brucegustPHP DeveloperAuthor Commented:
No, sorry..

I'm using Windows XP
0
 
brucegustPHP DeveloperAuthor Commented:
OK, I've got the hidden files displayed and I'm back to the comment I made just before your last entry...
0
 
brucegustPHP DeveloperAuthor Commented:
I got it!

I rerouted the temp directory to C:\Windows\Temp using the php.ini file.

Thanks for your help!
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

  • 6
  • 3
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now