• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 572
  • Last Modified:

Lotus out of office schedule

I have edited the out of office agent for an employee to respond on an event instead of a schedule.  I have set the target for responding after mail arrives.
This does not work and instead the out of office agent runs at midnight.
Any ideas as to what I should look into? Thanks
0
NetworkTeam
Asked:
NetworkTeam
  • 3
  • 2
  • 2
  • +1
3 Solutions
 
Sjef BosmanGroupware ConsultantCommented:
The OoO agent is one of the most difficult elements of the mail database and should not be lightly modified. It is not only the visible agent that's working for you, it is also the server that responds to mails arriving. And more.

What do you want exactly, so we can respond to your real question?
0
 
NetworkTeamAuthor Commented:
I want the OoO to respond immediately after mail arrives as opposed to running on a scheduled basis
0
 
brwwigginsIT ManagerCommented:
easiest method would be to convince your management to upgrade to R8 as this is an enhancement from that release. In R8 it is moved to a server (router) based task instead of agents in the database from my understanding
0
Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

 
NetworkTeamAuthor Commented:
we are in the process of moving our servers to R8 however the user in particular is on R6 and probably will be for a fair amount of time.  i have set the OoO agent on other mailboxes to respond on the event of new mail arriving as opposed to the schedule and it works fine
not sure why this persons OoO would be any different
0
 
brwwigginsIT ManagerCommented:
do they have any other agents that run after new mail arrives? I believe you can only have one
0
 
Sjef BosmanGroupware ConsultantCommented:
Please assume that 'they' (read: Lotus) have had pretty good reasons to implement it they way they did. I suppose that the main reason for using a scheduled agent is that it can be managed in a more controlled way: enabling and disabling it are primitive functions to Notes.

If you need the OoO agent to respond quicker, you could try to adjust the intervals it runs on. You can even set it to every 15 minutes or so. You might need to change a server parameter, because the server has a standard setting (I think the minimum interval is 30 minutes or so, not sure).

Conclusion: don't fiddle with the OoO agent's code, but you can adjust the timing or write your own agent.
0
 
SysExpertCommented:
see

http://www.experts-exchange.com/Software/Office_Productivity/Office_Suites/Lotus_SmartSuite/Lotus_Notes/Q_22097129.html

OOO runs 4 times a day by default.

You can either change the agent schedule at your own risk, or create a simpler agent that does work after mail comes in via the Create agent option.


I hope this helps !
0
 
NetworkTeamAuthor Commented:
im not actually editting the code of the OoO
when you first open the OoO agent in domino designer a properties dialog box appears
the bottom of that box includes a section called runtime which will allow you to run the agent on event or a schedule
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

  • 3
  • 2
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now