[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 519
  • Last Modified:

TortoiseSVN connecting to wrong IP

I'm trying to connect to a SVN using TortoiseSVN. I've never used it before to connect to a SVN. However, when I put in a URL to one IP it returns with "root@###.##.###.##'s password, which is a completely different IP. The root password IP is for another server of mine that I've never used with TortoiseSVN. I've uninstalled Tortoise, reinstalled and still the same thing. I've cleared the url cache, log files in TortoiseSVN and still the same error happens. The only thing I can think of is that I also use Putty which has the root IP saved. The IP that TortoiseSVN asks for the password for is only saved in Putty and Dreamwaeaver. Any ideas?
0
phper
Asked:
phper
  • 3
  • 2
1 Solution
 
sh0eCommented:
To clear authentication cache:
Go into TortoiseSVN settings and go to Saved Data.  Clear Authentication Data.
I don't understand what you mean by root IP.  root usually refers to the super-user account, not a dns or IP.


Looks to me like you are trying to Check-Out from an SVN that requires authentication.
Just type in your authentication information.

Or give more information on what it is that you mean when you say it returns "root@###.##.###.##'s password and "root password IP".
What exactly are you being returned with?
0
 
phperAuthor Commented:
In the saved data area in settings only 'URL History', 'Dialog Sizes & Positions' and the 'Action Log' options are enabled. I previously cleared them all and still the following happens.

When I put in the URL as:
svn+ssh://myusername@sdev.domain.com/var/svn/doma/
with domain.com being at IP 111.111.111.11 and myusername not being root.

What comes up is a prompt to input:
root@222.222.222.22's password:
with 222.222.222.22 being my other server, which I've never used with TortoiseSVN.
0
 
sh0eCommented:
svn+ssh is for accessing subversion through ssh.  It uses Putty sessions, so your suspicion that it had something to do with the Putty saved session is correct.

The url format is
svn+ssh://username@puttysession/path

If you are not trying to access svn through ssh, you should be using http:// or svn://
0
 
phperAuthor Commented:
Any idea how to fix this? PuTTY is just an exe, not an installed program so I can't just uninstall it. Plus I use PuTTY.
0
 
sh0eCommented:
Tortoise SVN is simply reading your PuTTy settings.  This is how it works.
Just define a new session in PuTTY for Tortoise SVN to use.
Eg:
Make saved session myssh1 with settings needed to access ssh.
Use url svn+ssh://username@myssh1/path
This is how you are supposed to access svn over ssh, through a PuTTY configured saved session.

Are you trying to access svn through ssh?
If you are not, you should not be using svn+ssh
try svn://sdev.domain.com/var/svn/doma/
or http://sdev.domain.com/var/svn/doma/
0

Featured Post

Hire Technology Freelancers with Gigs

Work with freelancers specializing in everything from database administration to programming, who have proven themselves as experts in their field. Hire the best, collaborate easily, pay securely, and get projects done right.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now