• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 918
  • Last Modified:

Cannot Browse Network Share, Norton Firewall Blocking Network Share

I have a wireless network with several vista home basic machines, several XP machines, and one vista ultimate machine. My network is a workgroup rather than a domain, so there is no server and every user has a matching account on every computer that they need to access over the network.

The vista ultimate machine was recently repartitioned so that it's network share lives on its own partition. Before this change all networking was working perfectly. The new network share has the same name meaning that the change should have been invisible to the rest of network. This was true of the other vista machines on the network, they all connected to the new share seamlessly. The XP machines could not find the new share at first, but after about an hour they found it and connected without a problem. However, one XP machine is being stubborn.

Let's call the Vista Ultimate machine "Alpha", it's network share "Alpha\Share", and the stubborn XP machine "Bravo". Bravo cannot see or connect to Alpha. Bravo cannot browse to Alpha, and if I type "\\Alpha\Share" into file explorer I get an error saying that the location cannot be found. Alpha is explicitly trusted in my Noton Firewall, but as a precaution I disabled the firewall. After doing this Bravo could not see Alpha in its network places, but if I typed "\\Alpha\Share" into the address bar of file exlorer, then Bravo would connect to Alpha. At this point I could turn the firewall back on and everything would be peachy. However, if I log off from Bravo or restart I am back to square one - not being able to see or connect to Alpha. The only way to connect is to turn off the norton firewall and type the "\\Alpha\Share" into file explorer. So I have two questions.
1) Why is norton firewall blocking my connection to Alpha even though its IP address is explicityly trusted?
2) Why can't I browse to Alpha from Bravo, even after I've connected by turing off the firewall and manually typing its share name?
0
qadmin
Asked:
qadmin
  • 6
  • 4
  • 2
  • +1
1 Solution
 
every1isevil2Commented:
you have to create a rule to allow your local network... Also, make sure you enable netbios

But your major problem is NORTON INTERNET SECURITY.... It's a crappy firewall... Settings are WAY too high to the point that it causes problems like these.
0
 
CarsontlCommented:
Switching back to a simpler windows firewall and using User Access Control (UAC) with vista is pretty secure enough, this will keep Norton's firewall's mits off your system and open the gates to your share.
0
 
qadminAuthor Commented:
I have a rule that allows my local network. The entire IP address range of my local network is trusted by Norton Firewall.

NetBios is enabled on all machines.

I agree that Norton firewall is not a good piece of software and I'm open to not using it, but everything was working before the network share of Alpha was placed on its own partition. Bravo can still connect to everyone else on the network, except for Alpha. It seems like there must be a solution to this problem short of disabling the firewall.
0
Improved Protection from Phishing Attacks

WatchGuard DNSWatch reduces malware infections by detecting and blocking malicious DNS requests, improving your ability to protect employees from phishing attacks. Learn more about our newest service included in Total Security Suite today!

 
every1isevil2Commented:
try to disable all firewalls and see if the problem is resolved.
If everything works properly, then turn on one firewall and test... and then the other... this will help you find which firewall is restricting the connection. If it is even the firewall.
0
 
qadminAuthor Commented:
There is only one firewall. I am not using Windows Firewall. The firewall in Norton Internet Security is the only firewall in play. Browsing does not work with or without the firewall. A connection is only possible with the firewall off. So I have two separate problems: 1) Browsing doesn't work, 2) Norton firewall is blocking my connection despite a rule allowing it.
0
 
Darr247Commented:
They're explicitly trusted by range, but how about on the Restricted tab?  I think a single IP (or MAC) there might over ride its inclusive IP range on the Trusted tab.

And how about the AutoBlock in the Intrusion Prevention section?  Try browsing to the share and see if it shows up in AutoBlock for some reason.
0
 
qadminAuthor Commented:
There is nothing in the restricted tab.
I checked the AutoBlock and do not see any entries. But remember I can't brose to the share. The share does not show up in my network places. The only way to reach the share is to disable the firewall then type the share name into file explorer.
0
 
Darr247Commented:
>  checked the AutoBlock and do not see any entries

They only appear there when they're actively being blocked. From there you can sent them to restricted or trusted if you want, or just leave them in autoblock where they'll disappear when you/they stop trying to connect..
0
 
qadminAuthor Commented:
Darr247, thanks for the additional information about AutoBlock. I viewed AutoBlock while actively trying to connect to Alpha and saw no activity.

I was ready to just give up on the Norton firewall so I turned it off and turned Windows firewall on. I got the same exact behavior. With Windows firewall on I could not connect to Alpha. If I turned Windows firewall off I could connect. After connecting I could turn Windows firewall back on and still access the Alpha network share. I still cannot to browse to Alpha\Share ever.

Any more suggestions?
0
 
Darr247Commented:
How about when using the IP address (\\xxx.xxx.xxx.xxx\share) instead of the netbios name?
i.e. with NIS running and enabled.
0
 
qadminAuthor Commented:
Using the IP address (\\xxx.xxx.xxx.xxx\Share) worked. So this seems to indicate that this entire thing is a NetBIOS issue, but I have NetBIOS over TCP/IP enabled on every machine in my network. What else could be responsible for interfering with NetBIOS?

By the way, it turns out that this problem is affecting every XP machine in the network. The other users of the XP machines just hadn't been squeeky wheels up until today.
0
 
Darr247Commented:
If they're all NIS, it's in NIS Options, Personal Firewall, Advanced Settings, Configure button.

Should be at least 6 netbios rules in there that need to be in the correct order (Allow before the corresponding Block), inbound and outbound for each of ports 137, 138 and 139. I remember I added the port number (shows on the Communications tab when you Modify the rule) to the descriptions in mine, and then put them in the order I wanted, but I don't remember what the default order was, mainly because all 6 had essentially the same description before I added their port numbers to their desc's.
0
 
qadminAuthor Commented:
Thanks for sticking with this problem Darr247. After adding all the rules that you reccommended I was able to connect.
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Protect Your Employees from Wi-Fi Threats

As Wi-Fi growth and popularity continues to climb, not everyone understands the risks that come with connecting to public Wi-Fi or even offering Wi-Fi to employees, visitors and guests. Download the resource kit to make sure your safe wherever business takes you!

  • 6
  • 4
  • 2
  • +1
Tackle projects and never again get stuck behind a technical roadblock.
Join Now