Solved

Problems getting DHCP on Cisco Switch

Posted on 2008-10-14
11
968 Views
Last Modified: 2012-05-05
Hello Expert Guys,

I have a Catalyst 6509 that I would like to use. If I use an static IP Address on a client connected to this switch everything goes fine (internet, Outlook, Remote MRP Applications, etc) but If I want to get a dynamic IP Address from our current DHCP server (155.139.1.37) it doesn't assign any IP. The DHCP server is working fine since have other switches connected and getting IPs from this DHCP Server, but I'm having problems with this switch only. I'm getting internet and DHCP Services from the first Fiber Port. Here is the config file:

!
boot system flash 0x2
boot config bootflash:0x2
logging snmp-authfail
enable secret 5 *******************
enable password *******************
!
ip subnet-zero
!
!
!
mpls ldp logging neighbor-changes
no mls flow ip
no mls flow ipv6
mls cef error action freeze
!
!
!
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
dot1x system-auth-control
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
  auto-sync standard
!
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
!
interface GigabitEthernet1/1
 ip address 155.139.1.3 255.255.255.0
 ip helper-address 155.139.1.37
!
interface GigabitEthernet1/2
 no ip address
 shutdown
!
interface GigabitEthernet1/3
 no ip address
 shutdown
!
interface GigabitEthernet1/4
 no ip address
 shutdown
!
interface GigabitEthernet1/5
 no ip address
 shutdown
!
interface GigabitEthernet1/6
 no ip address
 shutdown
!
interface GigabitEthernet1/7
 no ip address
 shutdown
!
interface GigabitEthernet1/8
 no ip address
 shutdown
!
interface GigabitEthernet2/1
 no ip address
!
interface GigabitEthernet2/2
 no ip address
!
interface GigabitEthernet2/3
 no ip address
!
interface GigabitEthernet2/4
 no ip address
!
interface GigabitEthernet2/5
 no ip address
!
interface GigabitEthernet2/6
 no ip address
!
interface GigabitEthernet2/7
 no ip address
!
interface GigabitEthernet2/8
 no ip address
!
interface GigabitEthernet2/9
 no ip address
!
interface GigabitEthernet2/10
 no ip address
!
interface GigabitEthernet2/11
 no ip address
!
interface GigabitEthernet2/12
 no ip address
!
interface GigabitEthernet2/13
 no ip address
!
interface GigabitEthernet2/14
 no ip address
!
interface GigabitEthernet2/15
 no ip address
!
interface GigabitEthernet2/16
 no ip address
!
interface GigabitEthernet2/17
 no ip address
!
interface GigabitEthernet2/18
 no ip address
!
interface GigabitEthernet2/19
 no ip address
!
interface GigabitEthernet2/20
 no ip address
!
interface GigabitEthernet2/21
 no ip address
!
interface GigabitEthernet2/22
 no ip address
!
interface GigabitEthernet2/23
 no ip address
!
interface GigabitEthernet2/24
 no ip address
!
interface GigabitEthernet2/25
 no ip address
!
interface GigabitEthernet2/26
 no ip address
!
interface GigabitEthernet2/27
 no ip address
!
interface GigabitEthernet2/28
 no ip address
!
interface GigabitEthernet2/29
 no ip address
!
interface GigabitEthernet2/30
 no ip address
!
interface GigabitEthernet2/31
 no ip address
!
interface GigabitEthernet2/32
 no ip address
!
interface GigabitEthernet2/33
 no ip address
!
interface GigabitEthernet2/34
 no ip address
!
interface GigabitEthernet2/35
 no ip address
!
interface GigabitEthernet2/36
 no ip address
!
interface GigabitEthernet2/37
 no ip address
!
interface GigabitEthernet2/38
 no ip address
!
interface GigabitEthernet2/39
 no ip address
!
interface GigabitEthernet2/40
 no ip address
!
interface GigabitEthernet2/41
 no ip address
!
interface GigabitEthernet2/42
 no ip address
!
interface GigabitEthernet2/43
 no ip address
!
interface GigabitEthernet2/44
 no ip address
!
interface GigabitEthernet2/45
 no ip address
!
interface GigabitEthernet2/46
 no ip address
!
interface GigabitEthernet2/47
 no ip address
!
interface GigabitEthernet2/48
 no ip address
!
interface GigabitEthernet3/1
 no ip address
!
interface GigabitEthernet3/2
 no ip address
!
interface GigabitEthernet3/3
 no ip address
!
interface GigabitEthernet3/4
 no ip address
!
interface GigabitEthernet3/5
 no ip address
!
interface GigabitEthernet3/6
 no ip address
!
interface GigabitEthernet3/7
 no ip address
!
interface GigabitEthernet3/8
 no ip address
!
interface GigabitEthernet3/9
 no ip address
!
interface GigabitEthernet3/10
 no ip address
!
interface GigabitEthernet3/11
 no ip address
!
interface GigabitEthernet3/12
 no ip address
!
interface GigabitEthernet3/13
 no ip address
!
interface GigabitEthernet3/14
 no ip address
!
interface GigabitEthernet3/15
 no ip address
!
interface GigabitEthernet3/16
 no ip address
!
interface GigabitEthernet3/17
 no ip address
!
interface GigabitEthernet3/18
 no ip address
!
interface GigabitEthernet3/19
 no ip address
!
interface GigabitEthernet3/20
 no ip address
!
interface GigabitEthernet3/21
 no ip address
!
interface GigabitEthernet3/22
 no ip address
!
interface GigabitEthernet3/23
 no ip address
!
interface GigabitEthernet3/24
 no ip address
!
interface GigabitEthernet3/25
 no ip address
!
interface GigabitEthernet3/26
 no ip address
!
interface GigabitEthernet3/27
 no ip address
!
interface GigabitEthernet3/28
 no ip address
!
interface GigabitEthernet3/29
 no ip address
!
interface GigabitEthernet3/30
 no ip address
!
interface GigabitEthernet3/31
 no ip address
!
interface GigabitEthernet3/32
 no ip address
!
interface GigabitEthernet3/33
 no ip address
!
interface GigabitEthernet3/34
 no ip address
!
interface GigabitEthernet3/35
 no ip address
!
interface GigabitEthernet3/36
 no ip address
!
interface GigabitEthernet3/37
 no ip address
!
interface GigabitEthernet3/38
 no ip address
!
interface GigabitEthernet3/39
 no ip address
!
interface GigabitEthernet3/40
 no ip address
!
interface GigabitEthernet3/41
 no ip address
!
interface GigabitEthernet3/42
 no ip address
!
interface GigabitEthernet3/43
 no ip address
!
interface GigabitEthernet3/44
 no ip address
!
interface GigabitEthernet3/45
 no ip address
!
interface GigabitEthernet3/46
 no ip address
!
interface GigabitEthernet3/47
 no ip address
!
interface GigabitEthernet3/48
 no ip address
!
interface GigabitEthernet4/1
 no ip address
!
interface GigabitEthernet4/2
 no ip address
!
interface GigabitEthernet4/3
 no ip address
!
interface GigabitEthernet4/4
 no ip address
!
interface GigabitEthernet4/5
 no ip address
!
interface GigabitEthernet4/6
 no ip address
!
interface GigabitEthernet4/7
 no ip address
!
interface GigabitEthernet4/8
 no ip address
!
interface GigabitEthernet4/9
 no ip address
!
interface GigabitEthernet4/10
 no ip address
!
interface GigabitEthernet4/11
 no ip address
!
interface GigabitEthernet4/12
 no ip address
!
interface GigabitEthernet4/13
 no ip address
!
interface GigabitEthernet4/14
 no ip address
!
interface GigabitEthernet4/15
 no ip address
!
interface GigabitEthernet4/16
 no ip address
!
interface GigabitEthernet4/17
 no ip address
!
interface GigabitEthernet4/18
 no ip address
!
interface GigabitEthernet4/19
 no ip address
!
interface GigabitEthernet4/20
 no ip address
!
interface GigabitEthernet4/21
 no ip address
!
interface GigabitEthernet4/22
 no ip address
!
interface GigabitEthernet4/23
 no ip address
!
interface GigabitEthernet4/24
 no ip address
!
interface GigabitEthernet4/25
 no ip address
!
interface GigabitEthernet4/26
 no ip address
!
interface GigabitEthernet4/27
 no ip address
!
interface GigabitEthernet4/28
 no ip address
!
interface GigabitEthernet4/29
 no ip address
!
interface GigabitEthernet4/30
 no ip address
!
interface GigabitEthernet4/31
 no ip address
!
interface GigabitEthernet4/32
 no ip address
!
interface GigabitEthernet4/33
 no ip address
!
interface GigabitEthernet4/34
 no ip address
!
interface GigabitEthernet4/35
 no ip address
!
interface GigabitEthernet4/36
 no ip address
!
interface GigabitEthernet4/37
 no ip address
!
interface GigabitEthernet4/38
 no ip address
!
interface GigabitEthernet4/39
 no ip address
!
interface GigabitEthernet4/40
 no ip address
!
interface GigabitEthernet4/41
 no ip address
!
interface GigabitEthernet4/42
 no ip address
!
interface GigabitEthernet4/43
 no ip address
!
interface GigabitEthernet4/44
 no ip address
!
interface GigabitEthernet4/45
 no ip address
!
interface GigabitEthernet4/46
 no ip address
!
interface GigabitEthernet4/47
 no ip address
!
interface GigabitEthernet4/48
 no ip address
!
interface GigabitEthernet5/1
 no ip address
!
interface GigabitEthernet5/2
 no ip address
!
interface GigabitEthernet6/1
 no ip address
!
interface GigabitEthernet6/2
 no ip address
!
interface Vlan1
 no ip address
!
interface Vlan2
 no ip address
!
ip default-gateway 155.139.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 155.139.1.1
no ip http server
!
!
!
snmp-server community atlas1 RW
!
!
dial-peer cor custom
!
!
!
!
line con 0
line vty 0 4
 password ************
 login
!
end      

Any help to fix the DHCP issue is really appreciated, Thank Guys! Gustavo.
0
Comment
Question by:thaboloko
  • 4
  • 3
  • 3
  • +1
11 Comments
 
LVL 17

Expert Comment

by:Andres Perales
ID: 22713313
perhaps you are missing the ip helper statement ...
0
 
LVL 50

Accepted Solution

by:
Don Johnston earned 250 total points
ID: 22713427
It would appear that the DHCP server is connected out the g1/1 port. This is a layer 3 interface.

I'm assuming the PC's are connected to the other ports which are in VLAN1.

So the first thing you'll need is a VLAN1 interface with an IP address

Next you'll need a helper-address pointing at the DHCP server. (The helper-address on the g1/1 interface is unnecessary.)

Finally, you'll need to make sure that the DHCP server has a scope defined for the network the PC's are on.


0
 
LVL 3

Assisted Solution

by:JasonTracy
JasonTracy earned 250 total points
ID: 22713434
Backup your config, then try pasting this in there:
!
!
interface GigabitEthernet1/1
no ip address 155.139.1.3 255.255.255.0
no ip helper-address 155.139.1.37
interface Vlan1
ip address 155.139.1.3 255.255.255.0
!
!

If that does not work, turn on portfast for the port that you've got the DHCP client PC in question plugged into with the command:

interface GigabitEthernet1/(whateverport)
 spanning-tree portfast
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22713503
Jason,

You can't have two routed interfaces connected to the same network. You'll get an "ip address overlap" message.
0
 
LVL 3

Expert Comment

by:JasonTracy
ID: 22713558
Donjohnston, you just beat me to it!

However, he shouldn't need the helper-address at all, since it appears that the DHCP server 155.139.1.37 is on the same subnet.
0
PRTG Network Monitor: Intuitive Network Monitoring

Network Monitoring is essential to ensure that computer systems and network devices are running. Use PRTG to monitor LANs, servers, websites, applications and devices, bandwidth, virtual environments, remote systems, IoT, and many more. PRTG is easy to set up & use.

 
LVL 3

Expert Comment

by:JasonTracy
ID: 22713577
Donjohnston,

I didn't.  The first command was removing it from his gi port, the later one adds it to the vlan1.

Although I must warn thaboloko, DO THOSE COMMANDS FROM SERIAL CONNECTION!  Otherwise, the first command will disconnect you from your switch and the others won't work.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22713605
Sorry, I missed the "no" in front of the first couple commands. Mea culpa.


0
 
LVL 2

Author Comment

by:thaboloko
ID: 22715356
I do not have currently access to the switch but I sent your comments to another guy, He made the changes and he is sending me the current conf, supposely based on your comments (still not working):

Current configuration : 8561 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service counters max age 10
!
hostname **********
!
boot system flash 0x2
boot config bootflash:0x2
logging snmp-authfail
enable secret 5 ************
enable password ****************
!
ip subnet-zero
!
!
!
mpls ldp logging neighbor-changes
no mls flow ip
no mls flow ipv6
mls cef error action freeze
!
!
!
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
dot1x system-auth-control
diagnostic cns publish cisco.cns.device.diag_results
diagnostic cns subscribe cisco.cns.device.diag_commands
!
redundancy
 mode sso
 main-cpu
  auto-sync running-config
  auto-sync standard
!
vlan internal allocation policy ascending
vlan access-log ratelimit 2000
!
!
interface GigabitEthernet1/1
 no ip address
 spanning-tree portfast

!
interface Vlan1
 ip address 155.139.1.3 255.255.255.0
 ip helper-address 155.139.1.37
!
interface Vlan2
 no ip address
!
router rip
 network 155.139.0.0
!
ip default-gateway 155.139.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 155.139.1.1
no ip http server
!
!
!
snmp-server community atlas1 RW
!
!
dial-peer cor custom
!
!
!
!
line con 0
line vty 0 4
 password ********
 login
!
end
0
 
LVL 2

Author Comment

by:thaboloko
ID: 22715860
Also we have running correctly another switch that the only difference is this interface, could somebody explain what is this and if I need to add this entry to my bad switch so I can fix the DHCP problem.... (and How)

Cat5500> (enable) set interface sc0 172.16.80.40 255.255.255.0
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22716242
We're going to need a better picture of the topology in order to resolve this. What is the IP address of the DHCP server? Where is it connected? What ports are the PC's connected to?

As for your 5500 question, that command assigns an IP address to the switch for management (telnet, SNMP).
 
0
 
LVL 2

Author Comment

by:thaboloko
ID: 22855659
Thank you Guys, I brought a cisco specialist to our site and fixed the problem, Thanks.
0

Featured Post

How to run any project with ease

Manage projects of all sizes how you want. Great for personal to-do lists, project milestones, team priorities and launch plans.
- Combine task lists, docs, spreadsheets, and chat in one
- View and edit from mobile/offline
- Cut down on emails

Join & Write a Comment

Getting hacked is no longer a matter or "if you get hacked" — the 2016 cyber threat landscape is now titled "when you get hacked." When it happens — will you be proactive, or reactive?
Shadow IT is coming out of the shadows as more businesses are choosing cloud-based applications. It is now a multi-cloud world for most organizations. Simultaneously, most businesses have yet to consolidate with one cloud provider or define an offic…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

22 Experts available now in Live!

Get 1:1 Help Now