RDP from XP to Ubuntu

I am trying to setup a terminal services connection using RDP from a given XP machine to a Ubuntu desktop.  This needs to be terminal services and not VNC - I've already gotten VNC going, but it can be slow at times, as you probably already know.  I can get terminal services going on the Ubuntu machine to the XP machines so there must be a way to do it the other way around.  
LVL 1
AthanmanAsked:
Who is Participating?

Improve company productivity with a Business Account.Sign Up

x
 
iPromoExpertConnect With a Mentor Commented:
http://www.nomachine.com/download-client-windows.php

try that. it works great for me.
0
 
sk_raja_rajaCommented:
1.Activate XDMCP on Ubuntu - SYSTEM >> Preferences >> Remote Desktop - Allow other users to view your desktop - Allow other users to control your desktop 
Install Cygwin/X onto the Windows XP machine. - Download and run setup.exe from http://www.cygwin.com/ - Install the standard packages on Cycwin/X along with :

- X11 > X-Startup-scripts - X11 > xorg-x11-base (this will set a lot of x11 dependencies to install also  you want to install these)

Run Cycgwin
In the Cgywim terminal enter the following command: $ XWin.exe :1.0 -unixkill -scrollbars -screen 0 1280 1024 -emulate3buttons -once -query (NAME / IP) & Put the name of the linux computer or its IP address
You should then see the Ubuntu login page. Voila.
Its possible I installed one or two other things on the Ubuntu system. I dont recall just now as I tried so many other ways to get this functionality working I now forget exactly what was done for what. If you try the above and it does not work, let me know and Ill figure out what else has to go onto the Ubuntu system. I know I installed freeNX although I am not sure if this was for the Cygwin connection or not. If you want to use SSH to Ubuntu via Cygwin there are some instructions here. I tried various SSH related ways of going about this. SSH from Windows directly and SSH via the Cygwin terminal. I kept getting the error that the port was not open. I tried port 177 (which XDCMP users) and 5901 and others, all to no avail. I am not sure how to make these ports available from Ubuntu. But the Xwin route works great.

PS: I cannot help you much on this and i took these instructions from a Forum, please give it a try
0
 
sk_raja_rajaConnect With a Mentor Commented:
You need NXServer, its free. Checkout the forum, your will find lots of info.
http://www.nomachine.com/download.php
0
Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

 
larsgaCommented:
There is an xrdp package available that implements the RDP server side for Linux. (sudo apt-get install xrdp). I am unfortunately unfamiliar with how well it works.

Alternatives are VNC (which you mentioned that you already have running), Nomachine NX and XDMPC/X11 (which were mentioned in the two answers above).
0
 
AthanmanAuthor Commented:
I could not get the NX client to work either way.  after installing it on the windows machine, I installed the server, client and then node on the Ubuntu machine.  I tried to get it going from the windows machine and I get a connection refused error.  With the following details:

NX> 203 NXSSH running with pid: 2264
NX> 285 Enabling check on switch command
NX> 285 Enabling skip of SSH config files
NX> 285 Setting the preferred NX options
ssh: connect to host XXX.XXX.XX.XX port 22: Connection refused

I then allowed incoming traffic on the default SSH port:

sudo iptables -A INPUT -p tcp --dport ssh -j ACCEPT

that didn't help anything so I shut down iptables but I keep getting the same error.  Does anyone have any ideas?
0
 
iPromoExpertCommented:
Are both machines on a local network or are you connecting via internet?
0
 
larsgaConnect With a Mentor Commented:
"ssh: connect to host XXX.XXX.XX.XX port 22: Connection refused"

This is probably caused by one of two things:

1) There is something blocking ssh traffic. Perhaps a firewall on the client or the server, or some network device (NAT router perhaps?) between the machines.

2) sshd is not running on the Ubuntu machine. On the Ubuntu machine, does a logon prompt come up if you do 'ssh localhost'? If it doesn't, you need to install and/or start ssh.
0
 
AthanmanAuthor Commented:
Both machines are definitely on the same network.  

The problem was definitely that ssh was not running on the machine.  For some reason I assumed that it was there by default.  

 

0
 
AthanmanAuthor Commented:
Setting up sshd on the Ubuntu machine nailed it.  
0
 
jgiordanoCommented:
vnc viewer for xp  free version and allow vnc connections in ubuntu
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.