Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1894
  • Last Modified:

Users unable to copy between citrix applications

We currently use Citrix to access our ERP client and some applications such as Excel, and Word. A couple of days ago users started reporting they could no longer copy/paste with Excel. Along with Excel being published in Citrix, we also have published applications that load add-ins for our ERP package along with excel, the add-in Excels are not affected by the copy/paste problem. I've done some testing and determined the following:

1. Copy/Paste to and from other Citrix application aside from Excel works fine.
2. Copy/Paste from other Citrix applications into Excel loaded with add-in works fine.
3. Copy/Paste from basic Excel to other applications doesn't work.

I think there is a mis-configuration inside Citrix for the Excel application, but I haven't noticed anything unusual. Has anyone had this problem before or any ideas?
0
pathix
Asked:
pathix
  • 3
  • 2
1 Solution
 
Ron9909Commented:
From what you are saying, there is no point talking about whether you have clipboard enabled, or any other type of configuration change, as basic clipboard functionality works in some cases.  There is no way to configure individual clipboard settings on an app by app basis.  

However...there have long been issues associated with using the clipboard, and most of these are to do with the clipboard chain - essentially, the clipboard viewer chain is a collection of all the applications that are interested in being notified of any changes to the clipboard.  Each application has to be registered to get notifications, but the problem is that the get these notifications from other apps in the chain.

Can you see the problem here - the chain is managed by the applications themselves, meaning that the apps are responsible for passing on notifications to other apps, and also removing apps from the chain.  I could go on into the mehcanics of what happens here, but suffice to say that this process is flawed and prone to issues.  I'm sorry to say that Office Apps, especially Excel can be prone to clipboard related issues in some circumstances.

With all that said, there could be a number of explanations for what is happening here, so I'd suggest the following (in no particular order):
1. Check for Office updates - you may want to do this on a test server
2. Remove the Excel Add-in and see if you can still reproduce the problem (test server).  Do all users have access to this add-in and are permissions in place to restrict access to it?
3. Check to see what version of the ICA client you are on.  10.1 for example has a few problems, move to 10.2
4. Check to see that when the issue occurs, you are only running a session on one server i.e. not across multiple TS
0
 
pathixAuthor Commented:
I'm thinking something has goten corrupted with excels published application, if I create a new published application with just the excel executable copy/paste works fine.
0
 
Ron9909Commented:
Hmm - that is very peculiar - I've not heard of that one before.  Put it down to one of those unexplained IT twilight zone moments I guess.  Are you saying the problem is now resolved?  
0
 
pathixAuthor Commented:
Yes, I recreated the application and it works.
0
 
Ron9909Commented:
Glad to hear it!  One to look out for in the future.
0

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now