Solved

HTML embed flash not working

Posted on 2008-10-14
6
755 Views
Last Modified: 2010-05-18
I have one flash file that will not work inside my network. When I embed the file in html it opens but when I press play it goes blank. I can embed another flash file and it will auto start. If I take the flash file that does not work and put it on another server outside my network it works.

If I put the url http://www.defelements.com/Yantis/sample.swf in my browser it works but if I embed that in html on my server it will not play.

note: that url is on another server, that is not my server.

>>>>>>>THIS CODE WILL NOT WORK>>>>>>>
<html>
 
<body>
 
	<object width="550" height="400">
<param name="movie" value="http://www.defelements.com/Yantis/sample.swf">
<embed src="http://www.defelements.com/Yantis/sample.swf" width="550" height="400">
</embed>
</object>
 
 
</body>
 
</html>
 
>>>>>>>>>THIS CODE WITH ANOTHER FLASH FILE WILL WORK>>>>>>>
 
<html>
 
<body>
 
	<object width="550" height="400">
<param name="movie" value="http://bytescout.com/demo/swfscout_VideoSample.swf">
<embed src="http://bytescout.com/demo/swfscout_VideoSample.swf" width="550" height="400">
</embed>
</object>
 
 
</body>
 
</html>

Open in new window

0
Comment
Question by:Roy Ortiz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
  • 2
6 Comments
 
LVL 1

Accepted Solution

by:
jarospirit earned 250 total points
ID: 22714894
As you explained the 2 files are working outside the network, I can see them from here too. So the problem is probably on the firewall port.

try opening port: tcp / 5222 and try again.

hope that helps
0
 

Author Comment

by:Roy Ortiz
ID: 22715281
I copied the code to another server at my home and I do not have port 52222 open and it works.

I can embed other flash files and it works on my network.
The flash file that does not work has two files involved to run a .swf and a .flv
the swf  has code embed in it that calles the flv file
0
 
LVL 1

Expert Comment

by:jarospirit
ID: 22716102
are you calling the flv locally or remotely(url).
The server might not have the MIME type for FLV
0
 

Author Comment

by:Roy Ortiz
ID: 22716234
flv running locally.
Were do I setup the MIME type for FLV on my server
0
 
LVL 4

Assisted Solution

by:MattKenefick
MattKenefick earned 250 total points
ID: 22734547
Use SWFObject2.0

code.google.com/p/swfobject
0

Featured Post

Online Training Solution

Drastically shorten your training time with WalkMe's advanced online training solution that Guides your trainees to action. Forget about retraining and skyrocket knowledge retention rates.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Building a website can seem like a daunting task to the uninitiated but it really only requires knowledge of two basic languages: HTML and CSS.
Finding original email is quite difficult due to their duplicates. From this article, you will come to know why multiple duplicates of same emails appear and how to delete duplicate emails from Outlook securely and instantly while vital emails remai…
The goal of the tutorial is to teach the user how to live broadcast using Flash Media Live Encoder and connecting it to YouTube to broadcast. Log into your Youtube account, choose live stream settings, start live stream from Flash Media Live Enc…
The viewer will the learn the benefit of plain text editors and code an HTML5 based template for use in further tutorials.

705 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question