• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 991
  • Last Modified:

cisco asa 5505 - can not connect to internet...

hi, i've got a asa5505, and as a cisco newbie, i tried to configure this on the asdm...no luck so far...

i can ping out using the asdm feature, but when a pc connects to the asa, it can not get out to internet...
right now, i have a static IP configured for my dsl, but the ultimate goal is to have it connect to our cable modem (which takes a dhcp address) wonder how much diff the config would be?

please see below for my config:

Result of the command: "show run"

: Saved
:
ASA Version 8.0(4)
!
hostname ciscoasa
enable password JknXOcF3d.mERF4I encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
name 192.168.90.0 inside description inside network
name 66.92.x.x outside description outside network
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.90.1 255.255.255.0
!
interface Vlan2
 description DSL or Cable
 nameif outside
 security-level 0
 ip address 66.92.x.x 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
boot system disk0:/asa804-k8.bin
ftp mode passive
clock timezone PST -8
clock summer-time PDT recurring
dns domain-lookup inside
dns domain-lookup outside
access-list outside_access_in extended permit ip any outside 255.255.255.0
access-list inside_nat0_outbound extended permit ip inside 255.255.255.0 inside 255.255.255.0
access-list inside_nat0_outbound extended permit ip inside 255.255.255.0 any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-613.bin
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 0.0.0.0 0.0.0.0
nat (outside) 0 inside 255.255.255.0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 66.92.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 0.0.0.0 0.0.0.0 inside
http 0.0.0.0 0.0.0.0 outside
http redirect outside 80
http redirect inside 80
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
auth-prompt prompt Hello
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
no crypto isakmp nat-traversal
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
dhcpd dns 208.67.222.222 208.67.220.220
dhcpd auto_config outside
!
dhcpd address 192.168.90.150-192.168.90.199 inside
dhcpd dns 208.67.222.222 208.67.220.220 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
 enable outside
username dyyuan password m0iHzxXYSsU6CZQv encrypted privilege 15
username dyyuan attributes
 memberof LOCAL
!
class-map inspection_default
 match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
 parameters
  message-length maximum 512
policy-map global_policy
 class inspection_default
  inspect dns preset_dns_map
  inspect ftp
  inspect h323 h225
  inspect h323 ras
  inspect rsh
  inspect rtsp
  inspect esmtp
  inspect sqlnet
  inspect skinny  
  inspect sunrpc
  inspect xdmcp
  inspect sip  
  inspect netbios
  inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:de7c5f72f8812c7d0438d23005949afa
: end
0
dyyuan
Asked:
dyyuan
  • 2
1 Solution
 
MikeKaneCommented:
You will need to add:
access-list inside_access_in extended permit tcp any any eq 80
access-list inside_access_in extended permit tcp any any eq 443
access-group inside_access_in in interface inside


You can probably remove these:
access-list inside_nat0_outbound extended permit ip inside 255.255.255.0 inside 255.255.255.0
access-list inside_nat0_outbound extended permit ip inside 255.255.255.0 any
nat (outside) 0 inside 255.255.255.0

You also dont want anyone on the outside accessing your ASA's http interface, remove this:
route Outside 0.0.0.0 0.0.0.0 12.54.220.161 1



After this, try browsing from the inside.   On the ASA, you can issue a show xlate command at the CLI and you should see the internal IP matched with the external interface IP.    


0
 
dyyuanAuthor Commented:
hmm, i've added those lines, and same results...still can not get out to internet...

0
 
dyyuanAuthor Commented:
it would seem i needed to change my default asa name...was being blocked by the ISP for some reason.
0

Featured Post

Industry Leaders: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now