Solved

Record audio on computer through SPDIF-IN

Posted on 2008-10-14
13
774 Views
Last Modified: 2012-05-05
I have a Soyo KT333 Dragon Ultra mother board with built in PCI audio chip which is Cmedia 8738.  This comes with a header attachement to the MB that gives me coaxial and optical-in and out SPDIF.

However I cannot get the SPDIF-in to work through either the optical or coaxial-in.  The SPDIF-out works fine.  In the mixer software, I select SPDIF-in and I tried two different software to try to record the audio coming in but so far no luck.

Any ideas??

thanks
0
Comment
Question by:jasguild
  • 5
  • 5
  • 2
13 Comments
 
LVL 31

Expert Comment

by:Frosty555
Comment Utility
First thing to troubleshoot:

Go to start->control panel->Sound and audio devices
Go to the Audio tab
In the "Sound Recording" section, make sure the spdif device is selected.
Click the "Volume..." button. The windows mixer will open.
Make sure the appropriate source is ticked for recording.

Next, in your audio recording program, make sure the same device is being used for recording as was specified in the sound properties you set above.

To eliminate the possibility of the problem being in your audio recording program, use SNDREC32.EXE. If you device is correctly setup, it will record properly.
0
 

Author Comment

by:jasguild
Comment Utility
I confirmed that the spdif device (the sound card) was selected under the audio tab.  
HOWEVER, when I click on volume, I dont see SPDIF as an option.  I see stereo mix, microphone, cd audio, aux, line in, wave.  I tried selecting each one but still nothing records . Should SPDIF be listed??  I also clicked on properties and ensrured that those are all volume controls  to select from for recording

Also where do I find sndrec32.exe??

thanks
0
 
LVL 31

Expert Comment

by:Frosty555
Comment Utility
sndrec32 is under start->accessories->entertainment->sound recorder

SPDIF is the protocol, so it wouldn't be listed in the mixer. You probably want line in or aux.-

Are you sure this is actually an input port, and that whatever it is connected to is properly outputting sound out the SPDIF port?
0
 
LVL 31

Expert Comment

by:Frosty555
Comment Utility
Also check drivers, and check if the motherboard came with any special configuration software for the SP/DIF ports. The input spdif port's sampling rate, bitrate, and # of channels must match the source's sampling rate, bitrate, and # of channels or you will not hear anything.
0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
Give Audacity software a try: http://audacity.sourceforge.net/  Here is a post from someone who used it to record digital: http://audacityteam.org/forum/viewtopic.php?f=26&t=2858
0
 

Author Comment

by:jasguild
Comment Utility
I am pretty sure my source is sending out sound because if I take the same spdif connection and connect to my receiver, I can hear it.

But you raised another good question about the sampling rate and number of channels matching.  The audio source I am trying to record from is via my cable box.  I have no idea what the sampling rate and number of channels it is sending and whether it changes depending on whether its a digital, HD or analog channel.  Any idea where I can find that out?  

I will check out the other options you gave me when I get home this evening
0
Complete VMware vSphere® ESX(i) & Hyper-V Backup

Capture your entire system, including the host, with patented disk imaging integrated with VMware VADP / Microsoft VSS and RCT. RTOs is as low as 15 seconds with Acronis Active Restore™. You can enjoy unlimited P2V/V2V migrations from any source (even from a different hypervisor)

 

Author Comment

by:jasguild
Comment Utility
I downnloaded audacity and still no luck.  I got an error message, please check the input source or sampling rate which sounds like what you are saying

 I did not find any place to set the sampling rate for spdif-IN but I found a settings for SPDIF-OUT.  I tried to record using "Line in" and "Aux" still with no luck.

any ideas on where i can set the sampling rate for spdif-IN?

Any other ideas/?

thanks

jas

0
 
LVL 69

Expert Comment

by:Callandor
Comment Utility
Take a look at this thread: http://forum.videohelp.com/topic292388.html - it says it's called "Project Rate" and it's in the bottom left hand corner.
0
 
LVL 31

Accepted Solution

by:
Frosty555 earned 351 total points
Comment Utility
This is a setting that strikes me as a hardware setting, not a software setting. You shouldn't have to set it in audacity, you should have to set it somewhere in control panel or your device's config software / drivers.

Look in Control Panel->Sound + Audio devices->Audio tab and see if the "Advanced..." button for the Sound Recording device is clickable. Inside might be some more settings.

Otherwise... did the motherboard come with any special audio-related applications? Perhaps a new item in Control Panel? Or a custom "mixer" utility?
0
 

Author Comment

by:jasguild
Comment Utility
I checked the sample rate and manufacturer's insturcitons with no luck.  I am not what sure what else to do.  I reinstalled the software that came with the sound card and tried differnet combinations of the options with no luck.  

jasguild
0
 
LVL 31

Expert Comment

by:Frosty555
Comment Utility
That's strange. I'm all out of ideas on this one. Perhaps there is something wrong with your motherboard?
0
 

Author Closing Comment

by:jasguild
Comment Utility
Frosty, it turns out that the driver I got from the manufacturer (C-Media) didn't work, however I did a windows update and the driver from windows update WORKED.  I am not sure how to explain that.  I did notice however that the recording via SPDIF is slightly slower than the source.

Other than that it works fine now.  Thanks for your help

jas
0

Featured Post

Maximize Your Threat Intelligence Reporting

Reporting is one of the most important and least talked about aspects of a world-class threat intelligence program. Here’s how to do it right.

Join & Write a Comment

What do we know about Legacy Video Conferencing? - Full IT support needed! - Complicated systems at outrageous prices! - Intense training required! Highfive believes we need to embrace a new alternative.
Great sound, comfort and fit, excellent build quality, versatility, compatibility. These are just some of the many reasons for choosing a headset from Sennheiser.
The viewer will learn how to successfully create a multiboot device using the SARDU utility on Windows 7. Start the SARDU utility: Change the image directory to wherever you store your ISOs, this will prevent you from having 2 copies of an ISO wit…
The viewer will learn how to successfully download and install the SARDU utility on Windows 8, without downloading adware.

771 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

15 Experts available now in Live!

Get 1:1 Help Now