Solved

SP_autostats is "ON" but Last updated column is three months old

Posted on 2008-10-14
1
502 Views
Last Modified: 2008-10-29
Hi Experts,
I ran Exec SP_autostats Employee... the AUTOSTATS cloumn is "ON" for all indexes, but the last update shows Jul (more than three months ago)

Can someone explain what is missing here?
0
Comment
Question by:sir-rob
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 
LVL 37

Accepted Solution

by:
momi_sabag earned 500 total points
ID: 22718572
even with autostats, statisitcs are collected only when some thresholds are being met
if your table hasn't been updated much in the last 3 months, it is possible that the statistics that were calculated 3 months ago are still relevant and that is why sql server didn't update them
0

Featured Post

MS Dynamics Made Instantly Simpler

Make Your Microsoft Dynamics Investment Count  & Drastically Decrease Training Time by Providing Intuitive Step-By-Step WalkThru Tutorials.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

If you having speed problem in loading SQL Server Management Studio, try to uncheck these options in your internet browser (IE -> Internet Options / Advanced / Security):    . Check for publisher's certificate revocation    . Check for server ce…
In this article we will get to know that how can we recover deleted data if it happens accidently. We really can recover deleted rows if we know the time when data is deleted by using the transaction log.

734 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question