2003 std doesn't start up - ntoskrnl.exe missing or corrupt?! BIG PROBLEMS

Posted on 2008-10-14
Last Modified: 2012-05-05
We have a utility server that runs Symantec, Backup Exec, Blackberry Enterprise server, etc. for the entire domain.

I tried to log into it today to check up on the backups, Symantec, etc. to make sure it was all functioning properly.  I usually remote into it via remote desktop.  I noticed that it wasn't responding (when i clicked 'connect' it would just double back to the 'remote desktop' screen).  Note that at this point, Blackberry Enterprise server, as well as the other services, were, to my knowledge, still responding and functioning.

I logged into the console, and noticed all the icons I had on the desktop were gone, and the program files folders in the start menu were empty for the most part.  

So, like any Windows user, i decided to reboot, to probably fix the problem :)

Well it didn't come back up... The error is "windows could not start because the following file is missing or corrupt: ntoskrnl.exe"

I've tried booting into the recovery console, and doing a fixmbr, fixboot, even tried copying the file (didn't work for some reason).

One thing that's strange, is the first time I went into the recovery console, the drive letter for the windows installation was "I" (which is wrong, because it should have been C).  The next time i went into it, it was "J"...

Also, doing a "bootcfg" or "bootcfg /add" command doesn't work... it says it can't find any windows installations.

The whole thing's making no sense whatsoever, but i need that server back online.  I've done a lot of research on yahoo, and tried about every solution out there.  Anyone have any ideas?!

Thanks - 500 points for whoever fixes this, AND IF NECESSARY, WE WILL PAY FOR YOUR SERVICES IN CASH - just need this fixed ASAP.
Question by:Mystical_Ice
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 4
  • 4
LVL 38

Expert Comment

ID: 22716771
It appears like your Boot.ini file is messed up:

You will need to edit the boot directory back to C:\ instead of I:\

You may also consider going into BIOS, By pressing F2 when you boot the machine and changing the Boot order or Bott sequence to your DVD drive first and then your Hard drive second. As a note, there are selections to use Network booting, (like the I:\ drive) and you may not want to network boot.

Author Comment

ID: 22716955
but what doesn't make sense to me, is why does the recovery console find: "I:\Windows" (or J:\Windows), and i can browse through the windows directory, and everything checks out, yet bootcfg finds nothing.
shouldn't "fixboot" fix the boot.ini file?

also i'm still worried about the missing programs and icons in windows before i tried rebooting it.

i'll try your solution later tonight, thanks!

Author Comment

ID: 22716970
also i should note that the only way i know how to edit the boot.ini file from the recovery console is with "bootcfg", and that command (as well as "bootcfg /add") did not work.
The Ultimate Checklist to Optimize Your Website

Websites are getting bigger and complicated by the day. Video, images, custom fonts are all great for showcasing your product/service. But the price to pay in terms of reduced page load times and ultimately, decreased sales, can lead to some difficult decisions about what to cut.

LVL 38

Expert Comment

ID: 22717229
Well, I am just amazed this is trying to go to the I:\ Drive or J:\ Drive to find the OS. I was thinking the BIOS may be trying to find the OS via a NETWORK BOOT. Maybe the boot sequence was a bit out of order.

Below is a copy of a Boot.ini that doesn't exactly determine the location of the boot drive.

To view or edit the Boot.ini:

First, the BOOT.INI file is usually set Read-only. To edit the boot.ini in recovery console you can type edit boot.ini. However, you have to change the attributes to the file prior to editting:

attrib -r -s -h C:\boot.ini

Once done, type "edit boot.ini" at the C:\ prompt

You may wish to print out another 2003 server's boot.ini in order to use as a reference.

Now that I look at my own boot.ini, I am thinking it is your BIOS is pointing to the wrong drive for boot sequence. Here is my boot.ini that simply doesn't say anything about the C:\ drive.
[boot loader]
[operating systems]
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /fastdetect /usepmtimer /pae /NoExecute=OptIn
LVL 38

Expert Comment

ID: 22717250
With that said:

The bios talks to the drives and also lists the sequence that they boot in.

The Boot.ini detects the OS and tries to load it.

So, if bios has (network boot) enabled and Boot.ini sees the OS. It can try to load from the I:\ drive or J:\ drive instead of the C:\ drive

Author Comment

ID: 22722377
there is no "edit" in the recovery console, and the attrib command didn't work
LVL 38

Expert Comment

ID: 22723844

attrib -r -s -h boot.ini     ((leave out the C:\))

Then, get a copy of the boot.ini from another machine onto a CD or other media the server supports. Rename the old boot.ini to boot.old. Now, copy D:\boot.ini  C:\ .  That should copy the boot.ini from the CD drive to the the C:\ drive root directory.

Restart computer.

Like I said. I still think this is a BIOS boot sequence. Can you tell me what the boot sequence is?

If the boot sequence is correct and we can't fix the boot.ini, we may have to resort to a repair installation.


Accepted Solution

Mystical_Ice earned 0 total points
ID: 22998034
Solution was to recreate the array and reinstall.  Bad array

Featured Post

Salesforce Has Never Been Easier

Improve and reinforce salesforce training & adoption using WalkMe's digital adoption platform. Start saving on costly employee training by creating fast intuitive Walk-Thrus for Salesforce. Claim your Free Account Now

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Setting up a Microsoft WSUS update system is free relatively speaking if you have hard disk space and processor capacity.   However, WSUS can be a blessing and a curse. For example, there is nothing worse than approving updates and they just have…
While rebooting windows server 2003 server , it's showing "active directory rebuilding indices please wait" at startup. It took a little while for this process to complete and once we logged on not all the services were started so another reboot is …
In this video, viewers will be given step by step instructions on adjusting mouse, pointer and cursor visibility in Microsoft Windows 10. The video seeks to educate those who are struggling with the new Windows 10 Graphical User Interface. Change Cu…
In this video, viewers are given an introduction to using the Windows 10 Snipping Tool, how to quickly locate it when it's needed and also how make it always available with a single click of a mouse button, by pinning it to the Desktop Task Bar. Int…

688 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question