?
Solved

DDE waiting for Excel command in Word merge

Posted on 2008-10-14
3
Medium Priority
?
1,348 Views
Last Modified: 2012-08-13
The PC owner regularly opens up a MS Word document that has a Excel spreadsheet merged to it.  All of a sudden it now gets an error message "Waiting for Microsoft Excel to accept DDE Commands".

We renamed the xls file xxxxOLD and pasted a backup of the file to the directory but got the same error message.

By the way, the backup file had not been updated for several months.  The DDE error message originates from a Word file just a few days old.

Any ideas?
0
Comment
Question by:michealbeethoven
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 2
3 Comments
 
LVL 10

Accepted Solution

by:
pkhari earned 2000 total points
ID: 22717620
Try this:

If in Office 2007: Go to->File (Office button)->Excel Options->Advanced->General section, and check the box on "Ignore other applications that use Dynamic Data Exchange (DDE)".

If in 2003, this option comes under Tools->Options->General->Settings section->Ignore other applications

Hope this helps.

Cheers
P.K.
0
 
LVL 10

Assisted Solution

by:pkhari
pkhari earned 2000 total points
ID: 22717681
Ok, I should have told you this - just do the reverse if your box is already ticked - meaning clear the check box.

Second option is to activate the conversion option in Word file. Under Tools->Options in 2003. (In 2007, it is under Office button->Word Options->Advanced->General section->Confirm file format conversion on open). Once you do this and save and reopen the file, you should be able to try various opions like using either DDE or ODBC. Try either one and see which one works for your situaion.

The last one I can think of is to relink the source data - achieved by renaming the current excel data source and when reopening Word, you will get an error saying data source not found. You can now select the new file and try moving ahead.

Hope this helps.

Cheers
P.K.

Some links for you:
http://www.wincert.net/forum/index.php?showtopic=2322
http://groups-beta.google.com/group/microsoft.public.word.mailmerge.fields/browse_frm/thread/f1578328b1e5bf9d/d6437ab462b6914e?lnk=st&q=Waiting+for+microsoft+excel+to+accept+dde+command&rnum=6&hl=en#d6437ab462b6914e
0
 

Author Closing Comment

by:michealbeethoven
ID: 31506165
Hello pkhari:

Thanks for the help, but, ultimately, the only solution was to uninstall/install MS Office.  I awarded you points for participation.
0

Featured Post

Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

It’s been over a month into 2017, and there is already a sophisticated Gmail phishing email making it rounds. New techniques and tactics, have given hackers a way to authentically impersonate your contacts.How it Works The attack works by targeti…
Ever visit a website where you spotted a really cool looking Font, yet couldn't figure out which font family it belonged to, or how to get a copy of it for your own use? This article explains the process of doing exactly that, as well as showing how…
This Micro Tutorial demonstrates using Microsoft Excel pivot tables, how to reverse engineer competitors' marketing strategies through backlinks.
This Micro Tutorial will demonstrate how to use longer labels with horizontal bar charts instead of the vertical column chart.

764 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question