Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 1154
  • Last Modified:

WordPress Spell Check Error

We have some clients who use WordPress, and one of them wants to make use of the Spell Check feature.  Unfortunately when trying to use this feature, we get the following error message.

**********
Error response: <br />
<b>Warning</b>: fsockopen() [<a href='function.fsockopen'>function.fsockopen</a>]: unable to connect to ssl://www.google.com:443 (Unable to find the socket transport &quot;ssl&quot; - did you forget to enable it when you configured PHP?) in <b>/home/username/public_html/test/wp-includes/js/tinymce/plugins/spellchecker/classes/GoogleSpell.php</b> on line <b>85</b><br /> Could not open SSL connection to google.{"id":null,"result":[],"error":null}
**********

At first, the information I found pointed to the fact that I did not have the pspell module enabled within PHP.  I have since enabled it within PHP, recompiled, but still no go.
0
sanderrob
Asked:
sanderrob
  • 2
1 Solution
 
GUEENCommented:
IIS or Linux?

If Linux you need to have CURL and SSL.  If for IIS - I haven't a clue!
0
 
sanderrobAuthor Commented:
Aha!  I hadn't enabled OpenSSL for PHP5.

Thanks a lot.
0
 
GUEENCommented:
Glad it worked!
Cheers,
/Shek
0

Featured Post

Who's Defending Your Organization from Threats?

Protecting against advanced threats requires an IT dream team – a well-oiled machine of people and solutions working together to defend your organization. Download our resource kit today to learn more about the tools you need to build you IT Dream Team!

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now