Solved

IntelliSense Doesn't Appear - VS2005

Posted on 2008-10-15
7
383 Views
Last Modified: 2013-11-26
For some reason IntelliSense has stopped appearing in Visual Studio 2005 (C# development), how can I get it back?

The following is the options for IntelliSense that are checked options:
Show Completion list after a character is typed
(disabled but checked)
      Place keywords in completion lists
      Place code snippets in completion lists

Selection In Completion List
Committed by typed the following characters:
{}[]().,:;+-*/%&|^!~=<>?@#'"\
Committed by pressing the space bar
IntelliSense pre-selects most recently used members
0
Comment
Question by:angus_young_acdc
  • 5
7 Comments
 
LVL 53

Accepted Solution

by:
Dhaest earned 300 total points
ID: 22718932
Can you check the following

from your Visual studio IDE click on tools->option menu
in options dialog, Select Text Editor->All Languages->General.
on the right side you will get options in statement completion,
check all the options and do the same in Basic->General options too. click ok now you should get the statement completion options
0
 
LVL 15

Author Comment

by:angus_young_acdc
ID: 22718955
I have had a look at that as per your post, the only options not ticked there are:
Enable virtual space
Word wrap
Line numbers

Do they need to be ticked?  As I still can't get anything to come up when I press . or other keys
0
 
LVL 16

Assisted Solution

by:ororiole
ororiole earned 200 total points
ID: 22719095
I've had this happen. I shut down Visual studio, reboot, restart Visual studio and intellisense comes back.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 
LVL 15

Author Comment

by:angus_young_acdc
ID: 22719109
Reboot my machine you mean?  I will give it a try.
0
 
LVL 15

Author Comment

by:angus_young_acdc
ID: 22719295
That still hasn't worked, it still won't appear.  
0
 
LVL 15

Author Comment

by:angus_young_acdc
ID: 22719365
I have went into Options -> Text Editor -> C# and selected the Auto list members option.  That seems to have sorted my problem for myself.
0
 
LVL 15

Author Closing Comment

by:angus_young_acdc
ID: 31506224
Issuing points, although I solved it myself.  Thanks anyway guys
0

Featured Post

Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

This article is for Object-Oriented Programming (OOP) beginners. An Interface contains declarations of events, indexers, methods and/or properties. Any class which implements the Interface should provide the concrete implementation for each Inter…
Performance in games development is paramount: every microsecond counts to be able to do everything in less than 33ms (aiming at 16ms). C# foreach statement is one of the worst performance killers, and here I explain why.

749 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question