Solved

Serving .EXE files on an IIS 6.0 Web Server, ClickOnce

Posted on 2008-10-15
1
1,357 Views
Last Modified: 2013-12-17
I just wanted to know, I'm already using the "Use, .deploy file extension" option on my project settings and by default I did add in the .deploy type as mentioned in the MSDN webby.

After doing this I still find the ClickOnce deployment path in VS 2005 still generates a setup.exe file. The very file i need serving by the IIS. in the past the IIS was already set up for me but recently it has been rebuilt so I'm learning and picking up the pieces as I go along.

My Deployment uploads quite a few .exe files namely pre requisites and in VS 2005 i find myself with Warnings in the Error List window. Saying ...

"Warning      1      Could not download 'setup.exe' from http://10.*.*8.8*/M...and_T._2/.            1      1      ...ce"

I never seen these before But it was 15+ before I added in the .deploy mime type onto my IIS WS.

Any ideas ... any one got a wiki or something that i could follow that shows you to fully set-up an IIS WS ready to recieve ClickOnce deployments?

Thanks,
Ibrar
0
Comment
Question by:iamumtaz
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
1 Comment
 

Accepted Solution

by:
iamumtaz earned 0 total points
ID: 22720001
I managed to get it to work by adding the mime types on the default website virtual directory and then removing them from all other places I had them.

I added in mime types for the  .application, .deploy and .manifest as said in the MSDN libraries.

Then I ran 'Check Server Extensions' and got the tool to fix any problems it find such as folder not marked as executable and no private folder.

I lowered the permissions on the deployed application, down to none and the app pool to default app pool.

Turned the IIS off (STOP).

Re-checked to make sure the MIME types are still in place.

Deleted any existing deployments made and but kept any automatically generated hidden folders (_vti_bin, _private, _vti_cnf, _vti_pvt, _vti_script and _vti_txt).

Turned the IIS on (START).

In VS 2005, re published the deployments to find no errors or warning to my target server.

Just getting some testers to feed back to me and let me know how they get on but I reckon its all working now. Any comments or accepted solutions then please reply. I will choose the best solution that matches.
0

Featured Post

Back Up Your Microsoft Windows Server®

Back up all your Microsoft Windows Server – on-premises, in remote locations, in private and hybrid clouds. Your entire Windows Server will be backed up in one easy step with patented, block-level disk imaging. We achieve RTOs (recovery time objectives) as low as 15 seconds.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Suggested Solutions

Title # Comments Views Activity
VB/ASP.Net "Value of type 'Date' cannot be converted to 'Integer'" 12 58
Problem to Office 1 65
Customising IE behaviour on certain pages 2 96
Services disabled 1 21
A long time ago (May 2011), I have written an article showing you how to create a DLL using Visual Studio 2005 to be hosted in SQL Server 2005. That was valid at that time and it is still valid if you are still using these versions. You can still re…
If you are a web developer, you would be aware of the <iframe> tag in HTML. The <iframe> stands for inline frame and is used to embed another document within the current HTML document. The embedded document could be even another website.
THe viewer will learn how to use NetBeans IDE 8.0 for Windows to perform CRUD operations on a MySql database.
The viewer will learn how to use and create new code templates in NetBeans IDE 8.0 for Windows.

738 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question