Solved

iPhone integration with Exchange 2003 SP2 and OWA

Posted on 2008-10-15
13
3,576 Views
Last Modified: 2012-06-21
I am trying to integrate the 3G iPhones with Exchange 2003 SP2 and have hit a brick wall. We currently use Blackberry devices and have a dedicated BES server for this, these work fine and have done for years.

We are also using OWA which is sitting behind a Windows ISA 2006 appliance. This has been in place for 2 years and also works fine. Anyone accessing the published OWA URL (https://owa.domain.com/exchange) is advised that "This certificate cannot be verified up to a trusted certification Authority" however clicking on continue when in Internet Explorer does take the user to the logon screen where they are able to login and send/read e-mails via OWA. This has always been the case and we are happy with this as there is only a very small number of users allowed this kind of access. I am assuming this is a self signed certificate?

I have read so many different document guides regarding implement iPhones and I've gone around in circles. Some mentioned using IMAP, some POP3. My understanding is that the 3G handsets (with v2.0) do not have to use POP3 or IMAP. Is this correct?

When I am trying to configure my iPhone where should I point the Server settings to from within the Exchange Mail setup on the iPhone? Is it owa.mydomain.com/exchange?

Here is a run down of what I have done so far.

Enabled "Exchange Outlook Mobile Access" from within Mobile Services on our Back-end Exchange Server and also ticked "Enable unsupported devices".

Installed Mobile ActiSync on the Backend Exchange Server and IIS now shows a few new websites within the Default Website

Installed the iPhone Configuration Web Utility on my laptop

Exported the cert.pfx and installed manually on a laptop

Where exactly am I going wrong?  Have I missed something obvious?

Thank you
0
Comment
Question by:MLShelp
  • 8
  • 5
13 Comments
 

Expert Comment

by:vconstantinou
ID: 22719676
Hi mate

No on the iphone dont put owa.mydomain.com/exchange  just put under server owa.mydomain.com

Have you tried that
0
 

Author Comment

by:MLShelp
ID: 22719745
Thanks,

When I start the create Exchange Mail wizard I enter all my details (e-mail address, domain name, username, password etc.) and when I click on Next the following security warning appears:

"Unable to verify Certificate
While automatically discovering account settings the certificate from domain.com could not be verified".

I click on Accept and enter my server as owa.domain.com and then the wizard continues and I can select the settings I want to synchronise and click on Save. When I try and access the Exchange account though I receive the "Cannot Get Mail The connection to the Server failed" message.
0
 

Expert Comment

by:vconstantinou
ID: 22719767
have you Got SP2 on both your Backend exchange server and Frontend exchange servers
0
Space-Age Communications Transitions to DevOps

ViaSat, a global provider of satellite and wireless communications, securely connects businesses, governments, and organizations to the Internet. Learn how ViaSat’s Network Solutions Engineer, drove the transition from a traditional network support to a DevOps-centric model.

 

Author Comment

by:MLShelp
ID: 22719854
We have Service Pack 2 for Exchange installed on our backend Server. We have an ISA 2006 server setting in our DMZ acting as the go between for owa requests.
0
 

Author Comment

by:MLShelp
ID: 22721206
I've been trying to check a few things and when I try and access http://MSEXserver/oma I am presented with a login box asking for username and password.  I enter my domain crendentials and then receive an error "A System error has occurred while processing your request. Please try again. If the problem persists, contact your administrator" The Exchange Server event logs show and Event ID of 1503 which hints towards http://support.microsoft.com/?kbid=817379.

I turned the SSL requirment off on the Exchange directory on the Exchange Server and the iPhone could then collect and send e-mails. Once I turned the SSL requirment  back on again the ability to send and receive stopped. With the SSL requirment turn off I was able to view http://msexserver/OMA I can now see the OMA layout and read e-mails.
0
 

Expert Comment

by:vconstantinou
ID: 22721269
have you opened port 443 (SSL) port on your firewall that points to the ISA server in the DMZ

In IIS too have you entered the 443 port number under SSL
0
 

Author Comment

by:MLShelp
ID: 22721666
443 is already open for OWA and it already shows in IIS as well.

I am going to follow the instructions in http://support.microsoft.com/?kbid=817379 and will report back.

Darren
0
 

Author Comment

by:MLShelp
ID: 22729101
After I made the changes I can now connect the OWA from the iphone but it's not working as I expected. It's pulling e-mail from the Exchange Server as apposed to pushing e-mail at the iPhone. The iPhones have got the Push mail option selected in the Mail accounts but e-mail will not come through unless I perform a manual Sync.
0
 

Accepted Solution

by:
MLShelp earned 0 total points
ID: 22729862
I found this support advice from Apple http://support.apple.com/kb/TS1868

1. The web listener timeout on our ISA2006  appliance has been increased from 1800sec to 3540sec (59 minutes) and stopped and started IIS
2. Internal and External DNS both point to our ISA2006 appliance
3. Those are the changes I made this morning
4. There were POP3 accounts on the phones but I have removed these now and the problem remains.
0
 

Expert Comment

by:vconstantinou
ID: 22729886
I know its very obvious, but im going to ask anyway.

On the Iphone  Settings\ Fetch New Data\Fetch  It has timers there get email on 15/30/60 mins or manual.

Maybe try setting it to manual , save it... then change it back to 15 mins.

I thought i would ask...
0
 

Author Comment

by:MLShelp
ID: 22730015
One both the iPhones on my desk I have them both Push - On. I set both phones to manual Fetch, saved and then change back to Push again but the e-mails do not automatically deliver.
0
 

Author Comment

by:MLShelp
ID: 22739475
About 6 hours after I made the changes listed at http://support.apple.com/kb/TS1868 the Exchange server has just started pushing mails straight to the iPhones. I'm assuming that it takes hours for the changes I made to take effect

Closed
0
 

Expert Comment

by:vconstantinou
ID: 22739505
Cool...

Usually its instant...  maybe a reboot would have made it kick in alot quicker...

Glad its working now.
0

Featured Post

Free Tool: Postgres Monitoring System

A PHP and Perl based system to collect and display usage statistics from PostgreSQL databases.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

Smartwatches: just a fashion accessory or a useful device for all? The Apple Watch (http://www.apple.com/watch/) was launched in April of 2015 and has become a new way for iPhone users to stay connected. Ranging from $349 to $17,000, the Apple Watch…
There is a security feature on iOS devices that is nearly impenetrable when it has been activated.  This article will provide some possible solutions as well as necessary steps to take to ensure you do not end up with a locked device.
This video demonstrates how to sync Microsoft Exchange Public Folders with smartphones using CodeTwo Exchange Sync and Exchange ActiveSync. To learn more about CodeTwo Exchange Sync and download the free trial, go to: http://www.codetwo.com/excha…
CodeTwo Sync for iCloud (http://www.codetwo.com/sync-for-icloud?sts=6554) automatically synchronizes your Outlook 2016, 2013, 2010 or 2007 folders with iCloud folders available via iCloud Control Panel. This lets you automatically sync them with…

830 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question