Solved

Router config question on point to point setup

Posted on 2008-10-15
18
525 Views
Last Modified: 2013-11-05
Hi we have a new T1 Point to point setup with Cisco 1841s on each end, I can ping from one side to the other via the desktops/servers but when I try to ping from the router on my side to anything on the other routers network it will not ping, email, file transfers and other network functions seem to work great other than any type of SQL connections it can take 10 mins to make SQL connections the following is the setup on the router on my end


Current configuration : 1160 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
!
boot-start-marker
boot-end-marker
!
no aaa new-model
ip cef
!
!
!
!!
!
!
!
interface FastEthernet0/0
 ip address 192.168.201.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 description $ES_LAN$
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface Serial0/0/0
 ip address 172.*.*.1  255.255.255.252
 service-module t1 timeslots 1-24
!
interface Serial0/1/0
 no ip address
 shutdown
!
router rip
 network 192.168.201.0
 network 192.168.204.0
 network 192.168.205.0
 no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.*.*.1
ip route 192.168.204.0 255.255.255.0 192.168.205.1
ip route 192.168.205.0 255.255.255.0 172.*.*.2
!
ip http server
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login local
line vty 5 15
 login
 transport input all
!
scheduler allocate 20000 1000
end
0
Comment
Question by:dougr37
  • 7
  • 6
  • 3
  • +2
18 Comments
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22720439
What is the clients default gateway on each end of the T1?  The 1841 or a local Firewall for Internet access?
0
 

Author Comment

by:dougr37
ID: 22720502
On my side the Kentucky side my default gateway is 192.168.201.1 the default gateway in Salem is 192.168.205.1
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22720527
On the Salem side, is 192.168.205.1 the LAN interface of the 1841? or a different device?
0
 

Author Comment

by:dougr37
ID: 22720558
yes my side gateway 192.168.201.1 is my 1841 and the salem side 192.168.205.1 is the 1841 on their side.
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22720616
That is interesting, you say you can't ping from your router to the 192.168.205.x hosts?  You should be able to as long as the gateways are the 1841's.

Where does the 192.168.204.x subnet come into play?  Is that part of the equation?
0
 
LVL 3

Expert Comment

by:NetAdminGuy
ID: 22720670
The routers I'm sure connect to a switch...we experienced this type issue when there was a speed/duplex mismatch between the router switch or the switch server.  The fact that any traffic is being passed may indicate the issue may not be on the routers.  Something else may be breaking the transmissions.
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22720679
Can you ping 192.168.201.1 from the Kentucky router?
0
 

Author Comment

by:dougr37
ID: 22720690
The .204 subnet is another network on the Salem end of the T1
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22720705
Is that the subnet you can't ping from your router?

Add a route for it and remove the invalid route:

no ip route 192.168.204.0 255.255.255.0 192.168.205.1
ip route 192.168.204.0 255.255.255.0 172.*.*.2
0
Find Ransomware Secrets With All-Source Analysis

Ransomware has become a major concern for organizations; its prevalence has grown due to past successes achieved by threat actors. While each ransomware variant is different, we’ve seen some common tactics and trends used among the authors of the malware.

 

Author Comment

by:dougr37
ID: 22720724
Yes I can ping the 192.168.201.1 and the 192.168.205.1 from either router
0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22720792
Couple things:

1) The static route statement "ip route 192.168.204.0 255.255.255.0 192.168.205.1" is incorrect. It should (probably) be "ip route 192.168.204.0 255.255.255.0 172.x.x.2"

2) There's no need to mask inside private addresses. Nobody can access them anyway, especially on a point-to-point T1 link.

3) You've got RIP and static routes. Can you post the routing table for both routers.
0
 

Author Comment

by:dougr37
ID: 22720931
Ky side
East-Bernstadt#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 172.*.*.2 to network 0.0.0.0

     172.30.0.0/30 is subnetted, 1 subnets
C       172.30.1.0 is directly connected, Serial0/0/0
C    192.168.201.0/24 is directly connected, FastEthernet0/0
S    192.168.204.0/24 [1/0] via 192.168.205.1
S    192.168.205.0/24 [1/0] via 172.30.1.2
S*   0.0.0.0/0 [1/0] via 172.*.*.2

Salem Side
Salem#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter

area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type

2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS

level-2
       ia - IS-IS inter area, * - candidate default, U - per-user

static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.205.101 to network 0.0.0.0

     172.*.*0/30 is subnetted, 1 subnets
C       172.*.*.0 is directly connected, Serial0/0/0
S    192.168.201.0/24 [1/0] via 172.*.*.1
S    192.168.204.0/24 [1/0] via 192.168.205.101
C    192.168.205.0/24 is directly connected, FastEthernet0/0
R    192.168.206.0/24 [120/1] via 192.168.205.101, 00:00:25,

FastEthernet0/0
S*   0.0.0.0/0 [1/0] via 192.168.205.101

0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22720989
So, what exactly is the problem?  From what to what doesn't work?

Since you are running RIP and you have more subnets than first let on, fix the RIP config on the 1841's:

router rip
network 172.x.x.x  <--the serial subnet

Also, make sure you remove this route:

no ip route 192.168.204.0 255.255.255.0 192.168.205.1




0
 
LVL 50

Expert Comment

by:Don Johnston
ID: 22721033
Can the 192.168.205.0 PC's ping the 172.30.1.1 address?
 
 If they can and the Kentucky router can't ping them back, then it's probably the firewall on the PC's blocking ICMP requests.
0
 

Author Comment

by:dougr37
ID: 22721084
The only real issue is any connections to our SQL server on the 192.168.205.* network takes about 10 mins to connect, and can't ping from the Ky router to andy Salem Hosts
0
 
LVL 43

Expert Comment

by:JFrederick29
ID: 22721125
For the SQL slowness, I assume this slowness isn't present on the 192.168.205.x subnet, right?  I would double check speed/duplex settings on the router and switch ports on the Kentucky side.  What is the bandwidth utilization on the T1 when SQL is slow?
0
 

Author Comment

by:dougr37
ID: 22721232
No SQL is fine on the Salem end the 192.168.205.*  all the switches are running full duplex gig copper, the routers are set to auto speed auto duplex, will have to check on the utilization, and thanks to everyone for all the help.
0
 
LVL 4

Accepted Solution

by:
ckozloski earned 500 total points
ID: 22721327
Actually,
with your default route set to 172.x.x.1
You shouldn't even need this routes at all:
ip route 192.168.205.0 255.255.255.0 172.*.*.2

What I am unclear about is this route:
ip route 192.168.204.0 255.255.255.0 192.168.205.1
What is the 192.168.205 network?

Here's how I see it laid out and correct me if im wrong:
Sub A<-->192.168.201.1 <--> 172.x.x.1/30 <-->172.x.x.2/30 <-->192.168.204.1 <--> Sub B
Subnet A's gateway is 192.168.201.1 and Subnet B's gateway is 192.168.204.1 and the subnet the routers communication on is 172.x.x.0/30
If this is the case you will need a route statement on either side that points each of the subnets to the tunnel such as this:
For Subnet A's Router add this route statement:
ip route 192.168.204.0 255.255.255.0 172.x.x.2 (This will force any traffic on Subnet A  destined for subnet B across the router.
For Subnet B's Router add this route statement:
ip route 192.168.201.0 255.255.255.0 172.x.x.1 (This will force traffic on Subnet B that is desitned for Subnet A to push across the router)
Once the router on the other side sees that it belongs to its subnet, it should know how to handle it at that point.
You could also setup a loopback interface on each of the routers and configure OSPF to handle all your subnet routing for you.
Hope this helps.
0

Featured Post

How to improve team productivity

Quip adds documents, spreadsheets, and tasklists to your Slack experience
- Elevate ideas to Quip docs
- Share Quip docs in Slack
- Get notified of changes to your docs
- Available on iOS/Android/Desktop/Web
- Online/Offline

Join & Write a Comment

Suggested Solutions

Title # Comments Views Activity
OSPF Routing Problems 9 64
Enterasys QoS setup 2 34
Transfer IOS from server to router via tftp 3 19
VLAN question 7 45
We've been using the Cisco/Linksys RV042 for years as: - an internet Gateway - a site-to-site VPN device - a leased line site-to-site subnet-to-subnet interface (And, here I'm assuming that any RV0xx behaves the same way as an RV042.  So that's …
Quality of Service (QoS) options are nearly endless when it comes to networks today. This article is merely one example of how it can be handled in a hub-n-spoke design using a 3-tier configuration.
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…
After creating this article (http://www.experts-exchange.com/articles/23699/Setup-Mikrotik-routers-with-OSPF.html), I decided to make a video (no audio) to show you how to configure the routers and run some trace routes and pings between the 7 sites…

759 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question

Need Help in Real-Time?

Connect with top rated Experts

26 Experts available now in Live!

Get 1:1 Help Now